+ Antworten
Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 10 von 19
  1. #1
    Registriert seit
    Dec 2005
    Beiträge
    1,286

    Standard Com port und COMPort_SendText

    hallo und guten tag !

    leider musste ich mein ips system komlett neu aufsetzen und die scripts neu erstellen. (das übt!)
    soweit ist alles wieder in ordnung bis auf die verbindung per com1 zu meinem denon a/v receiver.

    der com-port ist als instanz eingerichtet und sagt auch "open".
    wenn ich aber z.b.

    COMPort_SendText(30637, "PWSTANDBY");
    COMPort_SendText(30637, chr(13));

    sende, passiert nix. eigentlich sollte er auf standby schalten.
    was mach ich falsch ?

    danke, frank

  2. #2
    Registriert seit
    Sep 2005
    Ort
    Stade
    Beiträge
    6,613

    Hast du die Parameter der Comverbindung überprüft?

    Parität, Stopbits, Übertragungsrate... die müssen alle genau stimmen. Welche dein denon braucht müsste in der Bedienungsanleitung stehen.


    Toni

  3. #3
    Registriert seit
    Dec 2005
    Beiträge
    1,286

    hab ich geprüft ...

    anleitung sagt:
    communication system: tone step synchronisation
    communication speed: 9600bps
    character length: 8 bits
    parity control: none
    start bit: 1 bit
    stop bit: 1 bit
    communication procedure: non procedural
    communication data length: 135 bytex max.

    und so habe ich ips eingestellt:
    - just foreward
    - COM1
    - baud rate 9600
    - data bits 8
    - stop bits 1
    - parity none
    - flow control hardware
    - und open ist grün

  4. #4
    Registriert seit
    Sep 2005
    Ort
    Stade
    Beiträge
    6,613

    ist deine InstanzID denn auch wirklich die 30637 oder hast du das aus dem alten script gerettet?

    Haste mal nen anderen Befehl getestet?

  5. #5
    Registriert seit
    Dec 2005
    Beiträge
    1,286

    instanz id habe ich neu gesetzt. das passt. andere befehle habe ich auch probiert ... und auch den com-port in beide richtungen verbunden ...

    komische sache

  6. #6
    Registriert seit
    May 2005
    Beiträge
    2,278

    communication procedure: non procedural
    probiere doch mal, in den Com-Settings flow control=none einzustellen

    HTH
    Tommi

  7. #7
    Registriert seit
    Dec 2005
    Beiträge
    1,286

    jau ! das war es ! jubel hurra !

    vielen dank für eure hilfe :-) und einen schönen abend,

    frank <- happy !

  8. #8
    Registriert seit
    Jan 2009
    Beiträge
    43

    Hallo,

    ich würde auch gerne meinen Denon AVR-2805 mit IPS steuern. Hat jemand eine Idee?? Ich habe es mit "Comport-Sendtext" versucht, es passiert aber nichts... Ich habe den Receiver über ein "gerades" Kabel mit dem COM1 - Anschluß verbunden.

    Der Receiver hat einen RS232C Anschluß und ist nach der Bedienungsanleitung geeignet, um in Mediensteuerungen (AMX oder Creston) integriert werden zu können.

    Kann mir jemand weiterhelfen???

    Gruß
    Johannes

  9. #9
    Registriert seit
    Mar 2006
    Beiträge
    3,422

    Uuuups, der thread stammt aus 2006!
    Seither ist schon einiges Wasser die Elbe hinunter geflossen
    Hast du mal nach "Denon" gesucht?
    Da gibt's schon "Neueres"
    Gruß nancilla

  10. #10
    Registriert seit
    Jan 2009
    Beiträge
    43

    Ich habe schon das ganze Forum durchwühlt, aber bekomme es einfach nicht hin! Kann mir jemand ne kleine Anleitung senden???

    Danke im Voraus!

    Gruß
    Johannes

Ähnliche Themen

  1. IIS und Apache auf Port 80
    Von hightower im Forum Allgemeine Diskussion
    Antworten: 11
    Letzter Beitrag: 21.02.06, 16:00
  2. 1-Wire COM Port Adapter an c't-COM-auf-LAN-Adapter
    Von babba im Forum 1-Wire, M-BUS
    Antworten: 9
    Letzter Beitrag: 31.12.05, 17:50
  3. USB Port bis 45m verlängern
    Von Keule im Forum Allgemeine Diskussion
    Antworten: 10
    Letzter Beitrag: 15.10.05, 21:04
  4. Com Port Configuration
    Von Crazy_Hardware im Forum Ideen & Anregungen
    Antworten: 1
    Letzter Beitrag: 13.05.05, 08:50