+ Antworten
Seite 1 von 3 1 2 3 LetzteLetzte
Ergebnis 1 bis 10 von 27
  1. #1
    Registriert seit
    Aug 2010
    Ort
    Österreich (Korneuburg)
    Beiträge
    4,313

    Standard Sammlung an Fehlern in Bezug zur IPSLibrary

    Jeder Post sollte folgende Dinge enthalten:
    • eine Beschreibung des Fehlers (Fehlermeldung oder fehlerhaftes Verhalten)
    • die Ursache (fehlerhafte Konfiguration oder ...)
    • eine kurze Beschreibung wie das Problem behoben wurde


    Fragen zu unbekannten Fehlern und Problemen bitte im jeweiligen Module Thread stellen!!
    Gruß
    Andreas

  2. #2
    Registriert seit
    Aug 2010
    Ort
    Österreich (Korneuburg)
    Beiträge
    4,313

    Standard Unbekanntes Module

    Fehlermeldung
    PHP-Code:
    IPSModuleManager-Log-IPSModuleManager    2012-02-10 15:58:00.79  Module Download Ini File doesnt exists -> Load Ini File "https://raw.github.com/brownson/IPSLibrary--Test-/master/IPSLibrary\install\DownloadListFiles\Logger_FileList.ini"
    IPSModuleManager-Log-IPSFileHandler      2012-02-10 15:58:00.79  Copy [url]https://raw.github.com/brownson/IPSLibrary--Test-/master/IPSLibrary/install/DownloadListFiles/Logger_FileList.ini[/url] --> C:\IP-Symcon\scripts\IPSLibrary\install\DownloadListFiles\Logger_FileList.ini

    Fatal error:  Uncaught exception 'IPSFileHandlerException' with message 'File C:\IP-Symcon\scripts\IPSLibrary\install\DownloadListFiles\Logger_FileList.ini could NOT be found on the Server !!!' in C:\IP-Symcon\scripts\IPSLibrary\install\IPSModuleManager\IPSFileHandler\IPSFileHandler.class.php:97
    Stack trace
    :
    #0 C:\IP-Symcon\scripts\IPSLibrary\install\IPSModuleManager\IPSFileHandler\IPSFileHandler.class.php(146): IPSFileHandler->CopyFile('https://raw.git...', 'C:\IP-Sy...')
    #1 C:\IP-Symcon\scripts\IPSLibrary\install\IPSModuleManager\IPSFileHandler\IPSFileHandler.class.php(160): IPSFileHandler->CopyFiles(Array, Array)
    #2 C:\IP-Symcon\scripts\IPSLibrary\install\IPSModuleManager\IPSModuleManager.class.php(243): IPSFileHandler->LoadFiles(Array, Array)
    #3 C:\IP-Symcon\scripts\BaseLoader.ips.php(11): IPSModuleManager->__construct('Logger')
    #4 C:\IP-Symcon\scripts\BaseLoader.ips.php(4): InstallModule('Logger')
    #5 {main} thrown in C:\IP-Symcon\scripts\IPSLibrary\install\IPSModuleManager\IPSFileHandler\IPSFileHandler.class.php on line 97
      
    Abort Processing during ErrorUncaught exception 'IPSFileHandlerException' with message 'File C:\IP-Symcon\scripts\IPSLibrary\install\DownloadListFiles\Logger_FileList.ini could NOT be found on the Server !!!' in C:\IP-Symcon\scripts\IPSLibrary\install\IPSModuleManager\IPSFileHandler\IPSFileHandler.class.php:97 
    Fehlerursache
    Das File https://raw.github.com/brownson/IPSL...r_FileList.ini wurde nicht gefunden.
    In diesem Fall war die Angabe des Modules nicht korrekt und das entsprechende DownloadList File wurde am Server nicht gefunden.


    Fehlerbehebung
    Korrektur des Modul Names
    Gruß
    Andreas

  3. #3
    Registriert seit
    Aug 2010
    Ort
    Österreich (Korneuburg)
    Beiträge
    4,313

    Standard Call to undefined method IPSModuleManager::GetModuleCategoryID()

    Fehlermeldung:
    Fatal error: Call to undefined method IPSModuleManager::GetModuleCategoryID() in C:\IP-Symcon\scripts\IPSLibrary\install\InstallationScri pts\IPSTwilight_Installation.ips.php on line 98
    Abort Processing during Error: Call to undefined method IPSModuleManager::GetModuleCategoryID()
    Error in Script C:\IP-Symcon\scripts\IPSLibrary\install\InstallationScri pts\IPSTwilight_Installation.ips.php on Line 98
    Fehlerursache:
    der IPSModuleManager befindet sich nicht mehr auf dem aktuellen Stand

    Fehlerbehebung:
    Update des IPSModuleManager's
    PHP-Code:
        IPSUtils_Include ("IPSModuleManager.class.php""IPSLibrary::install::IPSModuleManager");
        
    $moduleManager = new IPSModuleManager('IPSModuleManager''https://raw.github.com/brownson/IPSLibrary/master');
        
    $moduleManager->UpdateModule(); 
    Geändert von Brownson (07.04.12 um 08:08 Uhr) Grund: Repository hinzugefügt
    Gruß
    Andreas

  4. #4
    Registriert seit
    Aug 2010
    Ort
    Österreich (Korneuburg)
    Beiträge
    4,313

    Standard Versions Fehler

    Fehlermeldung:
    Fatal error: in [Program\IPSLibrary\install\IPSModuleManager\IPSVer sionHandler\IPSFileVersionHandler] on line 138
    Abort Processing during Error: Uncaught exception 'IPSVersionHandlerException' with message 'Versions Fehler:
    ================================================== ======================
    === Modul IPSModuleManager ist veraltet und benötigt ein Update
    === Aktuelle Version: 2.50.1..Loaded
    === Benötigte Version: 2.50.2
    ================================================== ======================
    ' in C:\ab\IPS\IP-Symcon\scripts\IPSLibrary\install\IPSModuleManager \IPSVersionHandler\IPSFileVersionHandler.class.php :138
    Stack trace:
    #0 C:\ab\IPS\IP-Symcon\scripts\IPSLibrary\install\InstallationScri pts\IPSTwilight_Installation.ips.php(66): IPSFileVersionHandler->CheckModuleVersion('IPSModuleManage...', '2.50.2')
    #1 C:\ab\IPS\IP-Symcon\scripts\IPSLibrary\install\IPSModuleManager \IPSModuleManager.class.php(674): include('C:\ab\IPS\IP-Sy...')
    #2 C:\ab\IPS\IP-Symcon\scripts\IPSLibrary_Installation.ips.php(4): IPSModuleManager->InstallModule()
    #3 {main}
    thrown
    Error in Script C:\ab\IPS\IP-Symcon\scripts\IPSLibrary\install\IPSModuleManager \IPSVersionHandler\IPSFileVersionHandler.class.php on Line 138
    Fehlerursache:
    ein benötigtes Module befindet sich NICHT mehr auf dem aktuellen Stand.

    In diesem Fall ist der IPSModuleManager in der Version 2.50.1 installiert, benötigt wird aber mindestens die Version 2.50.2

    Fehlerbehebung:
    Update des IPSModuleManager's
    PHP-Code:
        IPSUtils_Include ("IPSModuleManager.class.php""IPSLibrary::install::IPSModuleManager");
        
    $moduleManager = new IPSModuleManager('IPSModuleManager''https://raw.github.com/brownson/IPSLibrary/master');
        
    $moduleManager->UpdateModule(); 
    Geändert von Brownson (07.04.12 um 08:08 Uhr) Grund: Repository hinzugefügt
    Gruß
    Andreas

  5. #5
    Registriert seit
    Aug 2010
    Ort
    Österreich (Korneuburg)
    Beiträge
    4,313

    Standard Cannot redeclare IPSLogger_Fat ...

    Fehlermeldung:

    "Fatal error: Cannot redeclare IPSLogger_Fat() (previously declared in C:\IP-Symcon\scripts\IPSLogger.ips.php:5) in C:\IP-Symcon\scripts\IPSLibrary\app\core\IPSLogger\IPSLo gger.inc.php on line 124
    "
    Fehlerursache:

    Der IPSLogger ist bereits in einer älteren Version (ohne IPSLibrary) installiert und benötigt eine entsprechende Anpassung.

    Fehlerbehebung:

    Das File IPSLogger.ips.php im scripts Verzeichnis muss an die IPSLibrary angepasst werden:

    Kompletten Inhalt des Files mit folgendem Code ersetzen
    PHP-Code:
    <?
       IPSUtils_Include 
    ('IPSLogger.inc.php',      'IPSLibrary::app::core::IPSLogger');
    ?>
    Die restlichen IPSLogger_xxx Files im scripts Verzeichnis von IPS können gelöscht werden.

    Siehe auch IPSLibrary Migration...
    Gruß
    Andreas

  6. #6
    Registriert seit
    Feb 2009
    Ort
    Hanau, Germany
    Beiträge
    17

    Standard IPSLibrary unter Server 2012 - Installation bringt Fehlermeldung

    Hallo,

    ich versuche auf einem frisch installiertem IPS die IPSLibrary zu installieren. Step 0 der Anleitung ist nicht erforderlich, da Neuinstallation. Step 1: BaseLoader Script angelegt. Dieses Script führe ich aus und erhalte folgende Fehlermeldung:



    ************************************************

    Download of ModuleManager
    Load File https://raw.githubusercontent.com/br...taller.inc.php

    Fatal error: Uncaught exception 'Exception' with message 'Download of File https://raw.githubusercontent.com/br...taller.inc.php failed !!!' in C:\IP-Symcon\scripts\IPSLibrary_BaseLoader.ips.php:58
    Stack trace:
    #0 C:\IP-Symcon\scripts\IPSLibrary_BaseLoader.ips.php(30): LoadFile('https://raw.git...', 'C:\IP-Symcon\sc...')
    #1 C:\IP-Symcon\scripts\13626.ips.php(26): include('C:\IP-Symcon\sc...')
    #2 {main}
    thrown in C:\IP-Symcon\scripts\IPSLibrary_BaseLoader.ips.php on line 58

    ************************************************

    Ich habe schon vieles in dem Forum zu diesem Thema gelesen, komme aber nicht weiter. Nur ein Beitrag erwähnt, dass es Probleme unter Server 2012 R2 gibt. Ist das bestätigt? Dann würde ich weitere Versuche unterlassen, IPSLibrary auf Server 2012 R2 zu installieren.

    Grüße

    Mischka

    KNX TP und PN - Homematic - IPSVIEW

  7. #7
    Registriert seit
    Feb 2009
    Ort
    Hanau, Germany
    Beiträge
    17

    Standard Nach langem Suchen Fehler gefunden: GData Virenscanner

    Es wurden an einigen Stellen im Forum Fehlermeldungen gepostet, die identisch zu meiner waren. Es gab Hinweise auf Server 2012, was sich aber letztlich nicht bestätigte. Ich habe auf mehreren Kunden Installationen IPSLibrary testweise installiert und bin darauf gestoßen, dass der GData Virenscanner das Problem verursachte. Ich habe in meinem Fall das Verzeichnis C:\IP-SYMCON als Ausschluss definiert und schon hat die Installation funktioniert.

    Grüße

    Mischka

    KNX TP und PN - Homematic - IPSVIEW

  8. #8
    Registriert seit
    Apr 2012
    Ort
    Euskirchen
    Beiträge
    217

    Bei der neuesten 4.0 Beta erscheint "Invalid UTF-8 sequence" in den Konfigurations-Skripten der Deutschen IPSLibrary-Modulen (s. Threads im 4.0 Testbereich).

    Gruß aus EU,

    Jörg

  9. #9
    Registriert seit
    Aug 2011
    Ort
    Hannover
    Beiträge
    221

    Standard NetPlayer / Viso / IPS 4.0 Test

    Hallo,

    ich bekomme dort, wenn ich die Remote ins Webfront einbinden will, die folgende Fehlermeldung:

    PHP-Code:
    18.09.2015 14:44:51*| PHP*| ErrorNoticeUndefined indexHTTP_HOST
       Error in Script 
    /usr/share/symcon/webfront/user/NetPlayer/NetPlayer_Utils.php on Line 138
      134 in IPSLibrary
    /app/core/IPSLogger/IPSLogger.inc.php (call IPSLogger_Out)
       
    44 in IPSLibrary/app/core/IPSLogger/IPSLogger_PhpErrorHandler.inc.php (call IPSLogger_Err)
      
    138 in webfront/user/NetPlayer/NetPlayer_Utils.php (call IPSLogger_PhpErrorHandler)
       
    28 in webfront/user/NetPlayer/NetPlayer_MP3Control.php (call include_once) 
    Für mich ist das nicht ganz schlüssig, ob das nun ein IPS 4 oder ein Netplayer-Problem ist?
    Raspi 3 B mit IPS 5.1 prof., AudioMax Multiroom,
    KNX/EIB, DALI, 1Wire, Alexa/EchoDots

  10. #10
    Registriert seit
    Apr 2012
    Ort
    Euskirchen
    Beiträge
    217

    Standard Fehlerhafte Installationsscripte (?)

    Bei der Installation wird die Variable ChartHTML mit dem Wert
    PHP-Code:
    <iframe src='./User/IPSHighcharts/IPSTemplates/Highcharts.php?CfgFile=/usr/share/symcon/webfront\user\IPSHighcharts\Highcharts\HighchartsCfgIPSPowerControl.tmp' width='100%' height='416' frameborder='0' scrolling='no'></iframe
    angelegt.

    Dieser ist jedoch falsch: das 'U' ./User/... muss klein geschrieben sein und auch die Backslashes müssen durch Slashes ersetzt werden.

Ähnliche Themen

  1. IPSLibrary
    Von Brownson im Forum IPSLibrary
    Antworten: 35
    Letzter Beitrag: 03.11.18, 20:17
  2. Script Library Sammlung und nützliche Anleitungen
    Von Ferengi-Master im Forum Skripte, PHP, SQL
    Antworten: 1
    Letzter Beitrag: 02.01.09, 00:54
  3. Script Library Sammlung
    Von RWN im Forum Skripte, PHP, SQL
    Antworten: 1
    Letzter Beitrag: 15.07.08, 19:06