+ Antworten
Ergebnis 1 bis 4 von 4
  1. #1
    Registriert seit
    Jan 2012
    Beiträge
    12

    Standard Ips 2.5, php 5.4, sqlsrv 3.0

    Hallo Gruppe.

    Ich hatte mich schon so gefreut, dass nun endlich ein passender Treiber verfügbar wäre, und doch hab ich keinen Erfolg beim Einbinden:

    Windows 7 x64
    IPS: 2.5, 10.02.12, #2252
    MSSQL 2008
    Dieser Treiber für MSSQL

    Die DLLs sind in c:\IP-Symcon\ext zu finden.

    Auch ändere ich die php.ini entsprechend.

    Restart des IP-Symcon-Services bringt 2 Dinge:

    1. Meldung im Log für jede der DLLs: Version stimmt nicht überein: PHP: 5.4.0, EXT: 3.0.3421

    2. Eintrag in der php.ini wird entfernt.

    Was mach ich falsch...?

    Danke und LG, Harald.

  2. #2
    Registriert seit
    Jan 2007
    Ort
    Ostseeküste, da wo der Strand am weißesten und am breitesten ist
    Beiträge
    632

    Normaler Connection String über ADO geht doch immer und braucht keine speziellen Treiber. Allerdings habe ich PHP so bisher nur an MS-SQL 2005 laufen, dicke 2008er-Systeme aber nach gleichem Prinzip an Perl (nicht IPS). Sollte sicher auch an PHP gehen und gibt kaum was performanteres.

    Gruß Gerd

    Sent from unterwegs using mein Telefon.
    V1 (60%), V2.5(40%), Kopplung per Client-/Server-Socket; MS-SQL; Server-OS: W7/64, XP, ~400 Komponenten (HM, EnOcean, HMS100, FS20, ISDN/GigaSet, Gardena, LevelJet, Wetter), PTZ-IP-CAMs; USV --- Interessen: Synerget. Anwendgn. (passive Klimatisierung, Szenarienerkennung und -steuerung, Look ahead, Datamining...), behindertenspezifische Unterstützungen und Absicherungen

  3. #3
    Registriert seit
    Jan 2012
    Beiträge
    12

    Standard ADO funktioniert...

    Danke, ADO funktioniert. Allerdings wollte ich das eben mit den MS-Treibern hinbekommen. Anyway...

    Noch eine Frage:
    Ich möchte alle Werte in eine DB schreiben, die das logging-Flag eingeschalten haben.

    Wo bau ich das am einfachsten ein? Sollte ich aus der logging.db lesen?
    Gibt's einen Punkt wo man das zentral einbauen kann?

    Danke,
    Harald.

  4. #4
    Registriert seit
    May 2005
    Beiträge
    2,269

    Die Extension wird auch funktionieren,wenn sie für 5.4 gemacht ist. Allerdings muss man ihr den richtigen Versionstring verpassen. Siehe auch diesen älteren Thread mit dem gleichen Problem: http://www.ip-symcon.de/forum/f52/ei...544/#post79115

    Tommi

Ähnliche Themen

  1. PHP vs. IPS Funktionen
    Von bbernhard im Forum Skripte, PHP, SQL
    Antworten: 2
    Letzter Beitrag: 15.10.09, 11:59
  2. Neuere PHP Version für IPS oder älteres phpMyAdmin?
    Von Hinti im Forum Skripte, PHP, SQL
    Antworten: 17
    Letzter Beitrag: 23.02.09, 08:19
  3. Script Library Sammlung und nützliche Anleitungen
    Von Ferengi-Master im Forum Skripte, PHP, SQL
    Antworten: 1
    Letzter Beitrag: 02.01.09, 00:54
  4. Objektorientieres PHP mit IPS ???
    Von Ergoforce im Forum Allgemeine Diskussion
    Antworten: 2
    Letzter Beitrag: 28.12.06, 22:15
  5. Problem - PHP version 5.1 und extensions
    Von daniel1005 im Forum Allgemeine Diskussion
    Antworten: 4
    Letzter Beitrag: 30.11.05, 21:29