+ Antworten
Ergebnis 1 bis 5 von 5
  1. #1
    Registriert seit
    Nov 2013
    Beiträge
    17

    Question Keine Daten über COM Port

    Hallo zusammen,

    ich hoffe, dass Ihr mir bei meinem ersten Problem, welches ich hier habe, helfen könnt.
    Folgende Problematik tritt bei mir auf.

    Es sollen die Daten meiner Stromzähler ausgelesen werden.
    Diese wurden folgendermaßen angeschlossen

    RJ9-Stecker vom Stromzähler -> Serielles Modul -> Seriell auf USB Converter -> USB to LAN Adapter

    Die Anschlüsse funktionieren absolut problemlos und ich erhalte in Putty auf den seriellen Ports alle paar Sekunden Signale.
    Wir das gleiche über IPS durchgeführt, werden mir im Debug-Modus keine Daten angezeigt.

    Hat hier im Forum jemand eine Ahnung, woran es in diesem Fall liegen könnte?

    Habe bereits die Berechtigungen des IPS-Dienstes geändert, jedoch ohne Erfolg.
    Baudraten etc. auch, wobei es ja mit Putty funktioniert (9600 Baud, Datenbits 8, Stopbits 1, Parität keine)

  2. #2
    Registriert seit
    Jun 2005
    Beiträge
    3,744

    Hi,
    Du mußt Deine Konfigurationen hier darstellen, also die Lan-Instance, so entnehme ich es Deiner Beschreibung.

    Ansonsten einfach mal die serielle Schnittstelle (ohne LAN) in IPS mal konfigurieren, ev. geht Das ja.

    Firewall mal ausschalten hast Du sicher schon probiert.

    Gruß Helmut

  3. #3
    Registriert seit
    Nov 2013
    Beiträge
    17

    Hallo Helmut,

    die Verbindung findet über einen virtuellen COM-Port statt.

    Hier mal ein Screenshot von IPS:
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	IPS.JPG 
Hits:	90 
Größe:	39.9 KB 
ID:	23609

    Über eine Putty-Verbindung via COM-Port auf dem Server bekomme ich jede Sekunde Daten übermittelt.
    Es liegt also nicht an der Verbindung an sich, sondern am Abgreifen der Daten über den COM-Port von IPS.

    Hier mal der Screenshot aus Putty:
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Putty.JPG 
Hits:	111 
Größe:	63.8 KB 
ID:	23610

    Bei Fragen einfach fragen.
    Geändert von Armithage (24.11.13 um 15:08 Uhr)

  4. #4
    Registriert seit
    Jan 2009
    Ort
    Bremen
    Beiträge
    181

    Hallo Armithage,

    ich denke Du mußt den ComPort unter IPS noch öffnen.
    Hatte damals bei der Einbindung meines Zählers ähnliche Anfangsprobleme.

    Lies Dir mal diesen Link durch.

    Auf die Schnelle gehts auch hier

    Gruß Stefan
    IPS 5.3 auf Pi3
    1 x FHZ1300, 6 x FHT80B, 8 x FHT8V, WDE-1 mit 6x S555TH, 1-Wire, div HM und natürlich

  5. #5
    Registriert seit
    Nov 2013
    Beiträge
    17

    Zitat Zitat von Zwieback Beitrag anzeigen
    Hallo Armithage,

    ich denke Du mußt den ComPort unter IPS noch öffnen.
    Hatte damals bei der Einbindung meines Zählers ähnliche Anfangsprobleme.

    Lies Dir mal diesen Link durch.

    Auf die Schnelle gehts auch hier

    Gruß Stefan
    Hey,

    das gab die erleuchtende Idee.
    Das hinterlegte Script hat perfekt funktioniert:
    PHP-Code:
    COMPort_SetDTR(12345 /*Instance ID*/  true); 
    Nochmals vielen Dank dafür!

    Nun muss ich nur noch hoffen, dass mein USB Server nicht dauernd abschmiert.
    Solange kein Netzwerkfehler auftritt, funktioniert alles bestens.
    Auch ein Script zum Ein- und Ausschalten der COM-Ports muss ich jetzt noch schreiben, dann passt alles wie gewünscht.

    Grüße Armithage

Ähnliche Themen

  1. All3690 keine Daten im IPS
    Von reblade im Forum ALLNET, W&T, Loxone, IPswitch
    Antworten: 5
    Letzter Beitrag: 01.05.11, 20:57
  2. Daten über Com-Port einlesen
    Von computerpap im Forum Allgemeine Diskussion
    Antworten: 40
    Letzter Beitrag: 25.12.09, 12:43
  3. WIIPS 3.0b sammelt keine Daten
    Von BerndS im Forum IP-Symcon WIIPS
    Antworten: 2
    Letzter Beitrag: 12.09.09, 10:21
  4. Keine neuen Daten in Wiips
    Von Heidewinkler im Forum IP-Symcon WIIPS für Version 1.0
    Antworten: 20
    Letzter Beitrag: 24.02.08, 11:48
  5. FHT80B-2 erhalte keine Daten
    Von Eric im Forum Sonstige Funkkomponenten / Wetterstationen
    Antworten: 6
    Letzter Beitrag: 22.10.07, 18:16