+ Antworten
Seite 1 von 5 1 2 3 ... LetzteLetzte
Ergebnis 1 bis 10 von 48
  1. #1
    Registriert seit
    Jul 2011
    Ort
    Wiesbaden
    Beiträge
    449

    Standard Wago 750-842 Modbus/TCP Socket getrennt

    Hallo :-)

    Ich habe als Testaufbau vor dem Einbau eine Wago 750-842 hier stehen. Hierfür habe ich in IPS einen Client Socket, ein Modbus Gateway und für Jeden Digitalen eingang ein Mosbus Gerät angelegt.
    Nachdem man erst mal hinter die adressierung gestiegen ist funktioniert das alles auch fast Problemlos.

    Aus einem mir noch unbekannten Grund steigt allerdings der TCP-Socket aus, was natürlich dazu fürht, dass alle übergeordneten instanzen nicht mehr funktionieren. Nach kurzer Zeit kommt der Socket dann selbstständig wieder und wenige Sekunden Später geht das ganze von vorne los.
    Der Modbus/TCP-Connection Timeout steht bei 5000 ms und die Firewall ist erst mal komplett deaktiviert.
    Hat jemad eine idee woran es leigen könnte?


    Name:  Socket.PNG
Hits: 817
Größe:  26.2 KB
    IP-Symcon auf Raspberry PI / Windows / Docker / Synology (Docker)
    Homematic CCU2, Wago, LoRaWAN und Mikrocontroller

  2. #2
    Registriert seit
    Oct 2013
    Ort
    Appenzell
    Beiträge
    240

    Mach mal ein printscreen von der baumstruktur
    Und weitere Frage gehst du auf merker oder direkt auf die in outs?


    Gesendet von iPhone mit Tapatalk

  3. #3
    Registriert seit
    Jul 2011
    Ort
    Wiesbaden
    Beiträge
    449

    Outputs habe ich zur Zeit noch keine dran. Ich greife direkt auf die IO's zu ohne irgendein Programm in der Steuerung selbst.
    IP-Symcon auf Raspberry PI / Windows / Docker / Synology (Docker)
    Homematic CCU2, Wago, LoRaWAN und Mikrocontroller

  4. #4
    Registriert seit
    Oct 2013
    Ort
    Appenzell
    Beiträge
    240

    Hast du nur lesen markiert?
    Was du auch versuchen kannst geh mal über die merker und schau ob das Problem dann immer noch bestehend ist


    Gesendet von iPhone mit Tapatalk

  5. #5
    Registriert seit
    Jul 2011
    Ort
    Wiesbaden
    Beiträge
    449

    ich habe für die Wago leider keine Software da. Es funktioniert ja auch eigentlich. Ab und zu setzt es halt mal aus. die letzte Stunde läuft es wieder problemlos.
    IP-Symcon auf Raspberry PI / Windows / Docker / Synology (Docker)
    Homematic CCU2, Wago, LoRaWAN und Mikrocontroller

  6. #6
    Registriert seit
    Oct 2013
    Ort
    Appenzell
    Beiträge
    240

    Codesys ist doch gratis ?
    Kann man die nicht im Internet irgendwo runterladen
    Ansonsten bekommt man die auch von wago


    Gesendet von iPhone mit Tapatalk

  7. #7
    Registriert seit
    Oct 2013
    Ort
    Appenzell
    Beiträge
    240

    Ich greife immer über die merkeradressen zu und hatte das Problem noch nie
    Kenne aber vom Codesys her das ein direktes zugreifen auf die Hardware Adressen ggf zu Problemen führen kann speziell wenn versucht wird auf ne only read zB zu schreiben


    Gesendet von iPhone mit Tapatalk

  8. #8
    Registriert seit
    Jul 2011
    Ort
    Wiesbaden
    Beiträge
    449

    Zitat Zitat von firebuster Beitrag anzeigen
    ich habe für die Wago leider keine Software da. Es funktioniert ja auch eigentlich. Ab und zu setzt es halt mal aus. die letzte Stunde läuft es wieder problemlos.
    welche braucht man denn?

    Die hier?
    CODESYS V2.3.9.46 (current version) von der Seite: klick

    Sonst habe ich nur das hier gefunden:
    klick
    IP-Symcon auf Raspberry PI / Windows / Docker / Synology (Docker)
    Homematic CCU2, Wago, LoRaWAN und Mikrocontroller

  9. #9
    Registriert seit
    Oct 2013
    Ort
    Appenzell
    Beiträge
    240

    Standard Wago 750-842 Modbus/TCP Socket getrennt

    Müssten beide gehen
    Wobei ich auf 2te tendieren würde da die Codesys von Wago noch Wago spezifische Komponenten beinhaltet

    Dachte jedoch das die software an sich gratis sei
    Wenn du ein Starterkit hast sollte sie dabei gewesen sein (und preislich sind die ja nicht soviel höher als die Komponenten Einzel)
    Falls du den Controller Einzel gekauft hast ist schwerer, aber wenn du mehr als nur etwas spielen willst mit dem Controller wirst du sie brachen werden
    Vor allem wenn du dann mehr als nur digitale i/os hast

    Wenn du ein Starterkit hast und die Software nicht mehr finden kannst, kannst du den wago support Fragen die haben vielleicht Verständnis und schicken dir nen Download Link

    Mal ne andere Frage wie hast du die Hardwarekonfiguration machen können für den Controller ohne Codesys?
    Blinkt der rot? (Unterste led)

    Sowas könnte dein Problem auch verursachen

    Gesendet von meinem Gedanken-Maschine Interface mit einem digital Technik Konverter
    Geändert von rkoster (23.12.14 um 07:59 Uhr)

  10. #10
    Registriert seit
    Jul 2011
    Ort
    Wiesbaden
    Beiträge
    449

    Wenn der Controller frisch ist erstellt er automatisch ein prozessabbild der angeschlossenen Klemmen die digitalen Eingänge starten bei Adresse 0 und die digitalen Ausgänge auf Adresse 512 (glaube ich ... Das Päckchen mit den Digital Out Bausteinen ist unterwegs :-) )
    Für einfache Verknüpfungen mit Logikbausteinen und Timern sollte die erste Variante doch auch funktionieren?
    IP-Symcon auf Raspberry PI / Windows / Docker / Synology (Docker)
    Homematic CCU2, Wago, LoRaWAN und Mikrocontroller

Ähnliche Themen

  1. WAGO 750-841 langsamer als 750-842 ?
    Von rene im Forum SPS Automatisierungstechnik
    Antworten: 1
    Letzter Beitrag: 22.04.12, 10:38
  2. Wago 750-842 alte Firmware
    Von Gorilatzu im Forum SPS Automatisierungstechnik
    Antworten: 2
    Letzter Beitrag: 06.04.12, 19:32
  3. WAGO 750-842 + Abgesetzt Erweiterung mit Profibus?
    Von System-Fan im Forum SPS Automatisierungstechnik
    Antworten: 4
    Letzter Beitrag: 30.01.12, 21:11
  4. Wago 750-842 Aenderung zur Laufzeit
    Von mibu im Forum SPS Automatisierungstechnik
    Antworten: 3
    Letzter Beitrag: 12.10.11, 18:26
  5. Wago I/O über Modbus TCP ansprechen
    Von miickey29 im Forum SPS Automatisierungstechnik
    Antworten: 32
    Letzter Beitrag: 19.11.08, 20:28