+ Antworten
Ergebnis 1 bis 2 von 2
  1. #1
    Registriert seit
    Sep 2014
    Ort
    Limeshain (Hessen)
    Beiträge
    5,424

    Exclamation UnregisterTimer Funktion in Modulen evtl. fehlerhaft?!

    Diese Funktion > geklaut von Nall chan lässt mal ganz übel die IPS-Console ihre Verbindung zum IPS-Server verlieren

    Wenn ich diese Funktion in einem Modul verwende. Zum Beispiel wenn ein Haken entfernt wird und beim Klick auf Übernehmen der zugehörige Timer gelöscht werden soll, dann bekomme ich oben in der IPS-Console den schönen roten Balken, muss die IPS-Console beenden, neu öffnen und mich neu mit dem Server verbinden

    PHP-Code:
    protected function UnregisterTimer($Name)
        {
            
    $id = @IPS_GetObjectIDByIdent($Name$this->InstanceID);
            if (
    $id 0)
            {
                if (!
    IPS_EventExists($id))
                    throw new 
    Exception('Timer not present');
                
    IPS_DeleteEvent($id);
            }
        } 

    Mein Fehler oder ein Fehler im IPS? Der Timer wurde entfernt, aber beim nächsten Versuch das gleiche Verhalten wieder

    Wenn es nicht mein Fehler ist, dann sollte man das fixen, bevor die Funktion sich in noch mehr Modulen verbreitet und irgendwann mal "Destroy" funktioniert...weil dann gibt es viele IPS-Consolen-Crashs

    Grüße,
    Chris
    IP-Symcon Module >> www.bayaro.net << Verfügbare Module: BatterieMonitor, BundesligaTabelle, Enigma2BY, HeizölPreise, Helios, Horoskop, HostMonitor, IPSInformations, MELCloud, Müllabfuhr, PJLink, RSS, TankerkönigSpritpreise, xREL
    IPS Unlimited, ~1200 Scripte, ~7000 Variablen

  2. #2
    Registriert seit
    Mar 2014
    Ort
    Lübeck
    Beiträge
    272

    Moin Chris.

    Hab nun versucht das Problem nachzustellen.

    Wenn ich über ApplyChanges die Unregister Funktion aufrufe, funktioniert bei mir alles einwandfrei!
    Magst du mir ein auf das Problem reduziertes Beispiel basteln, wo bei dir der Fehler auftaucht?

    Grüße
    Pio
    Grüße von der DokuFront

Ähnliche Themen

  1. Antworten: 3
    Letzter Beitrag: 15.01.17, 17:27
  2. Eltako Dimmaktor funktion fehlerhaft?!
    Von raypancel im Forum Allgemeine Diskussion
    Antworten: 9
    Letzter Beitrag: 30.12.15, 21:13
  3. Alternative zu Plugwise evtl. als Eigenbau?!
    Von grind im Forum Haustechnik
    Antworten: 1
    Letzter Beitrag: 28.04.11, 16:34
  4. IP-Symcon + LOGO! evtl. EIB
    Von sanman im Forum KNX/EIB, LCN
    Antworten: 12
    Letzter Beitrag: 07.03.07, 18:04

Stichworte