+ Antworten
Ergebnis 1 bis 8 von 8
  1. #1
    Registriert seit
    Nov 2011
    Beiträge
    297

    Standard Version 4: COM Port unter Win10 lässt sich nicht mehr öffnen

    Hi,

    ich habe einen ISKRA Optopkoppler zum auslesen meines Stromzähler an einem echtem Seriellen Port (also kein usb2serial). Unter IPS 3.4 habe ich den Port für eine minute geöffnet, daten empfangen und anschließend wieder geschlossen.

    Seit 4.0 geht das nicht mehr. Ich kann den Port zwar öffnen, aber schließen geht nicht, versuche ich das stürzt die Konsole inkl der IPS Dienst knallhart ab.

    Manchmal hilft es, den COM-Port von COM1 auf COM2 zu setzen und dann wieder zurück, aber auch hier hab ich es oft, das die Konsole bzw der Dienst abstürzt.

    Als einzigen Workaround lasse ich den Port nun offen, aber dadurch ändern sich viele Variablen sekündlich, finde ich jetzt auch nicht sooo prall

    mfg
    kris
    Software: IP-Symcon V. 5 Unlimited Ubuntu 18.04
    Hardware: Shuttle DS77U3/16GB/1TBSSD
    Virtualisierung: Proxmox V6
    Homematic: Raspberrymatic

  2. #2
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    22,191

    Passiert der Absturz auch, wenn du es per Konsole öffnest/schließt? Oder passiert der Effekt nur, wenn du es per Skript machst?

    paresy

  3. #3
    Registriert seit
    Nov 2011
    Beiträge
    297

    HI,

    sorry, vergessen zu erwähnen. Das Problem besteht nur, wenn versucht wird per
    Code:
    IPS_SetProperty($COMPortID, 'Open', true);
    IPS_ApplyChanges($COMPortID);
    zu öffnen bzw. zu schließen. Das gemeine aber ist, wenn ich den Port per script geschlossen habe, und dann manuell - also per Konsole - wieder öffnen möchte, so stürzen Konsole und Dienst ab.

    Mit freundlichen Grüßen
    KRis
    Software: IP-Symcon V. 5 Unlimited Ubuntu 18.04
    Hardware: Shuttle DS77U3/16GB/1TBSSD
    Virtualisierung: Proxmox V6
    Homematic: Raspberrymatic

  4. #4
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    22,191

    Ist vermute dein Problem hängt mit diesem Fehler zusammen: Scripte laufen nicht mehr seit upgrafe auf V4.0 - Seite 2

    paresy

  5. #5
    Registriert seit
    Nov 2011
    Beiträge
    297

    Hi,

    Leider nein, ich habe bereits das Öffnen und schließen des Ports in ein separates Script ausgelagert.

    Ich schätze der Dienst knallt deshalb da es sich um einen echten seriellen Port handelt und nicht um einen USB zu seriell Adapter.

    Ich schau mal ob ich noch irgendeine Meldung herbekomme. Die ereignisanzeige von Windows sagt nur, das der Dienst unerwartet beendet wurde

    Mit freundlichen Grüßen
    Kris
    Software: IP-Symcon V. 5 Unlimited Ubuntu 18.04
    Hardware: Shuttle DS77U3/16GB/1TBSSD
    Virtualisierung: Proxmox V6
    Homematic: Raspberrymatic

  6. #6
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    22,191

    Wenn er unerwartet beendet wurde... hast du einen MiniDump Ordner im IP-Symcon Ordner? Wen ja, magst du mir den mal zukommen lassen?

    paresy

  7. #7
    Registriert seit
    Nov 2011
    Beiträge
    297

    Hi,

    Wenn er unerwartet beendet wurde... hast du einen MiniDump Ordner im IP-Symcon Ordner? Wen ja, magst du mir den mal zukommen lassen?
    leider habe ich keinen minidump. Nur die Ereignisanzeige


    Code:
    Dienst "IP-Symcon Environment" wurde unerwartet beendet. Dies ist bereits 6 Mal passiert.
    Code:
    - System 
    
      - Provider 
    
       [ Name]  Service Control Manager 
       [ Guid]  {555908d1-a6d7-4695-8e1e-26931d2012f4} 
       [ EventSourceName]  Service Control Manager 
     
      - EventID 7034 
    
       [ Qualifiers]  49152 
     
       Version 0 
     
       Level 2 
     
       Task 0 
     
       Opcode 0 
     
       Keywords 0x8080000000000000 
     
      - TimeCreated 
    
       [ SystemTime]  2016-03-06T21:26:20.612461500Z 
     
       EventRecordID 2394 
     
       Correlation
    mfg
    kris
    Software: IP-Symcon V. 5 Unlimited Ubuntu 18.04
    Hardware: Shuttle DS77U3/16GB/1TBSSD
    Virtualisierung: Proxmox V6
    Homematic: Raspberrymatic

  8. #8
    Registriert seit
    Nov 2011
    Beiträge
    297

    Hi,

    Code:
    -Fix: Deadlocks im Zusammenhang mit dem Öffnen und Schließen von I/Os aus dem Empfangsskript der RegisterVariable gelöst
    Prima, mein Problem wurde damit behoben, gerade getestet. Danke.

    Mit freundlichen Grüßen
    Kris
    Software: IP-Symcon V. 5 Unlimited Ubuntu 18.04
    Hardware: Shuttle DS77U3/16GB/1TBSSD
    Virtualisierung: Proxmox V6
    Homematic: Raspberrymatic

Ähnliche Themen

  1. Webfront lässt sich nicht mehr öffnen
    Von SmartHomeSchweiz im Forum Allgemeine Diskussion
    Antworten: 1
    Letzter Beitrag: 27.07.14, 08:53
  2. Webfront lässt sich nicht öffnen
    Von HMH_DE im Forum WebFront
    Antworten: 7
    Letzter Beitrag: 07.03.14, 06:34
  3. Antworten: 1
    Letzter Beitrag: 19.08.12, 07:57
  4. Dashboardformular lässt sich nicht mehr öffnen
    Von Bugelnig im Forum Dashboard
    Antworten: 5
    Letzter Beitrag: 24.03.10, 20:46