+ Antworten
Seite 2 von 2 ErsteErste 1 2
Ergebnis 11 bis 17 von 17
  1. #11
    Registriert seit
    Jun 2011
    Ort
    Thüringen
    Beiträge
    1,222

    Hi Wibo,

    ich komme erst ab Samstagnachmittag dazu - werde mir aber beide Themen ansehen und nach Möglichkeit ändern.

    Ciao
    herbertf
    IPS 5.x (beta) auf W10x64 in Hyper-V von W2016, FHZ1300, WDE-01, Homematic-CCU2, VISION-Z-WAVE-Stick alles über Silex-SX3000GB, 2*RaZberry,FHT80x, FS20 BidCos-RM, 19*FIBARO-Roller Shutter (V1+2), 15*Fibaro(-Dimmer, -Sensoren, -Switche), 7*Raspberry-PI2 ü. JSON-RPC, 3 VISION-Bewegungsmelder, 2 AEON-Multisensor, Homematic-Aktoren,15*Plugwise, 6 PhilioSensoren,

  2. #12
    Registriert seit
    Jan 2010
    Ort
    Rheinland Pfalz
    Beiträge
    1,755

    Bitte mach dir kein Stress.

    Sind nur Wünsche,

    Familie (und Shop!) haben andere Priorität !
    Gruß WiBo

    "Eventuelle Rechtschreib- und Tippfehler jeglicher Art sind nur ein Zeichen meiner Geschwindigkeit Ich bitte euch, gelassen darüber hinweg zu lesen."

  3. #13
    Registriert seit
    Jun 2011
    Ort
    Thüringen
    Beiträge
    1,222

    Zitat Zitat von Nall chan Beitrag anzeigen
    Grundsätzlich hat SPRT_SendText in einem Modul nix zu suchen.
    Dafür gibt es SendDataToParent.
    Die Fehlermeldung ist ja auch eindeutig, die IO-Instanz ist nicht geöffnet.
    Michael
    Hi Michael,

    ich habe in der Testing-Version jetzt dies:
    SPRT_SendText($COM_ID, $sendestring);
    durch dies ersetzt:
    $this->SendDataToParent($sendestring);

    Bekomme jetzt aber eine Fehlermeldung:

    Name:  sendatatoparnet.JPG
Hits: 148
Größe:  32.0 KB

    Hast Du da noch einen Tipp für mich?

    Schönen Sonntag noch

    Ciao
    herbertf
    IPS 5.x (beta) auf W10x64 in Hyper-V von W2016, FHZ1300, WDE-01, Homematic-CCU2, VISION-Z-WAVE-Stick alles über Silex-SX3000GB, 2*RaZberry,FHT80x, FS20 BidCos-RM, 19*FIBARO-Roller Shutter (V1+2), 15*Fibaro(-Dimmer, -Sensoren, -Switche), 7*Raspberry-PI2 ü. JSON-RPC, 3 VISION-Bewegungsmelder, 2 AEON-Multisensor, Homematic-Aktoren,15*Plugwise, 6 PhilioSensoren,

  4. #14
    Registriert seit
    Jun 2012
    Ort
    House of Dragons @ Lübeck
    Beiträge
    9,413

    Du musst da schon etwas mehr machen, dazu gibt es einmal das Thema Datenaustausch in der Doku und die Beispiele von dem SymconTest Repositorie auf GitHub.
    Michael
    on Win7VM (ESXi): I5, 24GB RAM, HW-RAID5, 3xSat | HW: CCU + 123 Geräte (506ch), EM1000, CUL, 1Wire, XBee, ELRO 433MHz, FritzBox Cable, Android Phone + Tablet, Samsung C-Serie TV +SamyGo-Ext, Onkyo NR| SW: IPS, Apache2(mod_ssl/PHP), MySQL, hMailServer, PRTG, Rising AV, Piwik, RoundCube, Wordpress, WinLIRC, WHS2011, MediaPortal, XBMC

  5. #15
    Registriert seit
    Jun 2011
    Ort
    Thüringen
    Beiträge
    1,222

    Danke, ich schaue mir das Beispiel an - wird aber erst morgen, ich muss nochmal los.
    IPS 5.x (beta) auf W10x64 in Hyper-V von W2016, FHZ1300, WDE-01, Homematic-CCU2, VISION-Z-WAVE-Stick alles über Silex-SX3000GB, 2*RaZberry,FHT80x, FS20 BidCos-RM, 19*FIBARO-Roller Shutter (V1+2), 15*Fibaro(-Dimmer, -Sensoren, -Switche), 7*Raspberry-PI2 ü. JSON-RPC, 3 VISION-Bewegungsmelder, 2 AEON-Multisensor, Homematic-Aktoren,15*Plugwise, 6 PhilioSensoren,

  6. #16
    Registriert seit
    Jun 2011
    Ort
    Thüringen
    Beiträge
    1,222

    Hi,

    ich habe nun also in der Testing auf SendDataToParent umgestellt.

    Weiterhin habe ich die DELAYS von 1100ms auf 1500ms erhöht.

    Das Problem (bzw. vor allem die Lösung) unter Windows verstehe ich aber nach wie vor nicht. Die von Wibu unter Windows auskommentierte Zeile:
    HTML-Code:
    in Modul Script Zeile 533  IPS_ApplyChanges($COM_ID); deaktiviert
    wird nur im SerialPort-Fehlerfall erreicht und speziell da möchte ich ja die serielle SS erneut öffnen und IPS_ApplyChanges durchführen. Gerade dies funktioniert beim Raspberry super. Warum dies unter Windows nicht gehen soll erschließt sich mir nicht.

    Die Zeile533 ist jetzt in Zeile 536, ich habe auch zusätzlich noch ein Delay hinzugefügt.

    PHP-Code:
    IPS_SetProperty($COM_ID,"Open",true);            //serielle Schnittstelle verschluckt sich - IPS-Problem?
    IPS_Sleep($delay);
    //Nachfolgende Zeile Probleme unter Windows ??? 
    IPS_ApplyChanges($COM_ID); 

    @Wibu: Es wäre schön wenn Due die Testing nochmal ausprobieren könntest.
    @Nallchan: Muss ich zum Öffnen der SS unter Windows etwas anderes tun?

    Ciao
    herbertf
    IPS 5.x (beta) auf W10x64 in Hyper-V von W2016, FHZ1300, WDE-01, Homematic-CCU2, VISION-Z-WAVE-Stick alles über Silex-SX3000GB, 2*RaZberry,FHT80x, FS20 BidCos-RM, 19*FIBARO-Roller Shutter (V1+2), 15*Fibaro(-Dimmer, -Sensoren, -Switche), 7*Raspberry-PI2 ü. JSON-RPC, 3 VISION-Bewegungsmelder, 2 AEON-Multisensor, Homematic-Aktoren,15*Plugwise, 6 PhilioSensoren,

  7. #17
    Registriert seit
    Jan 2010
    Ort
    Rheinland Pfalz
    Beiträge
    1,755

    Hallo Herbert,

    komme sehr wahrscheinlich erst ende nächster Woche dazu.

    Werde dann berichten.
    Gruß WiBo

    "Eventuelle Rechtschreib- und Tippfehler jeglicher Art sind nur ein Zeichen meiner Geschwindigkeit Ich bitte euch, gelassen darüber hinweg zu lesen."

Ähnliche Themen

  1. Modul für die Raspberry Pi GPIOs
    Von Elandril im Forum Entwicklung mit PHP-SDK/Delphi-SDK
    Antworten: 4
    Letzter Beitrag: 18.06.16, 07:33
  2. Identive SCL011 Contactless Reader Modul (nPA-Basisleser)
    Von EmJay im Forum Allgemeine Diskussion (2.x/3.x)
    Antworten: 21
    Letzter Beitrag: 26.08.14, 14:47
  3. Neuer Fingerprint Reader von ELV
    Von mws im Forum Haustechnik
    Antworten: 2
    Letzter Beitrag: 19.01.12, 12:48

Stichworte