+ Antworten
Seite 37 von 37 ErsteErste ... 27 35 36 37
Ergebnis 361 bis 369 von 369
  1. #361
    Registriert seit
    Aug 2013
    Beiträge
    30

    Zitat Zitat von thezepter Beitrag anzeigen
    Moin Jürgen,

    ja entweder du erstellst ihn kurz neu per ssh (ist ja nicht wild, du verlierst ja keine Config etc... einfach neuinstallieren und starten)

    Code:
    docker run --name symcon50104 --net="host" -v /volume1/docker/symcon/data:/var/lib/symcon -v /volume1/docker/symcon/log:/var/log/symcon -v /volume1/docker/symcon/:/root --privileged -v /dev/ttyACM0:/dev/ttyACM0 symcon/symcon:latest
    Oder du installierst dir "Portainer" und kannst das entspannt hinzufügen über eine Oberfläche.

    Anhang 43753
    Habt ihr eine Idee warum bei mir das Weiterleiten nicht funktioniert? Das USB Gerät wir in der Weboberfläche der Synology erkennt.
    Angehängte Grafiken Angehängte Grafiken  

  2. #362
    Registriert seit
    Aug 2017
    Beiträge
    415

    Hier hatte doch wer was geschrieben das bei Docker die settings.json beim Beenden nicht gespeichert wird. Ich dachte eigentlich ich habe diesen Fehler nicht aber habe es gerade mal beobachtet, tritt auch bei mir auf (5.1.3133 auf einer Synology NAS)
    IPS 5.1 - Docker auf Synology

  3. #363
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    20,784

    @Bayaro hat diesen Fehler auch auf einem Rapberry Pi System beobachtet. Es scheint eine Kombination aus genutzten Modulen zu sein und die Nutzung dieser. Der Fehler ist somit leider etwas schwer zu finden. Ich freue mich natürlich über alle Hinweise die ihr dazu habt - rechne aber aktuell nicht mit einer schnell Lösung.

    paresy

  4. #364
    Registriert seit
    Mar 2012
    Beiträge
    47

    (Entfernt, falscher Kontext...)
    Geändert von ssimn (16.07.19 um 11:39 Uhr)

  5. #365
    Registriert seit
    Aug 2013
    Beiträge
    30

    Standard USB Weiterleitung

    Ich habe es jetzt mal manuel per Konsole probiert mit folgendem Befehl:
    Code:
    docker run --name symcon_usb --net="host" -v /volume1/docker/Symcon/lib:/var/lib/symcon -v /volume1/docker/Symcon/log:/var/log/symcon -v /volume1/docker/Symcon/root:/root --privileged -v /dev/ttyACM0:/dev/ttyACM0 symcon/symcon:latest
    Folgende Fehlermeldung bekomme ich:
    Code:
    Bind mount failed: '/dev/ttyACM0' does not exists
    Ich habe bereits mehrere USB Ports an der Synology probiert, immer das selbe Problem.
    Leider bekomme ich das USB Gerät nicht verbunden...habt ihr noch eine Idee?

    In der Synology bekomme ich das Gerät angezeigt
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Synology_usb.JPG 
Hits:	21 
Größe:	26.5 KB 
ID:	49905
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	lsusb.JPG 
Hits:	19 
Größe:	67.1 KB 
ID:	49906
    Geändert von oooripooo (16.07.19 um 21:39 Uhr)

  6. #366
    Registriert seit
    Dec 2017
    Ort
    Wolfsburg
    Beiträge
    202

    Auch mit einem „sudo“ vor dem docker Befehl?
    IPS 5.1 Unlimited / Docker / Synology DS218+

  7. #367
    Registriert seit
    Aug 2013
    Beiträge
    30

    Ja auch mit sudo davor. Gibt es eine Möglichkeit den Pfad des USB Anschluss rauszufinden? Ist es möglich, dass es nicht der /dev/ttyACM0 ist? Der Eintrag ist nämlich tatsächlich nicht da wenn ich mir das /dev Verzeichnis anschaue.

  8. #368
    Registriert seit
    Apr 2019
    Ort
    Etelsen bei Bremen
    Beiträge
    104

    Hi,
    schau vielleicht mal per SSH direkt in der Synology nach. Ich habe den Effekt das bei einem Neustart des NAS die Ports sich ändern und aus /dev/ttyACM0 wird /dev/ttyACM1. Braucht man nicht auch USBSerialDrivers App damit die USB-Sticks angesprochen werden können? Ich habe sie auf jeden Fall installiert weil ich das schon für OScam brauchte.

    Das --privileged sollte doch das selbe sein wie "Mit hoher Priorität ausführen" oder? Bei mir läuft es auf einer DS415+ ohne manuelle Eingriffe direkt in der Docker-App von Synology.

    Ralf
    Geändert von HarmonyFan (17.07.19 um 08:06 Uhr)
    IPS 5.1 Unlimited / Docker / Synology DS415+

  9. #369
    Registriert seit
    Aug 2013
    Beiträge
    30

    Hey Ralf,

    dein Tipp mit den Treibern hat es gebracht!! Vielen Dank, nun hab ich meinen M-Bus Master endlich in meinem Docker Container.
    Falls noch jemand die passenden Treiber für seine Synology sucht, die sind hier zu finden:

    http://www.jadahl.com/drivers_6.2/

    Nochmals vielen Dank für die Hilfe!

Ähnliche Themen

  1. IP-Symcon via Docker Engine
    Von saschahb im Forum Allgemeine Diskussion
    Antworten: 89
    Letzter Beitrag: 16.01.18, 16:39
  2. Frage zu Docker - Debian - Synology
    Von c.radi im Forum Off Topic
    Antworten: 7
    Letzter Beitrag: 13.10.17, 10:22
  3. Antworten: 2
    Letzter Beitrag: 14.07.17, 12:52
  4. Docker für Raspberry Pi & Co
    Von Boui im Forum Off Topic
    Antworten: 0
    Letzter Beitrag: 03.09.16, 09:20
  5. Synology Docker mit Windows Container
    Von wolfgang im Forum Alles rund um den PC
    Antworten: 6
    Letzter Beitrag: 23.04.16, 08:07