+ Antworten
Seite 2 von 2 ErsteErste 1 2
Ergebnis 11 bis 17 von 17
  1. #11
    Registriert seit
    Sep 2014
    Ort
    Limeshain (Hessen)
    Beiträge
    5,280

    Gibt einige IPS-Skripte hier im Forum die HTML Code dynamisch zusammenbauen und diesen dann an eine Funktion übergeben oder in eine Variable schreiben. Einfach nur auf deine Wünsche anpassen

    -Chris-
    IP-Symcon Module >> www.bayaro.net << Verfügbare Module: BatterieMonitor, BundesligaTabelle, Enigma2BY, HeizölPreise, Helios, Horoskop, HostMonitor, IPSInformations, MELCloud, Müllabfuhr, PJLink, RSS, TankerkönigSpritpreise, xREL
    IPS Unlimited, ~1200 Scripte, ~7000 Variablen

  2. #12
    Registriert seit
    Sep 2005
    Ort
    Sachsen-Anhalt
    Beiträge
    179

    Ich habe auf 5.1 geupdatet und nun werden keine HTML EMails mehr versendet.
    Beim SENDEN Button kommt die Meldung:
    Abort Processing during Fatal-Error: filter_var(): explicit use of FILTER_FLAG_SCHEME_REQUIRED and FILTER_FLAG_HOST_REQUIRED is deprecated
    Error in Script /mnt/data/symcon/modules/.store/fonzo.ipsymconmailer/libs/Fonzo/PHPMailer/PHPMailer.pgp on Line 3599.
    Damit kann ich leider nichts anfangen.
    Wie bekomme ich das wieder gefixt?
    Fritzbox! 7590 mit OS 07.01
    Symbox 1. Generation

  3. #13
    Registriert seit
    Oct 2011
    Ort
    Hattersheim (Hessen)
    Beiträge
    6,199

    Zitat Zitat von zeras Beitrag anzeigen
    Abort Processing during Fatal-Error: filter_var(): explicit use of FILTER_FLAG_SCHEME_REQUIRED and FILTER_FLAG_HOST_REQUIRED is deprecated
    Error in Script /mnt/data/symcon/modules/.store/fonzo.ipsymconmailer/libs/Fonzo/PHPMailer/PHPMailer.pgp on Line 3599.
    Scheint wohl mit der PHP Version zusammen zuhängen, muss ich mal anschauen um das zu beheben.

  4. #14
    Registriert seit
    Sep 2005
    Ort
    Sachsen-Anhalt
    Beiträge
    179

    Zitat Zitat von Fonzo Beitrag anzeigen
    Scheint wohl mit der PHP Version zusammen zuhängen, muss ich mal anschauen um das zu beheben.
    Danke für die Info.
    Symcon hatte nach dem Update "gemeckert", dass es neue Versionen gibt. Diese habe ich dann hoffentlich korrekt installiert. Ob die alten Module noch Probleme machen, weiß ich leider nicht.

    Kann ich das Modul irgendwo in der Konsole finden, welches angemeckert wird?
    Ich bin mit den Modulen noch nicht so firm, wo die liegen.
    Fritzbox! 7590 mit OS 07.01
    Symbox 1. Generation

  5. #15
    Registriert seit
    Sep 2005
    Ort
    Sachsen-Anhalt
    Beiträge
    179

    Ich habe nun ein wenig recherchiert und probiert. In Zeile 3599 bei PHPMailer.php habe ich folgendes geändert. Damit scheint es nun zu gehen.

    Statt
    PHP-Code:
            if (filter_var('http://' $hostFILTER_VALIDATE_URLFILTER_FLAG_HOST_REQUIRED)) { 
    nun
    PHP-Code:
            if (filter_var('http://' $hostFILTER_VALIDATE_URL)) { 
    Wenn das so OK ist, könnte es ja im Module Store geändert werden.
    Fritzbox! 7590 mit OS 07.01
    Symbox 1. Generation

  6. #16
    Registriert seit
    Oct 2011
    Ort
    Hattersheim (Hessen)
    Beiträge
    6,199

    Zitat Zitat von zeras Beitrag anzeigen
    Wenn das so OK ist, könnte es ja im Module Store geändert werden.
    Ich habe PHPMailer auf Version 6.0.7 aktualisiert, damit sollte der Fehler auch weg sein. Im Beta Branch ist das sofort verfügbar, der Stable Branch folgt dann nach Freigabe.

    Nach diesem einem Modul Update ist der Symcon Dienst neu zu starten.
    Geändert von Fonzo (15.06.19 um 21:29 Uhr)

  7. #17
    Registriert seit
    Sep 2005
    Ort
    Sachsen-Anhalt
    Beiträge
    179

    Zitat Zitat von Fonzo Beitrag anzeigen
    Ich habe PHPMailer auf Version 6.0.7 aktualisiert, damit sollte der Fehler auch weg sein. Im Beta Branch ist das sofort verfügbar, der Stable Branch folgt dann nach Freigabe.

    Nach diesem einem Modul Update ist der Symcon Dienst neu zu starten.
    Danke.
    Ich habe die Beta installiert. Diese läuft nun.
    Fritzbox! 7590 mit OS 07.01
    Symbox 1. Generation

Ähnliche Themen

  1. Modul Update schlägt fehl bei lokal geändertem Modul
    Von bumaas im Forum Allgemeine Diskussion
    Antworten: 15
    Letzter Beitrag: 13.03.19, 14:05
  2. Antworten: 0
    Letzter Beitrag: 13.01.16, 23:50
  3. 2 x Modul "BundesligaTabelle" >> verschiedene Einstellungen pro Modul-Instanz
    Von Bayaro im Forum Entwicklung mit PHP-SDK/Delphi-SDK
    Antworten: 20
    Letzter Beitrag: 28.12.15, 12:06
  4. Per Modul Script starten / Per Script auf Modul wechseln
    Von grossermanitu im Forum WebFront
    Antworten: 12
    Letzter Beitrag: 28.11.10, 21:27

Stichworte