+ Antworten
Ergebnis 1 bis 2 von 2
  1. #1
    Registriert seit
    Aug 2011
    Ort
    Hannover
    Beiträge
    184

    Standard Fehler in 5.0: Sys_GetHardDiskInfo() ?

    Hallo allerseits,

    das Thema war hier im Bezug auf die Symbox schonmal aktuell und als behoben markiert.

    Jedoch hab ich hier noch ein Problem:

    df auf dem Pi:
    Code:
    root@SymconTest:~# df
    Filesystem     1K-blocks    Used Available Use% Mounted on
    /dev/root       30613684 1266364  28071388   5% /
    devtmpfs          470116       0    470116   0% /dev
    tmpfs             474724       0    474724   0% /dev/shm
    tmpfs             474724    6304    468420   2% /run
    tmpfs               5120       4      5116   1% /run/lock
    tmpfs             474724       0    474724   0% /sys/fs/cgroup
    /dev/mmcblk0p1     42131   22138     19993  53% /boot
    tmpfs              94944       0     94944   0% /run/user/1000
    root@SymconTest:~#

    und hier das Array per Sys_GetHardDiskInfo():
    Code:
    Array
    (
        [0] => Array
            (
                [LETTER] => /
                [LABEL] => /dev/root
                [TOTAL] => 1283641344
                [FREE] => 4281860096
            )
    
        [1] => Array
            (
                [LETTER] => /dev
                [LABEL] => devtmpfs
                [TOTAL] => 481398784
                [FREE] => 481398784
            )
    
        [2] => Array
            (
                [LETTER] => /dev/shm
                [LABEL] => tmpfs
                [TOTAL] => 486117376
                [FREE] => 486117376
            )
    
        [3] => Array
            (
                [LETTER] => /run
                [LABEL] => tmpfs
                [TOTAL] => 486117376
                [FREE] => 479662080
            )
    
        [4] => Array
            (
                [LETTER] => /run/lock
                [LABEL] => tmpfs
                [TOTAL] => 5242880
                [FREE] => 5238784
            )
    
        [5] => Array
            (
                [LETTER] => /sys/fs/cgroup
                [LABEL] => tmpfs
                [TOTAL] => 486117376
                [FREE] => 486117376
            )
    
        [6] => Array
            (
                [LETTER] => /boot
                [LABEL] => /dev/mmcblk0p1
                [TOTAL] => 43141632
                [FREE] => 20472320
            )
    
        [7] => Array
            (
                [LETTER] => /run/user/1000
                [LABEL] => tmpfs
                [TOTAL] => 97222656
                [FREE] => 97222656
            )
    
    )
    da passen die beiden (fett marktierten) Größen scheinbar nicht zueinander. Oder was ist hier falsch?

    Viele Grüße,
    Jörg
    Raspi 3 B mit IPS 4.3 prof., AudioMax Multiroom,
    KNX/EIB, DALI, 1Wire, habridge für Alexa/EchoDots

  2. #2
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    18,258

    Wir schauen uns das an!

    paresy

Ähnliche Themen

  1. Antworten: 7
    Letzter Beitrag: 20.03.18, 17:42
  2. Antworten: 6
    Letzter Beitrag: 25.11.17, 23:24
  3. Antworten: 40
    Letzter Beitrag: 12.02.17, 22:23
  4. Antworten: 3
    Letzter Beitrag: 12.01.15, 14:08
  5. Sys_GetHardDiskInfo ( ) für Wechseldatenträger
    Von Mastershort im Forum Allgemeine Diskussion (2.x/3.x)
    Antworten: 1
    Letzter Beitrag: 18.07.12, 07:05