+ Antworten
Ergebnis 1 bis 8 von 8
  1. #1
    Registriert seit
    Aug 2006
    Beiträge
    7

    Standard Upgrade auf IPS 5.0 - Modbus TCP zu Twincat-SPS in vmWare Player

    Hallo,

    ich verwende auf einem PC folgende Konfiguration:
    - Hostsystem: Windows 10 Pro 64 bit (IP: 192.168.17.4)
    - Guestsystem: Windows 7 Pro 32 bit (vmWare Player 12, bridged) mit Beckhoff Twincat 2 SPS (IP: 192.168.17.61)

    Bisher verwendete ich IPS 4.2 ebenfalls am Guestsystem. Die Verbindung zur Twincat SPS über Modbus TCP lief problemlos.

    Aufgrund des Upgrades auf IPS 5.0 musste ich IPS auf das Hostsystem (64 bit) verlagern. Die Einstellung am Client Socket (Modbus Gateway) änderte ich von 127.0.0.1:502 auf 192.168.17.61:502. Beim Aktivieren der Schnittstelle kommt die Fehlermeldung: "Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte. (Code: -32603)". Die Firewall am Guestsystem ist deaktiviert.

    Bin für jeden Hinweis dankbar.

  2. #2
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    20,734

    Lauscht der TwinCat Server auch auf allen Interfaces? Evtl. ist dort aus Sicherheitsgründen nur 127.0.0.1 eingestellt?

    paresy

  3. #3
    Registriert seit
    Aug 2006
    Beiträge
    7

    Ich kann von einem anderen PC im selben Netzwerk (IP: 192.168.17.120) problemlos auf den Twincat-Systemmanager zugreifen. Ich wüsste auch nicht, wo ich in Twincat die IP-Adressen einstellen könnte, auf denen der Server lauscht?

  4. #4
    Registriert seit
    Aug 2006
    Beiträge
    7

    Sorry, habe den Hinweis auf den TwinCat Server erst im 2. Anlauf verstanden. Habe jetzt am Guestsystem mit der TcModbusSrvCfg.exe die Konfiguration der IP-Adresse von "leer" (=127.0.0.1 =Default) auf "192.168.17.61" geändert. Beim Aktivieren der Schnittstelle (Client Socket (Modbus Gateway)) am Hostsystem kommt jedoch nach wie vor die Fehlermeldung: "Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte. (Code: -32603)".

  5. #5
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    20,734

    Hast du mal mit einem TCP Monitor geschaut, ob auf dem Server der Port genutzt wird und auf LISTEN steht?

    paresy

  6. #6
    Registriert seit
    Aug 2006
    Beiträge
    7

    Soweit ich TCPView verstehe, läuft der TwinCat Modbus Server und lauscht auf Port 502:

    Process: TcModbusSrv.exe
    PID: 1020
    Protocol: TCP
    Local Address: win-ejrmrh5ssee.fritz.box
    Local Port: 502
    Remote Address: WIN-EJRMRH5SSEE
    Remote Port: 0
    State: LISTENING

    "WIN-EJRMRH5SSEE" ist der Name der Local Machine, auf der die TwinCat-PLC läuft.

    P.S. Habe sowohl mit Firefox als auch mit MS Edge vergeblich versucht, ein Bildschirmfoto (JPG) an diese Nachricht anzuhängen. Wenn man die JPG-Datei in das Feld "Anhänge verwalten" > "Anhänge" zieht, öffnet Firefox die Datei und der Button "Fertig" ist nicht mehr sichtbar. MS Edge verweigert überhaupt das Kopieren der Datei in das Feld Anhänge?!

  7. #7
    Registriert seit
    Jul 2015
    Ort
    96178 Pommersfelden
    Beiträge
    73

    Hallo,

    ich stand vor knapp 6 Monaten vor der gleichen Aufgabe.
    Vielleicht ists auch deine Lösung.

    Grüße Alfred

    https://www.symcon.de/forum/threads/...attformwechsel

  8. #8
    Registriert seit
    Aug 2006
    Beiträge
    7

    Hallo Alfred,

    der TCP-Port 502 war geöffnet, hat dennoch nicht funktioniert. Habe auch die Firewall der Virtual Machine komplett ausgeschaltet, ohne Erfolg. Dennoch vielen Dank für den Hinweis.

    Ich habe allerdings jetzt die Lösung des Problems auf einer ganz anderen "Baustelle" gefunden: Bei einem Upgrade von "Windows 10" wird offenbar das Bridging zwischen Host und Guest (Virtual Machine von VMware) "zerschossen". Dies wird erst erkennbar, wenn man einen Portscan vom Host aus auf den Guest durchführt. Am Guest selbst kann man nichts erkennen. Sowohl das "Bridging" wird als i.O. angezeigt, als auch dass der Port 502 auf "LISTENING" steht.

    Erst ein Zurücksetzen der virtuellen Netzwerkadapter im Guest ("Restore Defaults") und eine Neukonfiguration löst das Problem.

    Gruß

    Stefan

Ähnliche Themen

  1. Starthilfe - Beckhoff CX9000 per TwinCAT Modbus TCP Server CE anbinden
    Von Nuku im Forum SPS Automatisierungstechnik
    Antworten: 5
    Letzter Beitrag: 23.08.17, 07:00
  2. ABB SPS, Modbus TCP & willkürliche Variablenänderung
    Von Chris R im Forum SPS Automatisierungstechnik
    Antworten: 3
    Letzter Beitrag: 04.04.17, 09:01
  3. Owos Lib für Beckhoff SPS/TwinCat
    Von StM im Forum SPS Automatisierungstechnik
    Antworten: 12
    Letzter Beitrag: 13.05.13, 10:12
  4. IPS auf VMWare
    Von Stromer im Forum Allgemeine Diskussion (2.x/3.x)
    Antworten: 3
    Letzter Beitrag: 25.03.13, 12:53
  5. ModBus // IPS->Moeller SPS --Zeitschaltuhr--
    Von rambaldi85 im Forum SPS Automatisierungstechnik
    Antworten: 0
    Letzter Beitrag: 21.04.12, 18:44

Stichworte