+ Antworten
Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 10 von 12
  1. #1
    Registriert seit
    Aug 2011
    Beiträge
    975

    Standard Aktualisierung des Uhrzeit-Widget?

    Hi,

    vielleicht nur ne Kleinigkeit, aber wann/wie häufig wird eigentlich das die mittels Uhrzeit-Widget angezeigte Uhrzeit aktualisiert.
    Ich hab gerade mehr als 4 Minuten Differenz zur Windows-Rechner-Zeit (des Servers) beobachtet, bevor die Zeit angepasst wurde.

    hardlog
    IPS 5.0unlim, 3x W&T WebIO12, diverse 1wire (LAN), FritzOS 7, z-Wave, DMX/ArtNet-Node, M-Bus, ESP8266 via MQTT

    "Prognosen sind schwierig, besonders wenn sie die Zukunft betreffen" N. Bohr

  2. #2
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    21,890

    Die Uhrzeit im Webfront kommt ausschließlich vom Client auf dem es angezeigt wird. Also synchronisiert sich gar nicht mit dem Server.

    paresy

  3. #3
    Registriert seit
    Aug 2011
    Beiträge
    975

    hmmm:

    Hier mal nen ScreenShot. Auf diesem WIn10-PC läuft IPS und in diesem Fall auch der Browser.

    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	uhr.JPG 
Hits:	189 
Größe:	21.2 KB 
ID:	46931
    IPS 5.0unlim, 3x W&T WebIO12, diverse 1wire (LAN), FritzOS 7, z-Wave, DMX/ArtNet-Node, M-Bus, ESP8266 via MQTT

    "Prognosen sind schwierig, besonders wenn sie die Zukunft betreffen" N. Bohr

  4. #4
    Registriert seit
    Aug 2018
    Beiträge
    62

    Zitat Zitat von paresy Beitrag anzeigen
    Die Uhrzeit im Webfront kommt ausschließlich vom Client auf dem es angezeigt wird. Also synchronisiert sich gar nicht mit dem Server.

    paresy
    Ich habe das auch schon festgestellt in den letzten Tagen. Die Ursprüngliche Frage bezog sich hier auf einen "aggregation error" der bei mir immer auftaucht. Scheint was mit dem Überschlag auf die nächste volle Stunde, bzw. den nächsten vollen Tag zu tun haben. Ich habe dann auch herausgefunden, dass die Zeiten zwischen meinem Raspberry, dem Windows Client und auch noch, wenn auch nur wenige sec, zum WF auf dem Windows Rechner, unterschiedlich sind.

    Hier der Link zum Post:
    Klick mich

    Auf Gerhards anraten hin, habe ich dann zwar noch den Timeserver vom Windows (btw Windows 7 x64) auf denselben wie im Pi umgestellt "0.de.pool.ntp.org", eine exakte Gleichheit der drei Zeiten hat das aber nicht gebracht.

    Weiterhin unschön, sind die unterschiedlichen Zeiten, wenn man sich die Timer im Webfront ansieht. Leider kann ich gerade keinen Screenshot dazu machen. Wenn z.B. in einen Skript ein 3 sec Timer gestartet wird, wird im WF ja die Zeit angezeigt, in welcher das Skript erneut ausgeführt wird. Durch die unterschiedlichen Zeiten wird das Skript dann z.B. wieder um 18:50:55 ausgeführt, im Uhrzeit Widget steht aber schon 18:51:15. Ich kann später dazu mal einen Screenshot nachreichen.
    IPS 5.3; Raspberry Pi mit Raspbian Stretch; LCN; LCN PCHK; Instar + Anpviz Kamera, Worx Landroid

  5. #5
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    21,890

    Kann ich das irgendwie nachstellen? Bei mir laufen die Uhren immer synchron!?

    paresy

  6. #6
    Registriert seit
    Jan 2007
    Ort
    H / DH // F / OF
    Beiträge
    1,051

    Das kannst du paresy - wirst es aber wahrscheinlich nicht ändern können.
    Die Uhrzeit auf dem RasPi ist nicht immer ganz syncron mit dem Client (trotz NTP, RTC etc.), von daher ist die Event-Schaltzeit natürlich auch nicht mit der angezeigten Uhrzeit syncron.
    Wenn das mal einen Kunden wirklich stört, lege ich eine Variable an in die ich (jede Minute) die Systemzeit schreibe. Dann ist das zwar nicht mehr "sekundengenau" - aber das Widget zeigt die "richtige" Zahl an.

    Grüße, Uwe
    natürlich ... TOGETHER - nicht mehr "Bus-Profi", jetzt ist der 'Job' hier "www.hausss.de" - immer mit LCN und

  7. #7
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    21,890

    Hi Uwe,

    auf dem Bild von Hardlog siehst du aber den Browser und die Systemuhrzeit - da kommt aber keinerlei Information vom Server Somit müssten die 1:1 synchron sein

    paresy

  8. #8
    Registriert seit
    Aug 2018
    Beiträge
    62

    Also ich habe mittlerweile folgendes gemacht (System ist wie gesagt W7 x64):

    - Die CMOS Batterie im Desktop PC gewechselt, die war bestimmt 5 Jahre alt, hat aber noch 3V gehabt, dennoch getauscht
    --> hatte keine Auswirkung, immer noch lief die W7 Zeit vor
    - einen anderen Zeitserver eingestellt, auf den das W7 System synchronisieren soll, auch denselben der auf dem Raspberry genutzt wird
    --> hatte keine Auswirkung, immer noch lief die W7 Zeit vor
    - Das HPET (High Precision Event Timer) im BIOS aktiviert, nachdem ich irgendwo im Forum davon gelesen habe
    --> Jetzt nach ca. 3h scheint die Zeit stabil zu bleiben. Ich vergleiche dabei sowohl mit dem Raspberry, als auch mit meinem Smartphone. Bevor ich das HPET aktiviert hatte, konnte ich nach wenigen Minuten schon beobachten das die Windows 7 Zeit "davonlief".

    Versuchsweise habe ich die Zeit auch mal mehrere Minuten im BIOS beobachtet, dort blieb Sie stabil, was für mein Verständnis einen Hardwarefehler ausschließt.
    IPS 5.3; Raspberry Pi mit Raspbian Stretch; LCN; LCN PCHK; Instar + Anpviz Kamera, Worx Landroid

  9. #9
    Registriert seit
    Aug 2011
    Beiträge
    975

    Interessanterweise schwanken die Differenzen. Ein System hab ich noch nicht erkannt. Ist ein rel. neuer PC mit aktuellem Win10.

    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	zeit.JPG 
Hits:	27 
Größe:	19.0 KB 
ID:	47188
    hat sich gerade "synchronisier". Bzw. bis ich einen Screenshot hatte wasren schon wieder 1 Minute Differenz drin.
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	zeit1.JPG 
Hits:	31 
Größe:	18.7 KB 
ID:	47189


    hardlog
    IPS 5.0unlim, 3x W&T WebIO12, diverse 1wire (LAN), FritzOS 7, z-Wave, DMX/ArtNet-Node, M-Bus, ESP8266 via MQTT

    "Prognosen sind schwierig, besonders wenn sie die Zukunft betreffen" N. Bohr

  10. #10
    Registriert seit
    Aug 2018
    Beiträge
    62

    Hast du mal versucht das HPET im Bios zu aktivieren? Bei mir hat das, zumindest bis jetzt, den Erfolg gebracht .
    IPS 5.3; Raspberry Pi mit Raspbian Stretch; LCN; LCN PCHK; Instar + Anpviz Kamera, Worx Landroid

Ähnliche Themen

  1. Server Datum und Uhrzeit des Widget
    Von ComputerMk im Forum WebFront
    Antworten: 1
    Letzter Beitrag: 05.05.17, 15:06
  2. Antworten: 3
    Letzter Beitrag: 06.02.17, 16:57
  3. Uhrzeit Widget ändern
    Von hardlog im Forum WebFront
    Antworten: 9
    Letzter Beitrag: 05.02.12, 11:58