+ Antworten
Seite 2 von 2 ErsteErste 1 2
Ergebnis 11 bis 15 von 15
  1. #11
    Registriert seit
    Nov 2012
    Ort
    Hochdorf
    Beiträge
    77

    Sorry, gestern hat es mir nicht mehr erreicht.. Hier nun die Debug-Ausgaben und weiteres.

    Das Gateway ist ein PI 3 mit einer Z-Wave-Platine (ZMEERAZ2):
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Gateway.png 
Hits:	68 
Größe:	37.5 KB 
ID:	48557

    Der Sensor hat da dann diese Klassen:
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Sensor_Klasse.png 
Hits:	79 
Größe:	37.3 KB 
ID:	48558

    Und der Input 2 sieht so aus:
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	node_2_klassen.png 
Hits:	66 
Größe:	28.6 KB 
ID:	48559

    Eingehängt mit Basic-Klasse sieht das dann in IPS so aus:
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	sensor_ips.png 
Hits:	82 
Größe:	51.4 KB 
ID:	48560

    Wenn nun einer der beiden Input-Kanäle (egal welcher) betätigt wird, passiert in IPS nur, dass der Hauptknoten aktualisiert wird, also so:
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Bildschirmfoto 2019-04-12 um 10.03.55.png 
Hits:	58 
Größe:	51.4 KB 
ID:	48561

    Beide Input-Kanäle stehen auf Normal Open, debug sieht so aus:

    Input 2 einschalten
    Code:
    TXT: 12.04.2019 09:11:52.00 | (R) Class (20): BASIC | <SOH>ˇ
    HEX: 12.04.2019 09:11:52.00 | (R) Class (20): BASIC | 01 FF 
    TXT: 12.04.2019 09:11:52.00 | (R) Class (20): BASIC | <SOH>ˇ
    HEX: 12.04.2019 09:11:52.00 | (R) Class (20): BASIC | 01 FF 
    TXT: 12.04.2019 09:11:52.00 | (R) Class (20): BASIC | <SOH>ˇ
    HEX: 12.04.2019 09:11:52.00 | (R) Class (20): BASIC | 01 FF
    Input 2 ausschalten
    Code:
    TXT: 12.04.2019 09:12:01.00 | (R) Class (20): BASIC | <SOH><NUL>
    HEX: 12.04.2019 09:12:01.00 | (R) Class (20): BASIC | 01 00 
    TXT: 12.04.2019 09:12:01.00 | (R) Class (20): BASIC | <SOH><NUL>
    HEX: 12.04.2019 09:12:01.00 | (R) Class (20): BASIC | 01 00 
    TXT: 12.04.2019 09:12:01.00 | (R) Class (20): BASIC | <SOH><NUL>
    HEX: 12.04.2019 09:12:01.00 | (R) Class (20): BASIC | 01 00
    Input 1 ist vollkommen identisch, es fehlt also noch die Information, welcher Input geschaltet hat.

    An meinem anderen Zwave-Gateway, auch ein PI mit Z-Wave-Platine, hier allerdings das etwas ältere Model ZME_RAZ_EU
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Bildschirmfoto 2019-04-12 um 10.06.52.png 
Hits:	49 
Größe:	32.7 KB 
ID:	48562

    Ist das anders, hier kommt auch noch eine Multi-Channel Nachricht (Sensor ist der gleiche):

    Input 2 an:
    Code:
    TXT: 12.04.2019 09:22:04.00 | (R) Class (60): MULTI_CHANNEL | <CR><STX><STX> <SOH>ˇ
    HEX: 12.04.2019 09:22:04.00 | (R) Class (60): MULTI_CHANNEL | 0D 02 02 20 01 FF 
    TXT: 12.04.2019 09:22:04.00 | (R) Class (20): BASIC | <SOH>ˇ
    HEX: 12.04.2019 09:22:04.00 | (R) Class (20): BASIC | 01 FF
    Input 2 aus
    Code:
    TXT: 12.04.2019 09:55:57.00 | (R) Class (60): MULTI_CHANNEL | <CR><STX><STX> <SOH><NUL>
    HEX: 12.04.2019 09:55:57.00 | (R) Class (60): MULTI_CHANNEL | 0D 02 02 20 01 00 
    TXT: 12.04.2019 09:55:57.00 | (R) Class (20): BASIC | <SOH><NUL>
    HEX: 12.04.2019 09:55:57.00 | (R) Class (20): BASIC | 01 00
    Ich befürchte also, es liegt schlicht an dem Z-Wave Modul für den PI, hier scheint das neuere ZMEERAZ2 etwas anders zu machen oder eben zu verschlucken.

    EDIT: IPS ist die neueste Testing Version auf einem PI.


    Gruss Mayday
    Geändert von mayday (12.04.19 um 09:16 Uhr)

  2. #12
    Registriert seit
    Apr 2018
    Beiträge
    9

    Hallo zusammen

    Über die Osterferien habe ich versucht den neuen Universalsensor von Fibaro FGBS-222 einzubinden. Soweit hat alles einwandfrei geklappt nun habe ich aber ein ähnliches Problem wie hier beschrieben. Die Werte der Sub ID 3 & 4 welche sich auf die beiden Universaleingänge (gelb & grün) beziehen, aktualisieren sich nur wen ich diese über die Statusvariable aktualisiere.

    Zum vergleich ich habe ebenfalls ein FGBS-001 im Einsatz, hier werden die Werte bei einer Änderung am Eingang sofort aktualisiert.
    Kann es sein dass dies ein ähnlichen Hintergrund hat?

    IP Symcon 5.0 läuft auf einem Raspberry 3 und als Z-Wave Gateway hab eich einen Aeotec Z-Wave Stick im Einsatz.

    Variablen in IPS
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Variablen.PNG 
Hits:	66 
Größe:	66.9 KB 
ID:	48714

    Log Eintrag bei manueller Aktualisierung
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Log.PNG 
Hits:	54 
Größe:	21.1 KB 
ID:	48715

    Gruss minor

  3. #13
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    24,122

    Ich würde dir empfehlen auf die 5.1 zu wechseln, da wir die Z-Wave Anbindung dort wesentlich verbessert haben.

    paresy

  4. #14
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    24,122

    @minor: Welche Version der MULTI_CHANNEL_ASSOCIATIONS unterstützt dein Gerät? Das Verteilen von Nachrichten auf Unterkanäle geht leider erst korrekt ab V3.

    @mayday: Auch hier kann dein Gerät leider nur V2 der MULTI_CHANNEL_ASSOCIATIONS. Somit kannst du bei den Untergräten nur abfragen was der Status ist

    paresy

  5. #15
    Registriert seit
    Nov 2016
    Beiträge
    61

    Zitat Zitat von minor Beitrag anzeigen
    Hallo zusammen

    Über die Osterferien habe ich versucht den neuen Universalsensor von Fibaro FGBS-222 einzubinden. Soweit hat alles einwandfrei geklappt nun habe ich aber ein ähnliches Problem wie hier beschrieben. Die Werte der Sub ID 3 & 4 welche sich auf die beiden Universaleingänge (gelb & grün) beziehen, aktualisieren sich nur wen ich diese über die Statusvariable aktualisiere.

    Zum vergleich ich habe ebenfalls ein FGBS-001 im Einsatz, hier werden die Werte bei einer Änderung am Eingang sofort aktualisiert.
    Kann es sein dass dies ein ähnlichen Hintergrund hat?

    IP Symcon 5.0 läuft auf einem Raspberry 3 und als Z-Wave Gateway hab eich einen Aeotec Z-Wave Stick im Einsatz.

    Variablen in IPS
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Variablen.PNG 
Hits:	66 
Größe:	66.9 KB 
ID:	48714

    Log Eintrag bei manueller Aktualisierung
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Log.PNG 
Hits:	54 
Größe:	21.1 KB 
ID:	48715

    Gruss minor
    Ich greife das hier mal wieder auf. Das gleiche Problem habe ich auch
    Ich habe 2 Fibaro FGS222. Diese aktualisieren die Sub Channels leider auch nicht. So weiß ich nie ob das Licht nun an ist oder aus.

    Habe ein paar Tests gemacht:
    Auf Basic Class umzustellen > Gleiches Problem
    Auf Simple Assoziazionen umgestellt > Gleiches Problem
    Sicheres Includieren deaktiviert und Modul neu hinzugefügt > Gleiches Problem


    Habe Symcon Version 5.2.
    Gibt es eine Möglichkeit das die Variablen automatisch ohne "Statusvariablen aktualisierung" vom Gerät an IP Symcon ankommen?
    Wenn ich manuell am Modul schalte kommen in IP Symcon folgende Daten rein
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	1.PNG 
Hits:	29 
Größe:	30.0 KB 
ID:	52463


    Ist hier das gleiche Problem wie oben beschrieben mit der V2 der MULTI_CHANNEL_ASSOCIATIONS das er keine Daten aktualisiert?
    Geändert von becker010 (01.02.20 um 16:11 Uhr)
    Hardware: Merten Connect System (9 Rolladen), Zipato RFID, Mehrere Fibaro Motion Sensoren, Fibaro RGBW, Fibaro Switch, Fibaro Button
    Gateway: Aeotec Z-Stick Gen 5 in Raspberry Pi
    Programmiert wird über ein Windows 10 Laptop, Software: IP-Symcon 5.4

Ähnliche Themen

  1. Antworten: 86
    Letzter Beitrag: 11.06.19, 22:16
  2. Antworten: 7
    Letzter Beitrag: 02.10.18, 10:34
  3. Z-Wave Binärsensor Fibaro Universal Binary Sensor - Bug
    Von tomgr im Forum Allgemeine Diskussion
    Antworten: 7
    Letzter Beitrag: 09.02.16, 18:45
  4. Raspberry - Razberry - fibaro-universal-sensor Problem
    Von tomgr im Forum Allgemeine Diskussion
    Antworten: 4
    Letzter Beitrag: 01.02.16, 17:55
  5. Problem mit Fibaro Flood Sensor nach Upgrade auf V. 3.2
    Von Mangar im Forum Allgemeine Diskussion (2.x/3.x)
    Antworten: 3
    Letzter Beitrag: 11.12.14, 14:27