+ Antworten
Seite 1 von 3 1 2 3 LetzteLetzte
Ergebnis 1 bis 10 von 25

Thema: IPS Absturz

  1. #1
    Registriert seit
    Mar 2016
    Ort
    Geltendorf
    Beiträge
    74

    Standard IPS Absturz

    Hallo,

    nach Upgrade auf 5.1 erlebe ich unerklärliche Abstürze von IPS auf einem Raspi 3. In der Logdatei sehe ich, dass um 13 h nach Zeitplan ein Thermostat angesteuert wird. Dann keinerlei Fehlereinträge, Dienst stürzt ab, lässt sich manuell wieder starten.

    System besteht aus einem Raspi mit ZWave Modul und ausschließlich ZWave Aktoren/Sensoren.

    Frage: Wie kann ich gezielt den Fehler nachstellen bzw. analysieren?

    Viele Grüße
    Andreas
    IPS 5.1 auf Raspi 3 mit Z-Wave-Modul, Danfoss LC-13 Thermostate,Fibaro Switches, Fensterkontakte, Bewegungsmelder, Button, Floodsensor, Aeon Switch.

  2. #2
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    21,644

    Am einfachsten, wenn du dies hier machst: Debugging für Experten (Raspberry Pi, Linux)

    Wenn du dann einen Backtrace für mich hast, kann ich bestimmt recht schnell die Ursache finden.

    paresy

  3. #3
    Registriert seit
    Mar 2016
    Ort
    Geltendorf
    Beiträge
    74

    Hallo Paresy,

    ich teste dies einmal, vielen Dank,

    Andreas
    IPS 5.1 auf Raspi 3 mit Z-Wave-Modul, Danfoss LC-13 Thermostate,Fibaro Switches, Fensterkontakte, Bewegungsmelder, Button, Floodsensor, Aeon Switch.

  4. #4
    Registriert seit
    Mar 2016
    Ort
    Geltendorf
    Beiträge
    74

    Hallo Paresy,

    gdb gibt folgende Fehlermeldung:

    Code:
    (gdb) bt
    #0  0x00a034fc in ZWaveBattery::ReceiveData(std::vector<unsigned char, std::allocator<unsigned char> >) ()
    #1  0x00a7b6c0 in ZWaveDevice::ReceiveData(IPSData const&) ()
    #2  0x00a7b370 in ZWaveDevice::ReceiveData(IPSData const&) ()
    #3  0x00fffb34 in IPSFlowHandler::SendDataToChildren(unsigned short, IPSData const&) ()
    #4  0x00a8fed4 in ZWaveGateway::ProcessRequest(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >) ()
    #5  0x00a937c8 in ZWaveGateway::ParseBuffer() ()
    #6  0x00a93d34 in ZWaveGateway::ReceiveData(IPSData const&) ()
    #7  0x00fffb34 in IPSFlowHandler::SendDataToChildren(unsigned short, IPSData const&) ()
    #8  0x01172320 in IOSerialPort::completedReading(std::shared_ptr<std::array<char, 4096u> >, std::error_code const&, unsigned int) ()
    #9  0x01175728 in asio::detail::descriptor_read_op<asio::mutable_buffers_1, std::_Bind<std::_Mem_fn<void (IOSerialPort::*)(std::shared_ptr<std::array<char, 4096u> >, std::error_code const&, unsigned int)> (IOSerialPort*, std::shared_ptr<std::array<char, 4096u> >, std::_Placeholder<1>, std::_Placeholder<2>)> >::do_complete(void*, asio::detail::scheduler_operation*, std::error_code const&, unsigned int) ()
    #10 0x008d8e44 in asio::detail::epoll_reactor::descriptor_state::do_complete(void*, asio::detail::scheduler_operation*, std::error_code const&, unsigned int)
        ()
    ---Type <return> to continue, or q <return> to quit---  
    #11 0x0116e2b4 in std::thread::_State_impl<std::_Bind_simple<IOSerialPort::Connect()::{lambda()#1} ()> >::_M_run() ()
    #12 0x026765d8 in execute_native_thread_routine ()
    #13 0x76f81fc4 in start_thread (arg=0x6cffe8a0) at pthread_create.c:458
    #14 0x76d6e038 in ?? () at ../sysdeps/unix/sysv/linux/arm/clone.S:76
       from /lib/arm-linux-gnueabihf/libc.so.6
    Backtrace stopped: previous frame identical to this frame (corrupt stack?)
    IPS 5.1 auf Raspi 3 mit Z-Wave-Modul, Danfoss LC-13 Thermostate,Fibaro Switches, Fensterkontakte, Bewegungsmelder, Button, Floodsensor, Aeon Switch.

  5. #5
    Registriert seit
    Mar 2016
    Ort
    Geltendorf
    Beiträge
    74

    PS: Mein 4.3 Backup läuft problemlos.
    IPS 5.1 auf Raspi 3 mit Z-Wave-Modul, Danfoss LC-13 Thermostate,Fibaro Switches, Fensterkontakte, Bewegungsmelder, Button, Floodsensor, Aeon Switch.

  6. #6
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    21,644

    Ein Gerät scheint beim Batteriestatus nicht ganz korrekte Daten zu senden. Ich werde zum nächsten Update dort ein paar zusätzliche Checks einbauen.

    paresy

  7. #7
    Registriert seit
    Mar 2016
    Ort
    Geltendorf
    Beiträge
    74

    Hallo Paresy,,

    ok, danke, hatte auch beobachtet das der Batteriestatus mit Vorsicht zu genießen ist. Bis wann ist denn mit einem Update zu rechnen?

    PS: Die erweiterten Statusvariablen machen in 5.1 insgesamt einen sehr guten Eindruck.

    Viele Grüße
    Andreas
    IPS 5.1 auf Raspi 3 mit Z-Wave-Modul, Danfoss LC-13 Thermostate,Fibaro Switches, Fensterkontakte, Bewegungsmelder, Button, Floodsensor, Aeon Switch.

  8. #8
    Registriert seit
    Mar 2016
    Ort
    Geltendorf
    Beiträge
    74

    Hallo,

    gibt es hierzu bereits eine Fehlerkorrektur?

    Danke,
    Andreas
    IPS 5.1 auf Raspi 3 mit Z-Wave-Modul, Danfoss LC-13 Thermostate,Fibaro Switches, Fensterkontakte, Bewegungsmelder, Button, Floodsensor, Aeon Switch.

  9. #9
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    21,644

    Leider noch nicht. Kommt diese Woche. Danke für deine Geduld!

    paresy

  10. #10
    Registriert seit
    Mar 2016
    Ort
    Geltendorf
    Beiträge
    74

    Hallo Paresy,

    ist der Fix im neuen Stable-Release berücksichtigt oder kann/muss ich auf gezielte Suche gehen, um den Aktor ggf. neu anzulernen?

    Danke,
    Andreas
    IPS 5.1 auf Raspi 3 mit Z-Wave-Modul, Danfoss LC-13 Thermostate,Fibaro Switches, Fensterkontakte, Bewegungsmelder, Button, Floodsensor, Aeon Switch.

Ähnliche Themen

  1. IPS 5.0 Dienst absturz bis zum PC absturz
    Von zonex im Forum Allgemeine Diskussion
    Antworten: 4
    Letzter Beitrag: 16.12.18, 17:46
  2. IPS Absturz
    Von kpiep im Forum Allgemeine Diskussion
    Antworten: 9
    Letzter Beitrag: 17.07.06, 15:25
  3. Absturz IPS
    Von uwe im Forum Allgemeine Diskussion
    Antworten: 1
    Letzter Beitrag: 22.06.06, 17:42