+ Antworten
Ergebnis 1 bis 5 von 5
  1. #1
    Registriert seit
    Jan 2012
    Beiträge
    453

    Standard interessantes Problem mit RequestAction in Verbindung mit Slidern und Touch

    Ich bin heute beim Testen meines neuen Moduls auf ein interessantes Problem gestoßen:

    Ich habe die Ansteuerung von Rollladen-Aktoren im Webfront mit Slidern, also Integer-Variable + RequestAction, gelöst. Das hat bei allen Tests prima funktioniert. Getestet habe ich allerdings mit Standardmonitor und Maus.

    Wenn ich jetzt das ganze auf IOS- oder Android-Geräten mit Touchscreen probiere, dann kommt es regelmäßig zu Mehrfachauslösung der Befehle. Das heißt ein und derselbe Befehl wird im Millisekunden Abstand bis zu 5x gesendet, was den Rollladen-Aktor in wildes Geklacker versetzt, bevor er dann endlich nach dem 5. Telegrammempfang mit der Arbeit beginnen kann.

    Erst hatte ich eine Wechselwirkung zwischen Touch-Sollwert und Aktorrückmeldung vermutet und beide Werte durch einen Soll- und einen Ist-Wert-Slider getrennt. Aber auch da kommt es zu dem Problem.

    Ist das Problem bekannt?
    Weiß jemand einen Workaround?

    Viele Grüße
    Jürgen

  2. #2
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    20,732

    Nutzt du dort die App oder auch das WebFront? Wie ist die Schrittweite eingestellt?

    paresy

  3. #3
    Registriert seit
    Jan 2012
    Beiträge
    453

    Ich nutze das Webfront. Schrittweite ist 1.
    Habe eben einen Gegencheck mit IPS-View gemacht. Das macht keine Probleme. Die APP probiere ich auch noch und werde berichten.

    Viele Grüße
    Jürgen

  4. #4
    Registriert seit
    Jan 2012
    Beiträge
    453

    mit der APP ging es schneller als erwartet. Also auch mit der APP aus dem Store und der aus TestFlight keinerlei Probleme.

    Viele Grüße
    Jürgen

  5. #5
    Registriert seit
    Jan 2012
    Beiträge
    453

    eben noch einen normalen HTML-Slider probiert. Geht auch korrekt.

Ähnliche Themen

  1. Problem Verbindung Siemens Logo7 mit IPS4.0 und Raspberry Pi2!
    Von odermerk im Forum Allgemeine Diskussion
    Antworten: 6
    Letzter Beitrag: 17.01.16, 20:58
  2. Problem mit Reverse Proxy mit ARR und Rewrite im IIS und Version 3.0
    Von Strichcode im Forum Allgemeine Diskussion (2.x/3.x)
    Antworten: 2
    Letzter Beitrag: 07.10.13, 14:13
  3. iPod Touch mit Wandhalterung und Stromversorgung
    Von Papapeti im Forum Alles rund um den PC
    Antworten: 2
    Letzter Beitrag: 13.11.09, 17:23
  4. COMPort - Problem mit TCP Verbindung
    Von alfred im Forum Allgemeine Diskussion
    Antworten: 3
    Letzter Beitrag: 03.09.06, 21:36