+ Antworten
Ergebnis 1 bis 5 von 5
  1. #1
    Registriert seit
    Feb 2009
    Beiträge
    342

    Standard Dienst nach IPS verzögert starten

    Hallo, folgendes Problem:
    Auf mein beim RASPI 3 läuft IPS mit MQTT... ein zusätzlicher Dienst (ebusd) liest die Daten meiner Heizungsregelung aus und schiebt die per MQTT zu IPS...soweit so gut, bis zu einem Reboot des RASPI klappt das.
    Nach dem Reboot versucht der ebusd Dienst wohl zu früh den RASPI MQTT zu konnekten...die Verbindung kommt nicht zu Stande. Ein 'Service ebusd Stop' mit anschliessendem 'Service ebusd Start' löst das Problem.
    Wie verzögere ich den Start des ebusd Service?

    Gruss Michael
    IPS auf Win10 Pro, PC nach c't 19/2013 (Core i5-4570, unter 20Watt), RASPI 2 mit YAHM CCU, RASPI 1, RASPI 3 mit PiLight & PiHole, FritzBox 7490

  2. #2
    Registriert seit
    Mar 2008
    Ort
    Ruesselsheim
    Beiträge
    3,458

    Hallo
    https://www.bastlerseite.at/service-...egert-starten/
    Wuerdest du nicht auch das Problem haben wenn du IPS-Dienst beendest?
    Dann ist ja eine Verbindung auch weg.
    Vielleicht solltest du den Dienst starten/neustarten wenn IPS gestartet ist.
    In Kern Instanzen-Event Handler ein Start-Skript definieren.

  3. #3
    Registriert seit
    Feb 2009
    Beiträge
    342

    Mmmhhh...das muss doch eleganter gehen...hab gegoogelt und gelesen, dass man Dienste verzögert starten kann...hab's aber nicht wirklich verstanden
    IPS auf Win10 Pro, PC nach c't 19/2013 (Core i5-4570, unter 20Watt), RASPI 2 mit YAHM CCU, RASPI 1, RASPI 3 mit PiLight & PiHole, FritzBox 7490

  4. #4
    Registriert seit
    Mar 2008
    Ort
    Ruesselsheim
    Beiträge
    3,458

    Zitat Zitat von micserver Beitrag anzeigen
    Mmmhhh...das muss doch eleganter gehen...hab gegoogelt und gelesen, dass man Dienste verzögert starten kann...hab's aber nicht wirklich verstanden
    Meine Link in meinem post hast du gelesen?


    Gesendet von iPad mit Tapatalk

  5. #5
    Registriert seit
    Feb 2009
    Beiträge
    342

    Upps, Asche auf mein Haupt... der Link ist mir auf dem Handy nicht aufgefallen...
    Danke, prüfe ich und werde Resultat berichten
    Gruss Michael
    IPS auf Win10 Pro, PC nach c't 19/2013 (Core i5-4570, unter 20Watt), RASPI 2 mit YAHM CCU, RASPI 1, RASPI 3 mit PiLight & PiHole, FritzBox 7490

Ähnliche Themen

  1. Antworten: 8
    Letzter Beitrag: 08.03.16, 11:32
  2. Skript verzögert starten
    Von paresy im Forum Anleitungen / Nützliche PHP Skripte
    Antworten: 1
    Letzter Beitrag: 23.04.12, 09:23
  3. IP-Symcon Dienst verzögert starten (z.B. BidCos, SerialPort->LAN, USB->LAN abwarten)
    Von konfu im Forum Anleitungen / Nützliche PHP Skripte
    Antworten: 1
    Letzter Beitrag: 10.04.12, 08:52
  4. IPS als Dienst unter WHS starten
    Von lueralba im Forum Alles rund um den PC
    Antworten: 0
    Letzter Beitrag: 02.05.11, 21:05
  5. Dienst automatisch starten, nach reboot
    Von brdiver677 im Forum Allgemeine Diskussion (2.x/3.x)
    Antworten: 9
    Letzter Beitrag: 13.12.09, 15:52