+ Antworten
Ergebnis 1 bis 5 von 5
  1. #1
    Registriert seit
    Jan 2015
    Ort
    Baden-Württemberg
    Beiträge
    305

    Standard Fehler in WFC_OpenCategory ?

    Hi Leute,

    habe heute von 5.0 auf 5.1 aktualisiert und dabei festgestellt, dass eines meiner Skripte welches auf klick eines Buttons eine bestimmte Kategorie als Popup öffnet, nicht mehr funktioniert.

    Im Grunde beschränkt sich das Skript auf folgendes:
    PHP-Code:
    $POPUP_CATEGORY 30775;
    WFC_OpenCategory($_IPS['CONFIGURATOR'], $POPUP_CATEGORY); 
    Fehlermeldung kommt im Webfront:

    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	2019-07-29 22_55_32-Window.png 
Hits:	35 
Größe:	6.9 KB 
ID:	49985

    Die Kategorie ist allerdings unter dieser ID vorhanden:

    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	2019-07-29 22_55_52-Window.png 
Hits:	39 
Größe:	1.8 KB 
ID:	49986

    Kann das jemand bestätigen oder weiß eventuell mehr ?

    Vor dem Update hat das Skript einwandfrei funktioniert, somit gehe ich stark von einem Bug aus.

    Danke!

    Grüße
    Daniel

  2. #2
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    21,057

    Ist diese Kategorie innerhalb deines WebFronts vorhanden? (Darf gerne unsichtbar sein!)

    Das WebFront lädt ab Version 5.1 ausschließlich die Elemente, die auch im WebFront direkt drin sind.

    paresy

  3. #3
    Registriert seit
    Jan 2015
    Ort
    Baden-Württemberg
    Beiträge
    305

    Hi Michael,

    danke für deine Rückmeldung!

    Mein Skript welches das Popup steuert hat die Kategorie als Child:

    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	2019-07-30 19_14_59-Window.png 
Hits:	25 
Größe:	14.7 KB 
ID:	49989

    Markierte Variable öffnet das Popup und wurde ins Webfront verlinkt. Nun habe ich die Kategorie ebenfalls verlinkt und es funktioniert.
    Fördert allerdings nicht gerade die Übersicht in der Struktur - kannst du mir den Grund für diese Änderung nennen ?

    Grüße
    Daniel

  4. #4
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    21,057

    Sicherheit. Alles war nicht explizit zum definierten WebFront gehört wird nicht geladen.

    paresy

  5. #5
    Registriert seit
    Jan 2015
    Ort
    Baden-Württemberg
    Beiträge
    305

    Alles klar, dachte ich mir.

    Danke für deine schnelle Hilfe!

Ähnliche Themen

  1. WFC_OpenCategory wieder schließen?
    Von pitti im Forum WebFront
    Antworten: 1
    Letzter Beitrag: 12.02.19, 21:21
  2. Antworten: 9
    Letzter Beitrag: 24.07.18, 12:44
  3. WFC_OpenCategory alternativ Baisc Lizenz?
    Von sallos im Forum WebFront
    Antworten: 2
    Letzter Beitrag: 19.03.18, 10:59