+ Antworten
Seite 1 von 3 1 2 3 LetzteLetzte
Ergebnis 1 bis 10 von 24
  1. #1
    Registriert seit
    Jan 2012
    Beiträge
    509

    Standard 5.1/5.2 startet nicht mit Debian Buster

    Habe eben meinen Odroid-HC1 auf Buster umgestellt. Unter Stretch lief Symcon RPI einwandfrei, unter Buster scheitert der Start mit folgendem log:
    Code:
    # /usr/bin/symcon
    *** IP-Symcon starting
    08/03/19 19:16:24 | 00000 | Kernel | Creating...
    08/03/19 19:16:24 | 00000 | Kernel | Platform: Raspberry Pi
    08/03/19 19:16:24 | 00000 | Kernel | Version: 5.1
    08/03/19 19:16:24 | 00000 | Kernel | Revision: af42594c75f079fb53124ba02623f3eaae0ab38b
    08/03/19 19:16:24 | 00000 | Kernel | Build: 07/03/19
    08/03/19 19:16:24 | 00000 | Kernel | WorkingDir: /var/lib/symcon/
    08/03/19 19:16:24 | 00000 | Kernel | SystemDir: /usr/share/symcon/
    08/03/19 19:16:24 | 00000 | Kernel | LogDir: /var/log/symcon/
    08/03/19 19:16:24 | 00000 | Kernel | Boost Version: 1_68
    08/03/19 19:16:24 | 00000 | Kernel | cURL Version: libcurl/7.62.0 OpenSSL/1.1.0j zlib/1.2.11
    08/03/19 19:16:24 | 00000 | Kernel | Git2 Version: 0.27.4
    08/03/19 19:16:24 | 00000 | Kernel | SSH Version: 0.8.5
    08/03/19 19:16:24 | 00000 | Kernel | ZLIB Version: 1.2.11
    08/03/19 19:16:24 | 00000 | Kernel | RapidJSON Version: 1.1.0
    08/03/19 19:16:24 | 00000 | Kernel | OpenSSL Version: OpenSSL 1.1.0j  20 Nov 2018
    08/03/19 19:16:24 | 00000 | Kernel | OpenSSL CertDir: /usr/share/symcon/
    08/03/19 19:16:24 | 00000 | Kernel | OpenSSL CertFile: /usr/share/symcon/cacert.pem
    08/03/19 19:16:24 | 00000 | Kernel | XML2 Version: 20908
    08/03/19 19:16:24 | 00000 | Kernel | XML2 Threads: Yes
    08/03/19 19:16:24 | 00000 | Kernel | PHP Version: 7.3.5
    08/03/19 19:16:24 | 00000 | Kernel | Initializing...
    08/03/19 19:16:24 | 00000 | LocalePool | Creating...
    08/03/19 19:16:24 | 00000 | LocalePool | Detected locale: C
    Segmentation fault
    Und bei Verwendung von GDB:
    Code:
    (gdb) run
    Starting program: /usr/bin/symcon 
    [Thread debugging using libthread_db enabled]
    Using host libthread_db library "/lib/arm-linux-gnueabihf/libthread_db.so.1".
    
    Program received signal SIGILL, Illegal instruction.
    0x017db7e8 in _armv7_tick ()
    Dabei macht es keinen Unterschied, ob ich Symcon 5.1 oder 5.2 verwende.
    Ich weiß, dass der Odroid nicht unterstützt wird, aber vielleicht lässt sich das trotzdem beheben.
    Hat jemand eine Idee?

    Viele Grüße
    Jürgen

  2. #2
    Registriert seit
    Aug 2009
    Ort
    Lippe
    Beiträge
    1,896

    locale nicht richtig unter Linux eingerichtet ?
    Nur aus dem Bauch.
    lg Thomas
    IPS Raspberry Pi2(3) mit LCN, HM, Sonoff+Shelly per MQTT, SONOS und viel Eigenbau + Pi2(3) mit Heizungssteuerung über GPIO per IPS

  3. #3
    Registriert seit
    Jun 2012
    Ort
    House of Dragons @ Lübeck
    Beiträge
    8,901

    Zitat Zitat von tomgr Beitrag anzeigen
    locale nicht richtig unter Linux eingerichtet ?
    Nur aus dem Bauch.
    Korrekt, die ist falsch.
    Michael
    on Win7VM (ESXi): I5, 24GB RAM, HW-RAID5, 3xSat | HW: CCU + 123 Geräte (506ch), EM1000, CUL, 1Wire, XBee, ELRO 433MHz, FritzBox Cable, Android Phone + Tablet, Samsung C-Serie TV +SamyGo-Ext, Onkyo NR| SW: IPS, Apache2(mod_ssl/PHP), MySQL, hMailServer, PRTG, Rising AV, Piwik, RoundCube, Wordpress, WinLIRC, WHS2011, MediaPortal, XBMC

  4. #4
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    21,009

    Bei GDB musst du über die SIGILL per c + ENTER drüber. Mich wundert dass es ohne locale ganz abstürzt.

    Auf dem Pi geht es unter Buster.

    paresy

  5. #5
    Registriert seit
    Aug 2009
    Ort
    Lippe
    Beiträge
    1,896

    Habe gerade mal ein Update auf einem PI2 auf Buster angeworfen(da ist ein IPS5.2 Testsystem drauf), dauert etwas.
    PI4(4GB) habe ich vor Wochen bestellt, aber der kommt erst Ende des Monats.
    Und dann wollte ich mal mit Buster spielen.
    lg Thomas
    IPS Raspberry Pi2(3) mit LCN, HM, Sonoff+Shelly per MQTT, SONOS und viel Eigenbau + Pi2(3) mit Heizungssteuerung über GPIO per IPS

  6. #6
    Registriert seit
    Aug 2009
    Ort
    Lippe
    Beiträge
    1,896

    Achso locale,
    damit hatte ich schon mal Probleme auf dem Tinkerboard, da die bei der Installation nicht richtig war.
    Auch da ist IPS nicht gestartet.
    lg Thomas
    IPS Raspberry Pi2(3) mit LCN, HM, Sonoff+Shelly per MQTT, SONOS und viel Eigenbau + Pi2(3) mit Heizungssteuerung über GPIO per IPS

  7. #7
    Registriert seit
    Jan 2012
    Beiträge
    509

    Zitat Zitat von paresy Beitrag anzeigen
    Bei GDB musst du über die SIGILL per c + ENTER drüber. Mich wundert dass es ohne locale ganz abstürzt.

    Auf dem Pi geht es unter Buster.

    paresy
    danke für den Tip. Dann kommt folgende Fehlermeldung:
    Code:
    *** IP-Symcon starting
    08/03/19 20:48:07 | 00000 | Kernel | Creating...
    08/03/19 20:48:07 | 00000 | Kernel | Platform: Raspberry Pi
    08/03/19 20:48:07 | 00000 | Kernel | Version: 5.2
    08/03/19 20:48:07 | 00000 | Kernel | Revision: 2e4fc9c1957c4c8b2a078b835b3bb5b3d9f5421d
    08/03/19 20:48:07 | 00000 | Kernel | Build: 07/31/19
    08/03/19 20:48:07 | 00000 | Kernel | WorkingDir: /var/lib/symcon/
    08/03/19 20:48:07 | 00000 | Kernel | SystemDir: /usr/share/symcon/
    08/03/19 20:48:07 | 00000 | Kernel | LogDir: /var/log/symcon/
    08/03/19 20:48:07 | 00000 | Kernel | Boost Version: 1_70
    08/03/19 20:48:07 | 00000 | Kernel | cURL Version: libcurl/7.64.1 OpenSSL/1.1.1b zlib/1.2.11
    08/03/19 20:48:07 | 00000 | Kernel | Git2 Version: 0.28.1
    08/03/19 20:48:07 | 00000 | Kernel | SSH Version: 0.8.7
    08/03/19 20:48:07 | 00000 | Kernel | ZLIB Version: 1.2.11
    08/03/19 20:48:07 | 00000 | Kernel | RapidJSON Version: 1.1.0
    08/03/19 20:48:07 | 00000 | Kernel | OpenSSL Version: OpenSSL 1.1.1b  26 Feb 2019
    08/03/19 20:48:07 | 00000 | Kernel | OpenSSL CertDir: /usr/share/symcon/
    08/03/19 20:48:07 | 00000 | Kernel | OpenSSL CertFile: /usr/share/symcon/cacert.pem
    08/03/19 20:48:07 | 00000 | Kernel | XML2 Version: 20909
    08/03/19 20:48:07 | 00000 | Kernel | XML2 Threads: Yes
    08/03/19 20:48:07 | 00000 | Kernel | PHP Version: 7.3.8
    08/03/19 20:48:07 | 00000 | Kernel | Initializing...
    08/03/19 20:48:07 | 00000 | LocalePool | Creating...
    08/03/19 20:48:07 | 00000 | LocalePool | Detected locale: C
    
    Program received signal SIGSEGV, Segmentation fault.
    0x00505170 in rapidjson::GenericValue<rapidjson::UTF8<char>, rapidjson::CrtAllocator>::FindMember(char const*) ()
    Hat also tatsächlich etwas mit den locales zu tun. Sind aber eigentlich ordentlich konfiguriert....
    viele Grüße
    Jürgen

  8. #8
    Registriert seit
    Jun 2012
    Ort
    House of Dragons @ Lübeck
    Beiträge
    8,901

    Nein, du hast vermutlich nur den lokalen Benutzer umgestellt. Aber nicht für den root unter dem Symcon läuft.
    Michael
    on Win7VM (ESXi): I5, 24GB RAM, HW-RAID5, 3xSat | HW: CCU + 123 Geräte (506ch), EM1000, CUL, 1Wire, XBee, ELRO 433MHz, FritzBox Cable, Android Phone + Tablet, Samsung C-Serie TV +SamyGo-Ext, Onkyo NR| SW: IPS, Apache2(mod_ssl/PHP), MySQL, hMailServer, PRTG, Rising AV, Piwik, RoundCube, Wordpress, WinLIRC, WHS2011, MediaPortal, XBMC

  9. #9
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    21,009

    Zitat Zitat von Nall-chan Beitrag anzeigen
    Nein, du hast vermutlich nur den lokalen Benutzer umgestellt. Aber nicht für den root unter dem Symcon läuft.
    Michael
    Das wirkt eher als wenn die Settings irgendwie kaputt ist. Kann das sein? Ist das ein frisches System?

    paresy

  10. #10
    Registriert seit
    Aug 2009
    Ort
    Lippe
    Beiträge
    1,896

    Versuch mal die locale DE nachzuinstallieren, bzw einzurichten.
    Denn bei dir steht locale: C im Log.
    lg Thomas
    IPS Raspberry Pi2(3) mit LCN, HM, Sonoff+Shelly per MQTT, SONOS und viel Eigenbau + Pi2(3) mit Heizungssteuerung über GPIO per IPS

Ähnliche Themen

  1. Raspbian Buster schon jemand probiert mit Symcon?
    Von power dodge im Forum Mikrocontroller
    Antworten: 2
    Letzter Beitrag: 30.06.19, 21:04
  2. Symcon auf Raspi startet ohne PID (bzw startet nicht)
    Von gros_ibou im Forum Allgemeine Diskussion
    Antworten: 5
    Letzter Beitrag: 30.12.16, 23:46
  3. Antworten: 3
    Letzter Beitrag: 25.11.16, 16:00
  4. Snapshot konnte nicht vom Server geladen werden ! (Konsole startet nicht mehr)
    Von wuppi83 im Forum Allgemeine Diskussion (2.x/3.x)
    Antworten: 6
    Letzter Beitrag: 26.11.14, 14:46