+ Antworten
Seite 2 von 2 ErsteErste 1 2
Ergebnis 11 bis 15 von 15
  1. #11
    Registriert seit
    Nov 2016
    Beiträge
    357

    Danke
    Leider passiert auch mit sudo service lsyncd start nichts Das Log bleibt auch leer. Wie kann ich den überprüfen, ob der Dienst richtig läuft?

    Grüße

  2. #12
    Registriert seit
    Nov 2016
    Beiträge
    357

    Hallo,

    ich habe nun noch mal versucht IPS mit lsyncd auf einen neu installierten RPI4 zum Laufen zu bekommen.
    Folgende Fehlermeldung steht im lsyncd.log:

    Sun May 17 16:22:47 2020 Normal: --- Startup, daemonizing ---
    Sun May 17 16:22:47 2020 Normal: recursive startup rsync: /var/lib/symcon/ -> /home/pi/nas_share/backup_symcon/lib/
    Sun May 17 16:22:47 2020 Normal: recursive startup rsync: /var/log/symcon/ -> /home/pi/nas_share/backup_symcon/log/
    Sun May 17 16:22:47 2020 Normal: recursive startup rsync: /root/ -> /home/pi/nas_share/backup_symcon/root/
    rsync: mkdir "/home/pi/nas_share/backup_symcon/lib" failed: No such file or directory (2)
    rsync error: error in file IO (code 11) at main.c(682) [Receiver=3.1.3]
    rsync: mkdir "/home/pi/nas_share/backup_symcon/root" failed: No such file or directory (2)
    rsync error: error in file IO (code 11) at main.c(682) [Receiver=3.1.3]
    rsync: mkdir "/home/pi/nas_share/backup_symcon/log" failed: No such file or directory (2)
    rsync error: error in file IO (code 11) at main.c(682) [Receiver=3.1.3]
    Sun May 17 16:22:47 2020 Error: Temporary or permanent failure on startup of /var/lib/symcon/ -> /home/pi/nas_share/backup_symcon/lib/. Terminating since "insist" is not set.

    Die Verzeichnisse sind soweit richtig gemountet, ich habe als pi user darin Lese- und Schreibrechte. Warum kann rsync kein Verzeichnis per mkdir unter /home/pi/nas_share/backup_symcon/ erstellen?

    Grüße

  3. #13
    Registriert seit
    Nov 2008
    Beiträge
    526

    Ich sichere schon seit langer Zeit mit dem Tool "Raspibackup" vom Rasperry auf meine Synology NAS!
    Kann ich nur Empfehlen!

  4. #14
    Registriert seit
    May 2006
    Ort
    Hannover
    Beiträge
    3,364

    Ich würde behaupten, dass die Rechte nicht passen bzw. der User nicht richtig eingetragen ist.

    Ich nutze NFS und die IP vom PI mit Schreibrechten, dann benötigst du keinen User und das Mounting geht genau so.
    MfG Ralf

  5. #15
    Registriert seit
    Nov 2016
    Beiträge
    357

    Problem gelöst!
    mit diesen Eintrag in der crontab funktioniert es nun:
    @reboot sleep 30 && lsyncd /etc/lsyncd.conf

    Scheint, als bräuchte der Mountpunkt nach dem Neustart etwas zu lange.

    Grüße

Ähnliche Themen

  1. IPS auf QNAP NAS zu empfehlen?
    Von FRAD im Forum Allgemeine Diskussion
    Antworten: 25
    Letzter Beitrag: 10.11.19, 21:30
  2. IP Symcon@Raspberry Pi: Laufzeit- und Nutzdaten auf USB Stick
    Von homa im Forum Allgemeine Diskussion
    Antworten: 13
    Letzter Beitrag: 21.04.19, 18:00
  3. Raspberry PI USB Umzug auf Synology NAS
    Von Izack im Forum Allgemeine Diskussion
    Antworten: 1
    Letzter Beitrag: 08.08.18, 08:32
  4. Antworten: 10
    Letzter Beitrag: 24.03.14, 15:07
  5. Datenlogging auf USB Stick?
    Von Franky76 im Forum Allgemeine Diskussion (2.x/3.x)
    Antworten: 3
    Letzter Beitrag: 21.08.11, 10:25