+ Antworten
Ergebnis 1 bis 10 von 10
  1. #1
    Registriert seit
    Mar 2016
    Beiträge
    49

    Standard [GELÖST] Registrierung beim Spotify-Modul nicht möglich

    Hallo,

    vorab schon mal vielen Dank für das neue Spotify-Modul, welches heute aus dem Adventskalender plumpste

    Leider scheint bei mir die Registrierung nicht so recht zu klappen. Ich habe wie beschrieben eine Instanz angelegt und versucht über den entsprechenden Button die Registrierung vorzunehmen. Daraufhin erteilte ich auf der Spotify-Webseite die erforderliche Freigabe und wurde zu oauth.ipmagic.de weitergeleitet. Ab da geht es aufgrund eines 500er-HTTP-Fehlers nicht weiter.

    Habe ich etwas falsch gemacht?

    Gruß,
    David

    PS: Der Account ist ein Premium Account
    Geändert von vita (16.12.19 um 12:48 Uhr)

  2. #2
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    22,826

    Hast du den Connect Dienst in IP-Symcon aktiviert?

    paresy

  3. #3
    Registriert seit
    Mar 2016
    Beiträge
    49

    Nein, hatte ich nicht. Nachdem ich ihn eben aktivierte lief auch die Spotify-Registrierung durch. Danke für den Hinweis!

    Muss der Connect-Dienst für die Nutzung des Moduls weiterhin aktiviert bleiben?

  4. #4
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    22,826

    Nein, nur die für Registrierung sollte dieser erforderlich sein, da Spotify an diese Adresse den Token schicken muss.

    paresy

  5. #5
    Registriert seit
    Mar 2016
    Beiträge
    49

    Danke für die schnelle Hilfe! Modul läuft nun

  6. #6
    Registriert seit
    Oct 2011
    Ort
    Hattersheim (Hessen)
    Beiträge
    7,100

    Zitat Zitat von paresy Beitrag anzeigen
    Nein, nur die für Registrierung sollte dieser erforderlich sein, da Spotify an diese Adresse den Token schicken muss.
    Läuft der Token nicht regelmäßig aus? Bei einem regelmäßigen Refresh braucht man dann doch auch den Connect Dienst aktiv oder?

  7. #7
    Registriert seit
    Mar 2016
    Beiträge
    49

    Konnte das gerade zufällig im Debug-Log der Instanz beobachten. Das Auffrischen des Tokens lief erfolgreich ohne Connect-Dienst durch:

    Code:
    TXT: 16.12.2019, 15:02:32 |     FetchAccessToken | OK! Access Token is valid until 16.12.19 15:03:13
    ...
    TXT: 16.12.2019, 15:03:30 |     FetchAccessToken | Use Refresh Token to get new Access Token!
    TXT: 16.12.2019, 15:03:31 |     FetchAccessToken | CACHE! New Access Token is valid until 16.12.19 16:03:31

  8. #8
    Registriert seit
    Oct 2013
    Beiträge
    80

    Zitat Zitat von paresy Beitrag anzeigen
    Nein, nur die für Registrierung sollte dieser erforderlich sein, da Spotify an diese Adresse den Token schicken muss.
    Servus paresy, ist es nicht möglich, dem Benutzer die Möglichkeit zu geben, eine benutzerdefinierte Adresse angeben zu können?

  9. #9
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    22,826

    Unmöglich. Die OAuth2 Authentifierung erfordert einen festen Endpunkt.

    Du kannst jedoch eine eigene API bei Spotify anmelden und das ganze Modul forken und gegen deinen Endpoint umbauen. Das ist jedoch massig viel Arbeit, da du dafür einen vollwertigen OAuth2 noch einbauen musst.

    paresy

  10. #10
    Registriert seit
    Oct 2013
    Beiträge
    80

    Zitat Zitat von paresy Beitrag anzeigen
    Unmöglich. Die OAuth2 Authentifierung erfordert einen festen Endpunkt.
    Du kannst jedoch eine eigene API bei Spotify anmelden und das ganze Modul forken und gegen deinen Endpoint umbauen. Das ist jedoch massig viel Arbeit, da du dafür einen vollwertigen OAuth2 noch einbauen musst.
    Danke für die Info. Solange das Modul dann auch weiterläuft wenn mal die Subskribtion ausläuft ist alles gut :-)

Ähnliche Themen

  1. Spotify Modul Lautstärke
    Von Fonzo im Forum PHP-Module
    Antworten: 0
    Letzter Beitrag: 16.12.19, 10:59
  2. Antworten: 3
    Letzter Beitrag: 30.12.18, 23:45
  3. Pumpe-EIN Registrierung (aber wie?)
    Von Heiko123 im Forum 1-Wire, M-BUS
    Antworten: 3
    Letzter Beitrag: 14.05.11, 18:37
  4. Installation Schnittstelle / Registrierung
    Von MarkusTC im Forum Allgemeine Diskussion
    Antworten: 2
    Letzter Beitrag: 02.04.05, 21:43