+ Antworten
Seite 1 von 4 1 2 3 ... LetzteLetzte
Ergebnis 1 bis 10 von 33
  1. #1
    Registriert seit
    Mar 2007
    Beiträge
    175

    Standard Hilfe! Anfänger sucht "Hallo Welt" für Wago

    Hallo,
    ich versuche schon eine ganze Weile Infos zum Thema "Wago einrichten mit IPS" zu bekommen.
    Viele Anfragen betreffen "was brauche ich? usw." und die anderen haben zu schon laufende Projekte Anfragen. Einige hatte auch den Wunsch geäußert einen eigenen "Wago-Bereich" zu eröffnen, das wäre auch mein Wunsch.
    Da sich in diesem Forum einige Wago Fachleute befinden, möchte ich hier fragen ob ihr mir beim einrichten helfen könntet?
    Vielleicht kann man damit gleich den neuen "Wago-Bereich" eröffnen?

    Ich habe zum testen folgendes aufgebaut:
    • 1x 750-342
    • 2x 750-403 4DI 24V
    • 1x 750-504 4DO 24V
    • 1x 750-513 2Kanal Relais mit 2 Schließer


    Ich möchte am 4DI Taster anschließen und damit (mit IPS) Ausgänge am DO schalten und mit 2 weiteren Taster das 2Kanal Relais steuern!

    weiteres habe ich im IPS Configuration Panel getan:

    Instances

    Instances>(rechts Klick) I/O> Wago I/O Modbus ausgewählt
    • danach wurde ein violettes Symbol mit #46639 Wago I/O Modbus erstellt


    • doppel Klick auf Symbol #46639>Connection IP Adresse vergeben



    Variables

    Variables>(rechts Klick auf IP-Symcon)>Add Variable>Name:750-403,Type:Boolean>o.k
    Variables>(rechts Klick auf IP-Symcon)>Add Variable>Name:750-504,Type:Boolean>o.k
    Variables>(rechts Klick auf IP-Symcon)>Add Variable>Name:750-513,Type:Boolean>o.k

    • Nun sind im "Treeview" unter IP-Symcon 3 rot unterlegte Zeilen vorhanden


    danach zurück auf Instances und dann (doppel Klick) auf Symbol "#46639", es öffnet sich ein Fenster "Wago I/O Modbus-Configuration"

    Data>Variables

    Mit Button "New" 3 Zeilen erstellt und durch Klick auf "Not assinged yet" jeweils aus dem sich öffnenden "Variable Selector-Fenster" 750-403, 750-504 & 750-513 ausgewählt


    Variable 750-403
    • Address = 0
    • Size = Bit
    • Poll Interval = 50ms


    Variable 750-504
    • Address = 512
    • Size = Bit
    • Poll Interval = 50ms


    Variable 750-513
    • Address = 0
    • Size = Bit
    • Poll Interval = 50ms


    Da ich nicht weiß was ich getan, noch ob ich etwas richtig gemacht habe nun was muß ich machen damit IPS die LED's an den Klemmen zum Leuchten bringt?

    Danke
    Geändert von inspiron (06.01.08 um 21:10 Uhr)

  2. #2
    Registriert seit
    Jul 2005
    Ort
    Roeselare - Belgium
    Beiträge
    1,394

    Ein commando senden ?
    Guck mal mit [CTRL] + [SPACE] im php-editor was fur commando's du nutzen kannst - oder hier zb: http://www.ipsymcon.de/wiki/index.php/WAGO_I/O

    Happy hunting
    All electric machines work on smoke... when the smoke escape from machines... they don't work anymore

  3. #3
    Registriert seit
    Mar 2007
    Beiträge
    175

    Zitat Zitat von GGGss Beitrag anzeigen
    Ein commando senden ?
    Guck mal mit [CTRL] + [SPACE] im php-editor was fur commando's du nutzen kannst - oder hier zb: http://www.ipsymcon.de/wiki/index.php/WAGO_I/O

    Happy hunting
    Commandos?????
    davon mal abgesehen habe ich mir schon gedacht das es ohne php nicht gehen wird.
    Bevor ich mich damit befasse muß ich doch Wissen ob das was ich bis jetzt gemacht habe richtig ist.

  4. #4
    Registriert seit
    Sep 2005
    Beiträge
    17

    Hallo Inspiron.

    die Ausgänge der Wago Steuerung kannst Du mit den Befehl MBT_WriteCoil und mit true und false ansteuern.


    $wago_id = 29373; //hier musst du die ID deiner Wago Steuerung eintragen.
    MBT_WriteCoil($wago_id,0, true);
    MBT_WriteCoil($wago_id,1, true);
    MBT_WriteCoil($wago_id,2, true);
    MBT_WriteCoil($wago_id,3, true);
    Die Abfrage der Ein und Ausgänge, ob sie eine 1 oder eine 0 haben, Erfolgt über Variablen. Du kannst/musst jedem Ein- Ausgang den du hast, eine Variable zuweisen. In deinem Fall je vier für DI und Vier für DO. Die Adressierung der Variablen muss aber stimmen. Mit den Adressen 1 bis 511 kannst du die Eingänge abfragen, und mit 512 bis 1023? kannst du die Ausgänge abfragen. Wichtig ist auch noch eine Poll Zeit einzustellen, sonnst kommt nichts an. Hab noch ein Beispiel meiner Konfiguration angefügt.

    Gruß Jochen

  5. #5
    Registriert seit
    Mar 2007
    Beiträge
    175

    Zitat Zitat von Fidi Beitrag anzeigen
    Hallo Inspiron.

    die Ausgänge der Wago Steuerung kannst Du mit den Befehl MBT_WriteCoil und mit true und false ansteuern.



    Gruß Jochen
    Hallo,
    das ist doch schon ein Anfang nur wo genau schreibe ich diese Abfragen ein?
    Muß ich bei EventScrpts ein neues Script erstellen?

  6. #6
    Registriert seit
    Sep 2005
    Beiträge
    17

    Ja, du kannst die paar Zeilen von oben einfach in ein neues Script einfügen.

    Gruß Jochen

  7. #7
    Registriert seit
    Mar 2007
    Beiträge
    175

    Juchu sie leuchten!
    Es ist doch erstaunlich, wie so eine kleine leuchtende LED, einem Freude entlocken kann!

    Es funktioniert allerdings erst wenn ich auf "Execute" im Script drücke. Wie wird denn das Script beim starten der ISP ausgeführt?

  8. #8
    Registriert seit
    Mar 2006
    Beiträge
    3,423

    Hi!

    Zitat Zitat von inspiron Beitrag anzeigen
    Wie wird denn das Script beim starten der ISP ausgeführt?
    z.B. durch Triggerevents
    , oder IPS_Runscript von einem anderen Script aus.
    Gruß nancilla

  9. #9
    Registriert seit
    Mar 2007
    Beiträge
    175

    mhh, wo trage ich das denn nun wieder ein. Im "Welcome.script", was macht das eigendlich?

  10. #10
    Registriert seit
    Mar 2007
    Beiträge
    175

    Standard Wie schalten?

    Wie kann ich denn jetzt sagen, wenn Taster an DI1 gedrückt, dann an

    • MBT_WriteCoil($wago_id,512, true); //4DO 1.1


    auch an?

Ähnliche Themen

  1. Anfänger Plant komplettumbau mit FS20 System und braucht Hilfe !
    Von drcracker im Forum Sonstige Funkkomponenten / Wetterstationen
    Antworten: 5
    Letzter Beitrag: 29.12.07, 18:00
  2. Hilfe für Anfänger - allgemeine Grundbegriffe
    Von Evo121 im Forum Beleuchtung / Lichttechnik
    Antworten: 9
    Letzter Beitrag: 24.01.07, 21:53
  3. Neuling sucht Hilfe
    Von Slottke im Forum Allgemeine Diskussion
    Antworten: 5
    Letzter Beitrag: 11.06.05, 21:50