+ Antworten
Ergebnis 1 bis 6 von 6
  1. #1
    Registriert seit
    May 2016
    Beiträge
    6

    Standard WAGO 750-842 PFC Eth Socket 502 Problem

    Hallo,

    ich habe mir 3 Wago Controller als SLAVES zum Steuern meiner Aktoren gekaufen.

    Generell funktioniert alles wirklich problemlos - zumindest eine gewisse Zeit.
    Mein IP-Symcon PC mit jeden Tag in der Nacht einen Reboot und verbindet sich nach
    dem Hochfahren wieder automatisch selbst mit den Gateways (Homematic / Wago).

    Leider hat IP-Symcon mit allen 3 Controllern das gleiche Problem. Nach einer gewissen
    Zeit kann sich IP-Symcon nicht mehr mit der Wago über das Client-Socket mit der IP
    und Port 502 verbinden. Den Wago Controller kann ich problemlos per Ping ansprechen
    und bekomme eine Antwort. Auch der Neustart von IP-Symcon bzw. den kompletten PC
    bringt nicht die Lösung. Wenn ich dagegen den Wago Controller kurz vom Strom nehme
    und der Wago Controller neu gestartet hat, funktioniert auch die Verbindung zwischen
    IP-Symcon und Wago wieder.

    Kennt jemand diesen Fehler bzw. die Lösung? Muss man im Wago Controller unter Watchdog
    evtl. was einstellen? Gibt es eine Möglichkeit den Wago Controller über einen Befehl aus
    IP-Symcon täglich neu zu starten (natürlich muss der Wago Controller dieser Zeit noch normal
    arbeiten). Die Idee wäre, den Wago Controller vielleicht über einen Link neu starten zu
    können.

    Aktuell habe ich Homematic Funkstecken für die Wago Controller gesteckt, welche nachts
    die Wago Controller kurz stromlos machen. Seitdem habe ich keine Probleme mit der
    Verbindung.

    Viele Grüße

    BMatzy

  2. #2
    Registriert seit
    Mar 2009
    Ort
    Neuwieder Becken
    Beiträge
    337

    Vermutlich hast du irgendeinen Speicherüberlauf o.ä. in der Wago durch die Abfragen. Wie viele Datenpunkte fragst du in welchem Intervall ab?
    Wago 740-881 102 DO + 96DI - 1-Wire OWOS (8x DS1820) - DALI (12 Endgeräte)
    AVR NET IO (ArtNET + k8io), Arduino (3x Wiegand26 Sebury K3)
    IP-Symcon 3.3 auf Windows Server 2008R2 C2D 2x2,8GHz 4GB Ram

  3. #3
    Registriert seit
    May 2016
    Beiträge
    6

    Eigentlich frage ich nichts ab, sondern sende direkt an die DO und das ist auch nicht zu häufig. Wenn mal viel Verkehr drauf ist, dann dann vielleicht alle 1-5min. 10 DO.

    Für alle die auch so ein Problem haben:

    Einrichten eines Modbus Devices mit:
    Adresse 8256 / WORD / Funktion (Schreiben) - Schreibe Single Register (06)

    In einem Script dann an diese Adresse den Wert 21930 schicken:
    ModBus_WriteRegisterWord(ID-Modbus Device, 21930);
    IPS_Sleep(3000);
    IPS_SetProperty(ID-Modbus Gateway, "Open", TRUE);
    IPS_ApplyChanges(ID-Modbus Gateway);

    Dies wird nun jeden Tag in der Nacht ausgeführt und sollte meine Probleme beheben.

    Falls jemand noch eine bessere Idee hat, bitte melden.


    Viele Grüße

    BMatzy

  4. #4
    Registriert seit
    May 2016
    Beiträge
    6

    Was mir noch eingefallen ist, ich hatte im Wago Controller mit dem Tool "WAGO Ethernet Settings" unter dem Register "MODBUS" den Watchdog (ms) auf 0 gesetzt, da vorher sehr viele Abbrüche hatte.


    Viele Grüße

    BMatzy

  5. #5
    Registriert seit
    Jun 2012
    Ort
    House of Dragons @ Lübeck
    Beiträge
    10,561

    Wenn du den auf 0 setzt, hast du vermutlich das Timeout deaktiviert.
    Wenn dann z.b. beim Neustart deines Rechners Symcon nicht sauber die Verbindung zur Wago trennt, bleibt die Verbindung in der Wago bestehen.
    Irgendwann nimmt sie dann einfach keine neuen Verbindungen entgegen.
    Ein sinnvoller Wert liegt über den kleinsten Intervall eine Abfrage/Steuerung an die Wago und unter der Zeit die dein Rechner zum neu starten braucht.
    Michael
    on Win10VM (ESXi): I7, 32GB RAM, HW-RAID5, 2xSat | HW: pivccu + ca.130 Geräte (ca.550ch), EM1000, CUL, 1Wire, FritzBox Cable, Android Phone + Tablet, Onkyo NR| SW: IPS, Apache2(mod_ssl/PHP), MySQL, hMailServer, PRTG, RoundCube, Win2016 Ess., MediaPortal, Kodi

  6. #6
    Registriert seit
    May 2011
    Beiträge
    330

    Hallo Bmatzy,

    hast du dein Problem lösen können?
    Ich habe exakt die gleiche Problematik wie in deinem Eingangspost beschrieben, ebenfalls mit einer Wago 842 (Firmware 05.05.02)

    Kannst du die von Nall-Chan beschriebene Thematik mit dem TimeOut bestätigen oder dementieren? Laut Web-Recherche sind wohl alle oder viele 842er standardmäßig auf 0 ms eingestellt. Ebenso wie meine.
    Edit: ich habe den Timeout gerade mal testweise auf 60 Sekunden stellen können. Nun muss ich einige Tage/Wochen beobachten. Melde mich dann.

    Deinen Modbus-Befehl fürs Soft-Reset werde ich mal testen - das ist für mich aber letztlich nicht des Rätsels Lösung, weil ich ja keine ModBus-Befehle mehr absetzen kann, sobald das Problem wirklich aufgetreten ist. Du resettest die SPS also einfach vorsorglich einmal täglich?

    Viele Grüße,
    ika
    Geändert von ika (11.09.20 um 13:50 Uhr)

Ähnliche Themen

  1. Wago 750-842 Modbus Prodblem
    Von lego im Forum SPS Automatisierungstechnik
    Antworten: 18
    Letzter Beitrag: 21.10.19, 15:28
  2. Frage zur Wago 750-842
    Von FeuerTeufel im Forum SPS Automatisierungstechnik
    Antworten: 12
    Letzter Beitrag: 18.04.19, 20:43
  3. Wago 750-842 Modbus/TCP Socket getrennt
    Von firebuster im Forum SPS Automatisierungstechnik
    Antworten: 47
    Letzter Beitrag: 07.01.15, 16:41
  4. WAGO 750-841 langsamer als 750-842 ?
    Von rene im Forum SPS Automatisierungstechnik
    Antworten: 1
    Letzter Beitrag: 22.04.12, 10:38
  5. Wago 750-842 alte Firmware
    Von Gorilatzu im Forum SPS Automatisierungstechnik
    Antworten: 2
    Letzter Beitrag: 06.04.12, 19:32

Stichworte