+ Antworten
Seite 13 von 17 ErsteErste ... 3 11 12 13 14 15 ... LetzteLetzte
Ergebnis 121 bis 130 von 163
  1. #121
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    24,076

    Stimmt Datum und Uhrzeit in deinem Ubuntu System?

    paresy

  2. #122
    Registriert seit
    Mar 2013
    Ort
    Issum
    Beiträge
    719

    Hallo paresy,

    das wars. Zeitzone stimmte nicht. Vielen Dank für die schnelle Hilfe.
    KNX / IPS unl. auf Tinkerboard S / IPSView / Amazon Echo und vieles mehr

  3. #123
    Registriert seit
    Oct 2017
    Beiträge
    573

    Moin,

    und bei mir seit 2 Tagen ruhe und keine Auffälligkeiten.

    Gruß
    IPS Professional meist aktuellste stable. Auf einen Qnap / Docker.
    Tasmota, MQTT, Sonoff etc.

  4. #124
    Registriert seit
    Feb 2017
    Beiträge
    2,171

    Erst einmal herzlichen Dank für eure ganzen Beobachtungen! Leider habe ich bisher noch nichts gefunden, ich bin aber weiterhin am Ball. Daher habe ich auch mal eine neue Debug-Version gebaut. Diese schreibt für jede Variable alle Dateien der letzten Stunde ins Log mit welchen die neue Stundenaggregation bei einem Neustart geschrieben wird und auch das Ergebnis. Wenn man dann wieder einen Ausreißer sieht, dann kann man schauen, wo hier die Differenzen stecken. Je nach Systemgröße könnte das beim Start einiges an Text sein. Die entstehenden Daten würden mir allerdings ungemein helfen.

    Die Downloads findet ihr hier:
    - Windows: https://apt.symcon.de/pool/symcon/wi...eros_amd64.exe
    - Ubuntu: https://apt.symcon.de/pool/symcon/ub...eros_amd64.deb
    - Raspberry: https://apt.symcon.de/pool/symcon/rp...eros_armhf.deb

    Wenn ihr dann nach einem Neustart einen Ausreißer bei einer Variablen entdeckt, dann wäre der Abschnitt im Log nach "Aktualisiere Aggregationsdaten für Variable... #12345" von der entsprechenden ID spannend. Am einfachsten macht ihr das auf altbewährtem Weg:
    - Vor dem Neustart ein Backup machen
    - Neustarten
    - Fehlerhafte Variable finden
    - Auf Abschluss der laufenden Stunde warten, damit der Ausreißer auch in den Dateien landet
    - Ein Dateipaket zusammensammeln mit:
    - Rohdaten des aktuellen Monats von der fehlerhaften Variable aus dem Backup
    - Aggregationsdateien der Variable, sowohl aus dem Backup als auch die aktuellen
    - Eure Logdatei

    Ich freue mich auf eure Rückmeldungen und besten Dank für eure Unterstützung! Dann können wir den Fehler hoffentlich langsam mal finden und beheben

    @PC Oldie: Ich bin heute nicht dazu gekommen, ich schaue mir den Fehler aber definitiv noch einmal an. Aktuell liegt mein Fokus auf den Ausreißern zur Null.

  5. #125
    Registriert seit
    Oct 2017
    Beiträge
    573

    Moin,

    kurze Frage dazu. Kriege ich einer der Versionen auch in einem Docker installiert? Qnap bei mir.

    Gruß
    IPS Professional meist aktuellste stable. Auf einen Qnap / Docker.
    Tasmota, MQTT, Sonoff etc.

  6. #126
    Registriert seit
    Dec 2011
    Beiträge
    146

    So, ich habe mal die Testversion installiert.
    Bei mir ist jetzt der 16 und 20.10. betroffen, siehe Grafik. Ich habe nur ein Backup von gestern. Variablen ID 47153.
    Sicherung von heute Nacht 04:00 Ich hatte mal wieder nicht dran gedacht, dass beim Installieren des deb Paketes Symcon automatisch gestartet wird. Die Variable ist Float. Es handelt sich um einen PV Ertragszähler, der nur ganze kWh zählt. Erfassung über Homematic, falls es irgendwie eine Rolle spielen sollte.
    Diesen Fehler habe ich so in der Vergangenheit nicht gehabt. Der Zähler wird seit ca. einem Jahr erfasst. Die Option Ignoriere geloggte Nullen habe ich noch nicht gesetzt. Vielleicht hilft es ja.

    Der Fehler verschwindet, sobald ich die Variable von Hand im Archivhandler reaggregiere. Ich habe auch diese Daten mal angehängt.

    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	graph01.png 
Hits:	18 
Größe:	113.5 KB 
ID:	55835
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	var01.jpg 
Hits:	14 
Größe:	34.8 KB 
ID:	55839
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	var02.jpg 
Hits:	15 
Größe:	65.9 KB 
ID:	55840
    Angehängte Dateien Angehängte Dateien
    Geändert von mj04 (21.10.20 um 19:35 Uhr)

    Gruß Martin

    Systeme: IPSymcon 5.5 auf Raspberry 4B
    Hardware: KNX, Siemens Logo 0BAX, Homematic, ESP32, Raspberry, NUKI, Froggit WH4000SE

  7. #127
    Registriert seit
    Dec 2011
    Beiträge
    146

    PS:
    so sieht der Graph korrekt aus.

    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	graph02.jpg 
Hits:	18 
Größe:	185.4 KB 
ID:	55842

    Gruß Martin

    Systeme: IPSymcon 5.5 auf Raspberry 4B
    Hardware: KNX, Siemens Logo 0BAX, Homematic, ESP32, Raspberry, NUKI, Froggit WH4000SE

  8. #128
    Registriert seit
    Feb 2017
    Beiträge
    2,171

    Danke für die Daten! So wie es aussieht, kommt der Fehler nicht direkt beim Neustart, denn laut den geloggten Daten sieht das alles richtig aus. Möglicherweise merkt sich die Variable aber nach dem Neustart einen falschen Referenzwert für die nächsten Zählerwerte. Daher habe ich das Debug noch einmal erweitert. Jetzt wird am Ende der initialen Vorbereitungen noch einmal der aktuelle Stand für jede Variable ausgegeben. Dann können wir mal schauen, ob es dort irgendwo einen Fehler gibt. Das hilft mir dann wieder weiter, wo ich als nächstes schauen muss...

    Die neuen Versionen findet ihr hier:

    - Windows: https://apt.symcon.de/pool/symcon/wi...eros_amd64.exe
    - Ubuntu: https://apt.symcon.de/pool/symcon/ub...eros_amd64.deb
    - Raspberry: https://apt.symcon.de/pool/symcon/rp...eros_armhf.deb

    @power dodge: Docker ist leider ein bisschen umständlicher, da ich die Versionen eigentlich nicht als "reguläre" IP-Symcon-Versionen rausbringen möchte... Da wir momentan ja trotzdem vorankommen, würde ich erst einmal nicht die Energie in eine Debug-Docker-Version investieren. Besten Dank aber für das Angebot!

  9. #129
    Registriert seit
    Dec 2011
    Beiträge
    146

    So, hab mit der neuen Debug Version getestet. Ich habe mal die Variable ID 31798 genommen. Diese weist den Fehler weiterhin auf.
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	v01.jpg 
Hits:	14 
Größe:	154.5 KB 
ID:	55851
    Im Anhang mal die Daten von vor dem Update (v5.5-83), nach dem Update (v5.5-84) und aktuelle vom Neustart Logfiles. Die 31798 werde ich jetzt mal nicht reaggregieren.
    Diesmal habe ich die Daten direkt vor dem Update gesichert.

    Ich hab zwei Logs angehängt, damit alles vollständig ist.
    Angehängte Dateien Angehängte Dateien
    Geändert von mj04 (22.10.20 um 14:55 Uhr) Grund: Weitere Logfiles

    Gruß Martin

    Systeme: IPSymcon 5.5 auf Raspberry 4B
    Hardware: KNX, Siemens Logo 0BAX, Homematic, ESP32, Raspberry, NUKI, Froggit WH4000SE

  10. #130
    Registriert seit
    Feb 2017
    Beiträge
    2,171

    Danke für das Feedback! "Leider" sieht weiterhin alles korrekt aus... Kannst du mir vielleicht mal ein vollständiges Backup von dir irgendwo hochladen? Dann könnte ich mal ausprobieren, ob der Fehler dann auch bei mir auftritt... Das würde den Suchvorgang deutlich beschleunigen. Ansonsten befürchte ich, das könnte mit den Debug-Versionen noch ein bisschen hin und her gehen...

Ähnliche Themen

  1. Frage zur Beschattung
    Von Alex0815 im Forum IPSStudio & IPSView
    Antworten: 4
    Letzter Beitrag: 29.02.16, 21:52
  2. Antworten: 2
    Letzter Beitrag: 17.03.14, 23:36
  3. Frage zur IPhone AP
    Von pinki99 im Forum Mobile (iOS/Android)
    Antworten: 7
    Letzter Beitrag: 10.01.11, 03:09
  4. Zur Lizenzmodellüberarbeitung
    Von Smudo im Forum Allgemeine Diskussion (2.x/3.x)
    Antworten: 11
    Letzter Beitrag: 02.08.10, 11:33
  5. Frage zur Registervariable
    Von Jannis im Forum Allgemeine Diskussion (2.x/3.x)
    Antworten: 4
    Letzter Beitrag: 29.05.09, 13:41