+ Antworten
Seite 14 von 17 ErsteErste ... 4 12 13 14 15 16 ... LetzteLetzte
Ergebnis 131 bis 140 von 163
  1. #131
    Registriert seit
    Dec 2011
    Beiträge
    147

    Hallo,

    ich finde es auch irgendwie crazy. Ich schicke dir mal einen Link mit dem Gesamtprojekt per PN. Kann etwas dauern.
    Ich meine mich mal entsinnen zu können, dass ich mal ein Problem mit einer Zählervariablen hatte, wo quasi der gleiche Wert gespeichert wurde. Da hatte sich durch Berechnungen in der Nachkommastelle eine minimale Abweichung ergeben, so dass der neue Wert oft minimal kleiner als der alte Wert war. Habe ich später programmtechnisch abgefangen. Da kam es dann auch zu solchen Effekten.

    Gruß Martin

    Systeme: IPSymcon 5.5 auf Raspberry 4B
    Hardware: KNX, Siemens Logo 0BAX, Homematic, ESP32, Raspberry, NUKI, Froggit WH4000SE

  2. #132
    Registriert seit
    Feb 2017
    Beiträge
    2,188

    Vielleicht hat es sich erledigt. Ich hatte noch eine Rückmeldung per Mail bekommen und der hat das Problem möglicherweise gefunden. Ich habe den Fix mal schnell gebaut: Bitte testet das gerne, damit wir mit dem Fehler dann auch hoffentlich abschließen können:

    - Windows: https://apt.symcon.de/pool/symcon/wi...uild_amd64.exe
    - Ubuntu: https://apt.symcon.de/pool/symcon/ub...uild_amd64.deb
    - Raspberry: https://apt.symcon.de/pool/symcon/rp...uild_armhf.deb

    Reaggregiert am besten vor der Installation noch einmal alle Variablen, damit sich hier keine vorherigen Fehler mit einschleichen. Und dann meldet euch nach mal nach der Installation, ob der Fehler weiterhin auftritt oder nicht.

  3. #133
    Registriert seit
    Dec 2011
    Beiträge
    147

    Hallo,

    ich habe die neue Version eingespielt. Davor habe ich alle Variablen reaggregiert. Der Fehler verschwindet bei Gesamtaggregation nicht. Ich habe jetzt die Variable einzeln reaggregiert. Das korrigiert den Fehler. System werde ich jetzt nochmal komplettneu starten und weiter beobachten. Ich werde berichten.
    Falls notwendig, kann ich dir dann nochmal komplette Backups zur Verfügung stellen (dann per PN).

    Gruß Martin

    Systeme: IPSymcon 5.5 auf Raspberry 4B
    Hardware: KNX, Siemens Logo 0BAX, Homematic, ESP32, Raspberry, NUKI, Froggit WH4000SE

  4. #134
    Registriert seit
    Oct 2010
    Ort
    Paderborn
    Beiträge
    2,904

    Zitat Zitat von mj04 Beitrag anzeigen
    Der Fehler verschwindet bei Gesamtaggregation nicht. Ich habe jetzt die Variable einzeln reaggregiert.
    Hallo Martin,

    das kann eigentlich nicht sein. Die Gesamtaggregation reaggregiert jede Variable einzeln. Man kann es auch am Datum der csv-Dateien im db Verzeichnis sehen.

    Burkhard
    HM per RaspberryMatic | EKM-868 | LGS-868 | 1 Wire | Fibaro Motion Sensor & Aeon Labs Z-Stick S2 | SONOS | Denon AVR 3312 | Vu+ Ultimo 4K | Sony KD-75XE9405 | Fritzbox 6360 | Hikvision DS-2CD2686G2-IZS | Echo Dot + Show | Stall.biz AirSniffer | Vaillant eBUS | Intel NUC i3 | IPS V5.5 Beta

  5. #135
    Registriert seit
    Dec 2011
    Beiträge
    147

    Hallo Burkhard,

    schön von dir zu hören. Ich geb dir da absolut Recht. Das komische ist, dass der Fehler erst seit der 5.5 auftritt. Ich verstehe das auch nicht wirklich. Offensichtliche Fehler in den Dateien habe ich auch nicht finden können. Ich sehe nur das graphische Ergebnis.
    Ich habe jetzt alles rebootet und nochmal Gesamtaggregiert. Jetzt scheint es erstmal ok zu sein. Soweit ich das beim "durchzappen" der Variablen feststellen konnte, hat es auch nur die PV Zählervariablen betroffen. Ich halte das mal im Auge. Nicht das es durch Zufall ein Fehler in meinem System ist, der genau zum Zeitpunkt der 5.5er Umstellung aufgetreten ist.

    PS: Ich habe demnächst mal wieder etwas Zeit für SMA Sorry, dass ich mich solange nicht gemeldet habe. Bei mir war sowas von Land unter...

    Gruß Martin

    Systeme: IPSymcon 5.5 auf Raspberry 4B
    Hardware: KNX, Siemens Logo 0BAX, Homematic, ESP32, Raspberry, NUKI, Froggit WH4000SE

  6. #136
    Registriert seit
    Oct 2010
    Ort
    Paderborn
    Beiträge
    2,904

    Standard Archivumbau zur 5.5

    Hallo Martin,

    kein Problem, SMA kann warten

    Bei meinen Zählervariablen ist nun mit dem letzten Teststand alles wieder in Ordnung - auch nach mehreren Neustarts und mehreren Stunden.

    Betroffen war wohl nur die Stundenaggregation bei Zählern. Meinem Eindruck nach waren vor allem Zähler betroffen, die sich über eine Stunde hinweg mal nicht geändert haben

    Aber da klärt uns Niels vielleicht noch auf

    Burkhard
    Geändert von bumaas (22.10.20 um 23:04 Uhr)
    HM per RaspberryMatic | EKM-868 | LGS-868 | 1 Wire | Fibaro Motion Sensor & Aeon Labs Z-Stick S2 | SONOS | Denon AVR 3312 | Vu+ Ultimo 4K | Sony KD-75XE9405 | Fritzbox 6360 | Hikvision DS-2CD2686G2-IZS | Echo Dot + Show | Stall.biz AirSniffer | Vaillant eBUS | Intel NUC i3 | IPS V5.5 Beta

  7. #137
    Registriert seit
    Feb 2017
    Beiträge
    2,188

    Hallo Burkhard,

    genau das war das Problem. Wenn beim Start noch keine Rohwerte für die laufende Stunde existierten, dann wurde der Referenzwert für das nächste Schreiben der Aggregationswerte nach der initialen Vorbereitung falsch gesetzt und halt wohl den Sprung verursacht. Es freut mich, dass es scheinbar wieder korrekt läuft! Dann bringen wir heute damit auch den RC2 raus.

  8. #138
    Registriert seit
    May 2008
    Ort
    Forstern
    Beiträge
    1,367

    Hi Niels,

    das klingt sehr plausibel. Wenn ich mir jetzt meine Variablen anschaue die betroffen waren, dann sind das Werte die täglich, max. stündlich geschrieben wurden. Erläuterungen passt jedenfalls zu meinen Variablen!

    Danke
    Heiko


    Gesendet von iPhone mit Tapatalk
    SERVER: FB 7490, RaspPi 3 B+, CCU2 und IP-Symcon V5.5 (Ninja) | SYSTEME: Amazon ECHOs, Apple TVs, Homematic/IP, LevelJet, Logitech Harmony, Magic Home, Pioneer AVR, Philips Hue, Samsung TV's, Somfy RFX, Tasmota- , Shelly- & Zigbee-Geräte, Apple & Android Handys & Tablets | MODULE: Almanac, Awido, Toolmatic Reihe (5x), Magic Home Controller, Pollenflug, Twinkly | SKINS: WwxSkin

  9. #139
    Registriert seit
    Dec 2011
    Beiträge
    147

    Hallo Niels,

    bei mir sieht es jetzt auch gut aus. Bei mir waren auch Werte wie bei pitti betroffen. Z. B. PV Zählervariablen, die sich nur tagsüber ändern. Und seit Beginn der wetterbedingten grauen Zeiten - bei uns jedenfalls - nur wenig ändern.

    Ich hatte gestern auch einige Symcon Restarts gemacht. Ebenso heute morgen. Alle Werte sind nach wie vor ok.
    Geändert von mj04 (23.10.20 um 09:20 Uhr) Grund: Tippfehler über Tippfehler :-(

    Gruß Martin

    Systeme: IPSymcon 5.5 auf Raspberry 4B
    Hardware: KNX, Siemens Logo 0BAX, Homematic, ESP32, Raspberry, NUKI, Froggit WH4000SE

  10. #140
    Registriert seit
    May 2006
    Ort
    Hannover
    Beiträge
    3,569

    Ich habe auch noch Probleme mit Zählern, meist wird der Gesamtwert an einem Tag angezeigt, obwohl die Varaiable auf Zähler steht.

    Meinen Versuch zu Aggregieren habe ich gerade abbrechen wollen, da der PI3B+ extrem zäh wurde.

    Das Ergebnis ist ein Absturz von symcon und ein crashdump
    Code:
    Stack trace (most recent call last) in thread 24348:
    #2    Object "/lib/arm-linux-gnueabihf/libc.so.6", at 0x76cca12f, in
    #1    Object "/usr/bin/symcon", at 0xf7419f, in backward::SignalHandling::sig_handler(int, siginfo_t*, void*)
    #0    Object "/usr/bin/symcon", at 0xf735ab, in backward::SignalHandling::handleSignal(int, siginfo_t*, void*)
    MfG Ralf

Ähnliche Themen

  1. Frage zur Beschattung
    Von Alex0815 im Forum IPSStudio & IPSView
    Antworten: 4
    Letzter Beitrag: 29.02.16, 21:52
  2. Antworten: 2
    Letzter Beitrag: 17.03.14, 23:36
  3. Frage zur IPhone AP
    Von pinki99 im Forum Mobile (iOS/Android)
    Antworten: 7
    Letzter Beitrag: 10.01.11, 03:09
  4. Zur Lizenzmodellüberarbeitung
    Von Smudo im Forum Allgemeine Diskussion (2.x/3.x)
    Antworten: 11
    Letzter Beitrag: 02.08.10, 11:33
  5. Frage zur Registervariable
    Von Jannis im Forum Allgemeine Diskussion (2.x/3.x)
    Antworten: 4
    Letzter Beitrag: 29.05.09, 13:41