Hallo,
nach heutigem Life-Update der V1 (zufällig ausgelöst, erstaunlicherweise dort wirklich Änderungen außer Iconset vorgefunden, zuletzt vor ca. 1 Monat versucht)

kam es nach Start zu folgenden Fehlermeldungen

Code:
...(viele gleichlautende davor)...
26.09.2008 10:03:00.718 | ERROR   | RRDTool              | RRDTool could not be started!
26.09.2008 10:03:00.874 | ERROR   | RRDTool              | RRDTool could not be started!
26.09.2008 10:03:00.874 | ERROR   | RRDTool              | RRDTool could not be started!
26.09.2008 10:03:01.93 | ERROR   | RRDTool              | RRDTool could not be started!
26.09.2008 10:03:01.436 | WARNING | ExecuteThread ID: 2804 | Error executing Script: Invalid floating point operation
26.09.2008 10:03:01.436 | ERROR   | ExecuteThread ID: 2804 | ScriptError:
 ../web_data/weather/exe/WEATHER_DataPoller.ips.php ~ Sender: 
RunScript ~ Result: 
26.09.2008 10:03:02.77 | ERROR   | RRDTool              | RRDTool could not be started!
26.09.2008 10:03:02.202 | ERROR   | RRDTool              | RRDTool could not be started!
26.09.2008 10:03:02.218 | ERROR   | RRDTool              | RRDTool could not be started!
26.09.2008 10:04:01.141 | ERROR   | RRDTool              | RRDTool could not be started!
...(viele gleichlautende danach)...
Die "could not start"-Meldungen sind offenbar von der Anzahl identisch zu den vorhandenen Graphen / RRD-Datenbanken (etwas über 100)

Paresys Tipp an DocMarten vom August:
PHP-Code:
echo RRD_Execute("version -"); 
brachte bei mir keine Ergebnisse, also keinen Output. Ergo: RRD irgendwo falsch oder defekt.

Ich nahm zuvor an, dass das alte Problem mit dem Neuinstallieren von WIIPS nach Lifeupdate nach so langer Zeit wohl bereinigt wäre. Das war offenbar eine fehlerhafte Annahme.

Andererseits hege ich keine Ambitionen, WIIPS nun nochmal in der alten V1 neu zu installieren und dann evtl. über 100 Graphen nochmal neu anzulegen. Deshalb habe ich (bei mir erfolgreich) folgendes Workaround gefunden.

Vorraussetzung, man hat eine Sicherung des IPS-Ordners, z.B. per Pulse angelegt:

Kopie der folgenden Dateien aus der Sicherung in den IPS-Ordner (IPS vorher stoppen, da Modul-Datei sonst offen ist / sich nicht kopieren läßt)

- ...\IP-SYMCON\rrdtools.dll
- ...\IP-SymCON\modules\Core.RRDTool.dll

...und IPS wieder hochfahren.

Die o.g. Versionsabfrage bringt dann auch das gewünschte Ergebnis.

=====

Frage:
Die Versionen vor/nach Life-Update differieren etwas:

Die dll im IPS-Verzeichnis ist Byteanzahl-identisch (315392)
Das Core.Module hingegen ist neu=44544 vs. alt=37888 Byte lang

Ist das wirklich eine neuere Version, die z.B. das lästige Umlaut-Problem nun auch für die V1 löst? Oder ist das eben "die normale dll, die eben nicht läuft"?

Sprich: Sollte man wirklich nochmal WIIPS aktuell irgendwo entpacken und eine neuere DLL installieren, um aktuellere Funktion und Stabilität zu haben?

Gruß Gerd

PS: Ob der Fehler im Weather-Modul noch existiert, weiß ich nicht. Habe die beiden Timer nun ausgeschaltet, da ich sowieso nur die normalen Graphen benutze und mir das daraus selber zusammenbaue.