+ Antworten
Seite 7 von 7 ErsteErste ... 5 6 7
Ergebnis 61 bis 65 von 65
  1. #61
    Registriert seit
    Oct 2007
    Beiträge
    92

    Ich habe in den letzen Stunden weitgehend meine V1 auf M2 "migriert" (wie Ihr der Uhrzeit dieses Eintrages entnehmen könnt: Ich habe das Projekt vorausschauend auf meinen Urlaub verlegt!

    Leider komme ich mit dem WIIPS echt nicht weiter. Ich übersetze mal den ersten Thread, so wie ich ihn interpretiert habe:

    2. Was muss man tun, um sein bestehendes WIIPS auf die V2 umzustellen? Das ist eigentlich ganz einfach:
    - Backup der V1 komplett zur Sicherheit
    Das ist soweit klar.

    - V1 nach V2 migrieren und natuerlich alles entsprechend der Foren-Hinweise anpassen. Das kann einige Zeit dauern, also fangt schon mal an...
    Das war gar nicht so schlimm: Solange ich nicht alle Variablen in allen Scripts auf IDs umstellen muss, geht das noch. Nur ein paar Befehle (z.B. IPS_GetUpdateTime) geändert....

    - WIIPS Module QS, WEATHER, CALENDAR deregistrieren
    ACHTUNG: RRD nicht deregistrieren !!!
    Bedeutet: IPS V2 beenden, V1 starten, WIIPS im Internet-Explorer starten und über "Konfiguration" die o.g. Module deregistrieren? (Wenn ja: Habe ich gemacht...)

    - Verzeichnis web_data aus V1 nach V2 kopieren
    ...auch klar

    - WIIPS V2 entpacken und install.php aufrufen
    ..ist inzwischen Version 2.4 - Die 2.0 und 2.1 etc lassen sich von IP-Symcon WebInterface nicht herunterladen.
    Das entpackte Verzeichnis bildet den Ordner "web" im IP-Symcon-Ordner.
    Danach starte ich wieder IPS V2. Danach Aufruf im Internet-Explorer: http://localhost/install.php (auch mit verschiedenen Ports und anderen Rechnern probiert)

    Ab hier ist das Ergebnis ständig anders, aber immer schlecht. Manchmal wird die Seite nicht gefunden. Im Idealfall wird noch der "Kopf" der WIIPS-Seite geladen und endet mit einem "<div". Nach zwei Stunden tüfteln habe ich jetzt endlich eine relativ aussagekräftige Fehlermeldung bekommen:

    HTML-Code:
    Warning: session_start() [function.session-start]: open(D:\Programme-XP\IP-Symcon\IP-Symcon-2\web_data\session\sess_2e55194b8b3ec005792603edba716034, O_RDWR) failed: No such file or directory (2) in D:\Programme_Server\IP-Symcon\IP-Symcon-2\web\base\global.ips.php on line 48
    Weiß jemand, was ich falsch mache?

    PS: Meine php.ini im V1 bestand nur aus einer Zeile:

    Code:
    [PHP]
    extension_dir = "C:\Programme\IP-SYMCON\"
    max_execution_time = 180
    
    [Session]
    session.save_handler = "files"
    session.save_path = "E:\Programme-XP\IP-Symcon\IP-Symcon\web_data\session"
    session.auto_start = 0
    session.use_trans_sid = 1
    session.name = "pt"
    ...der Ordner unter C: dürfte nie existiert haben. Den Ordner unter E:/ gibt es seit der Neu-Installation meines Rechners auch nicht mehr. Das hat IPS V1 scheinbar nich gestört.
    Ich habe es jetzt wie folgt geändert (bringt aber auch nichts):
    Code:
    [PHP]
    extension_dir = "D:\Programme-XP\IP-Symcon\IP-Symcon-2\"
    max_execution_time = 180
    
    [Session]
    session.save_handler = "files"
    session.save_path = "D:\Programme-XP\IP-Symcon\IP-Symcon-2\web_data\session"
    session.auto_start = 0
    session.use_trans_sid = 1
    session.name = "pt"
    Gute N8, douglas882

  2. #62
    Registriert seit
    May 2005
    Ort
    Leipzig
    Beiträge
    3,964

    Hallo,

    Zitat Zitat von douglas882 Beitrag anzeigen
    ...der Ordner unter C: dürfte nie existiert haben. Den Ordner unter E:/ gibt es seit der Neu-Installation meines Rechners auch nicht mehr. Das hat IPS V1 scheinbar nich gestört.
    dann haette dort auch einiges nicht funktioniert oder es befindet sich das Session Verzeichnis an einem anderen Ort.

    Ich habe es jetzt wie folgt geändert (bringt aber auch nichts):
    Code:
    [php]
    extension_dir = "D:\Programme-XP\IP-Symcon\IP-Symcon-2\"
    max_execution_time = 180
    
    [Session]
    session.save_handler = "files"
    session.save_path = "D:\Programme-XP\IP-Symcon\IP-Symcon-2\web_data\session"
    session.auto_start = 0
    session.use_trans_sid = 1
    session.name = "pt"
    lege mal einfach das Session Verzeichnis an. Ich glaube, das fehlt bei Dir und er macht deshalb Probleme.

    Achso: Nach der Aenderung der php.ini musst Du unbedingt den IPS stopppen und neu starten, sonst wird die Aenderung nicht aktiv.
    Gruss Uwe

  3. #63
    Registriert seit
    Oct 2007
    Beiträge
    92

    YES! Vielen Dank Torro! Es war die php.ini : Mit Deinem Tip (und ein paar Tassen Kaffee) läufts jetzt.
    Den Ordner unter E: gabs doch noch - auf der Backup-Festplatte. Nach der Korrektur der php.ini hatte ich allerdings gleich einen neuen Fehler im Pfad.

    MfG, douglas882

  4. #64
    Registriert seit
    Oct 2007
    Beiträge
    92

    Standard Beschriftung der x-Achse

    Jetzt habe ich doch gleich nochmal eine Frage:

    Kann man den "Raster" der Beschriftung der x-Achse / Zeit-Achse irgendwie beeinflussen? Beim "alten" WIIPS war in der Tagesansicht jede zweite Stunde beschriftet:
    "08:00 10:00 12:00 14:00 ..." usw.

    Mit dem neuen WIIPS ist das jetzt ein 6-Stunden-Raster (mit Tageskürzel):

    "Thu 12:00 Thu 18:00 Fri 00:00 ..."

    Ich finde das etwas "grob", vielleicht auch nur weil bei mir alle Graphen auf 800*500 Punkte sind.

    Steht diese Vorgabe vielleicht in der rrd.inc.php (da steht viel, was ich nicht verstehe! )?

    MfG, douglas882

  5. #65
    Registriert seit
    May 2005
    Ort
    Leipzig
    Beiträge
    3,964

    Hallo,

    Zitat Zitat von douglas882 Beitrag anzeigen
    Jetzt habe ich doch gleich nochmal eine Frage:

    Kann man den "Raster" der Beschriftung der x-Achse / Zeit-Achse irgendwie beeinflussen? Beim "alten" WIIPS war in der Tagesansicht jede zweite Stunde beschriftet:

    Mit dem neuen WIIPS ist das jetzt ein 6-Stunden-Raster (mit Tageskürzel):
    da ich daran nichts geaendert habe, scheint das die neue Version vom RRDTool so zu machen.

    Steht diese Vorgabe vielleicht in der rrd.inc.php (da steht viel, was ich nicht verstehe! )?
    nein, das steht da nicht drin, weil es von RRDTool direkt kommt.
    Gruss Uwe

Ähnliche Themen

  1. Schmutziger Trick: Programm auf einem entfernten Rechner ausführen / Remote-Hibernate
    Von sokkederheld im Forum Anleitungen / Nützliche PHP Skripte
    Antworten: 12
    Letzter Beitrag: 25.11.08, 16:32
  2. Einige Fixes fürs WIIPS (beta!! d.h. ohne Garantien)
    Von gwanjek im Forum IP-Symcon WIIPS für Version 1.0
    Antworten: 8
    Letzter Beitrag: 22.02.08, 07:33
  3. Projekterfahrung mit WIIPS / some Bugs
    Von gwanjek im Forum IP-Symcon WIIPS für Version 1.0
    Antworten: 6
    Letzter Beitrag: 11.01.08, 19:51
  4. WIIPS - Focus auf Benutzernamensfeld
    Von wgreipl im Forum IP-Symcon WIIPS für Version 1.0
    Antworten: 6
    Letzter Beitrag: 17.06.06, 09:51
  5. [kein Bug] Fehler seit Update -> WIIPS updaten auf 0.8x erforderlich
    Von samlehm im Forum IP-Symcon WIIPS für Version 1.0
    Antworten: 3
    Letzter Beitrag: 21.05.06, 21:58