+ Antworten
Seite 48 von 48 ErsteErste ... 38 46 47 48
Ergebnis 471 bis 476 von 476
  1. #471
    Registriert seit
    Jul 2008
    Beiträge
    42

    Bei mir funktioniert das so nicht. Z.B. Volume wird immer 0 ausgegeben. Grund ist, dass der string durch NULL Bytes zerhackt wird und das parsing der tags dann nicht geht. Bei mir funktioniert folgendes - while Schleife ersetzen durch:

    PHP-Code:
            while (!feof($fp)) {
                
    //$buffer = fgetss($fp,128);
                
    $buffer fgets($fp,128);                        
                
    $buffer=preg_replace('/\\0/'""$buffer); //null Bytes löschen
                
    $ret.= $buffer;        
            }
            
    $ret strip_tags($ret); //tags entfernen 

  2. #472
    Registriert seit
    Nov 2013
    Beiträge
    277

    @darx)
    Danke, war mir nicht aufgefallen, da ich das Webfront nicht verwende.
    Gruß
    hoep

  3. #473
    Registriert seit
    Dec 2010
    Beiträge
    921

    Standard Danke auch dafür ...

    Danke auch dafür ...
    Zitat Zitat von darx Beitrag anzeigen
    Bei mir funktioniert das so nicht. Z.B. Volume wird immer 0 ausgegeben. Grund ist, dass der string durch NULL Bytes zerhackt wird und das parsing der tags dann nicht geht. Bei mir funktioniert folgendes - while Schleife ersetzen durch:

    PHP-Code:
            while (!feof($fp)) {
                
    //$buffer = fgetss($fp,128);
                
    $buffer fgets($fp,128);                        
                
    $buffer=preg_replace('/\\0/'""$buffer); //null Bytes löschen
                
    $ret.= $buffer;        
            }
            
    $ret strip_tags($ret); //tags entfernen 
    Grüsse, Wolfgang
    IPS 3.4 #3775 auf Windows7 x64. Hardware: FB 7490 06.51, Synology NAS DS 109+ DSM 4.2-3252 (Apache 2.2.22, MySQL 5.1.49), Gigaset S685IP, S0-Stomzähler, IPSwitchAddE, PlugWise USB 30 Circles, EnOcean, Sonos Play3.

  4. #474
    Registriert seit
    Apr 2015
    Beiträge
    61

    Super!
    Das wars. Danke vielmals. Jetzt sind wieder alle Anzeigen perfekt.

    Danny

  5. #475
    Registriert seit
    Apr 2015
    Beiträge
    61

    Hallo.
    Vielleicht hat mir ja jemand ein korrigiertes PHPsonos.inc?
    Seit dem Fix sehe z.b. keine Radiotitel mehr, nur noch den Stream Namen.
    Die Buttons für Mute und Loudness hüpfen auch immer auf ON, obwohl nie gedrückt.

    Für eigene Radiosender ist dieses Modul für mich viel einfacher als das SONOS Modul, wo ich immer noch nicht herausgefunden habe, wie ich meine eigenen Stationen hinkriege (die vom Sonso Controller tauchen da nie auf).

    Danke
    Danny

  6. #476
    Registriert seit
    Sep 2012
    Beiträge
    135

    Moin darx,

    danke dafür! - das hat bei mir nun auch funktioniert .

    Grüße
    Thomas

    Zitat Zitat von darx Beitrag anzeigen
    Bei mir funktioniert das so nicht. Z.B. Volume wird immer 0 ausgegeben. Grund ist, dass der string durch NULL Bytes zerhackt wird und das parsing der tags dann nicht geht. Bei mir funktioniert folgendes - while Schleife ersetzen durch:

    PHP-Code:
            while (!feof($fp)) {
                
    //$buffer = fgetss($fp,128);
                
    $buffer fgets($fp,128);                        
                
    $buffer=preg_replace('/\\0/'""$buffer); //null Bytes löschen
                
    $ret.= $buffer;        
            }
            
    $ret strip_tags($ret); //tags entfernen 

Ähnliche Themen

  1. Einzelne Sonos Player ansteuern
    Von paresy im Forum Audio & Video, TK-Anlagen, ISDN
    Antworten: 43
    Letzter Beitrag: 25.04.16, 19:25
  2. UIO 88 über PHP in V2.0 ansteuern
    Von Schneider im Forum Allgemeine Diskussion (2.x/3.x)
    Antworten: 7
    Letzter Beitrag: 21.09.08, 21:40

Stichworte