+ Antworten
Seite 41 von 42 ErsteErste ... 31 39 40 41 42 LetzteLetzte
Ergebnis 401 bis 410 von 414
  1. #401
    Registriert seit
    Dec 2009
    Ort
    Berlin
    Beiträge
    826

    Hallo Swen,

    unabhängig von dem oben genannten Uhrzeit Fehler habe ich eben einen "05" Fehler mitgetraced:

    P.S. Es sieht so aus als wenn AUCH im Datum/Uhrzeit Empfangsstring die "05" (Monat) zu einem "Verwerfen" führt.
    Vllt. doch ein und der selbe Fehler...
    __________________
    IPS 5.1 Testing auf Raspi3 ; Mobile5.x ; AEON Stick/Zwave.Me StickC/1x Razberry Gen5;ca. 90 ZWave Geräte; 10x FHT80B;CCU1 (Funk/Wired);Fritzbox 7590;Viessmann; 1x ChuWi13 ;2x Sensus HRI und 1xEltako DSZ12DM an PiiGAB M-Bus; Instar 4011; AXIS 207W; RG-11

  2. #402
    Registriert seit
    Aug 2014
    Beiträge
    492

    1. Der Fehler mit der Schreibweise ist mir bekannt, mach ich da ein update, dann funktionieren bei allen die skripte nicht mehr.
    Das Update kommt, sobald das modul fertig ist.
    2. Fehlerquelle für 0x05 ist bereits lokalisiert, update folgt die Woche.

    Swen
    @I3 6100T, 16GB RAM, 2x SAMSUNG 850 SSD, Windows Server 2016 Essentials; 2xHP Procurve Network Switch(one with POE+); 4xRaspberry Pi Zero; 1xPi 2; 1xPi 3; IP Network Cams; Homematic YAHM on Pi 3; Osram Lightify; mehr Geräte folgen

  3. #403
    Registriert seit
    Dec 2009
    Ort
    Berlin
    Beiträge
    826

    Hallo Swen.

    Kein Stress, wenn Du einen Tester brauchst, ich stehe in der ersten Reihe

    Und wieder Danke für deine Arbeit.

    Gruß
    lueralba
    __________________
    IPS 5.1 Testing auf Raspi3 ; Mobile5.x ; AEON Stick/Zwave.Me StickC/1x Razberry Gen5;ca. 90 ZWave Geräte; 10x FHT80B;CCU1 (Funk/Wired);Fritzbox 7590;Viessmann; 1x ChuWi13 ;2x Sensus HRI und 1xEltako DSZ12DM an PiiGAB M-Bus; Instar 4011; AXIS 207W; RG-11

  4. #404
    Registriert seit
    Jul 2008
    Ort
    Wiesbaden
    Beiträge
    124

    Zitat Zitat von lueralba Beitrag anzeigen
    Hallo Hans-Christian,

    ich führe das "SENDEN" (per Script) so aus:

    PHP-Code:
            $SendeString "41";   //  zu übermittelnder Wert in Hex  (41 = 65 Grad dezimal)

            
    $modulid 16296;         // ID von Deiner Viesmann Instanz
        
    $hexstamp"6300";      //  Adresse in deiner Viessmann Heizung an die gesendet wird
        
    $bytes 1;                   // Beim Empfangen: Anzahl der erwarteten Bytes  / Beim Senden: Anzahl der zu sendenden Bytes
        
    $read_only false;        // F7 = true F4 = false 
        
    $return_data false;      // es wird der Rückgabe wert ausgegeben, oder false bei einen Fehler oder einen Timeout 
        
    $value $SendeString;  // wenn read_only "False" ist wird der angebene Wert (Wert in Hex) Gesetzt 
        
    $ips_id ;                  // Setzen des Rückgabe wertes in eine Variable (klappt bei mir nicht, daher NULL  !!!)
        
    $convert "";                // "" = kein Converter verwenden, 2 = /2, 10 = /10, 3600 = /3600
        
            
    $output ViesmannOpenV_SendData($modulid$hexstamp$bytes$read_only$return_data$value$ips_id$convert);
        
        
    //output = true -> senden erfolgreich
        //output = false -> senden fehlgeschlagen oder Timeout
        //output = Ausgabe der Antwort (wenn $return_data = true (siehe oben) übergeben wird) 
    Viel Erfolg.

    Gruß
    lueralba
    Seltsam, das geht bei mir nicht. Die output-Variable signalisiert "true", aber es wird nichts geschrieben ...

  5. #405
    Registriert seit
    Dec 2009
    Ort
    Berlin
    Beiträge
    826

    Gibt es keinen Fehler im Meldungen-Fenster ?

    Schau doch mal im Debug deiner seriellen Schnitttelle.
    Dort siehst du sehr schön was auf der COM Schnittstelle passiert.

    Und - zeig mal Dein Script, wenn du magst.

    Gruß
    lueralba
    __________________
    IPS 5.1 Testing auf Raspi3 ; Mobile5.x ; AEON Stick/Zwave.Me StickC/1x Razberry Gen5;ca. 90 ZWave Geräte; 10x FHT80B;CCU1 (Funk/Wired);Fritzbox 7590;Viessmann; 1x ChuWi13 ;2x Sensus HRI und 1xEltako DSZ12DM an PiiGAB M-Bus; Instar 4011; AXIS 207W; RG-11

  6. #406
    Registriert seit
    Jul 2008
    Ort
    Wiesbaden
    Beiträge
    124

    Zitat Zitat von lueralba Beitrag anzeigen
    Gibt es keinen Fehler im Meldungen-Fenster ?

    Schau doch mal im Debug deiner seriellen Schnitttelle.
    Dort siehst du sehr schön was auf der COM Schnittstelle passiert.

    Und - zeig mal Dein Script, wenn du magst.

    Gruß
    lueralba
    Danke, das Debugging ist wirklich prima. Und ...ohne zu wissen warum ... es funktioniert jetzt. Vielen Dank für Deine Unterstützung!

  7. #407
    Registriert seit
    Aug 2014
    Beiträge
    492

    So zum 0x05 Fehler.

    Hab jetzt einen Update hochgeladen.
    Pakete die eine längere Empfangsdauer von mehr als 1 Sekunde haben, über 2 Bytes lang sind und mit 05 enden werden jetzt Verworfen.

    Gruß: Swen

    Kleines Update:
    war noch ein Fehler drin, diesen habe ich behoben und die Zeit auf 0,5 Sekunden gesetzt.
    Es gibt auch im eine Ausgabe mit der Dauer der Zeit.
    Geändert von Acer90 (18.05.19 um 12:35 Uhr)
    @I3 6100T, 16GB RAM, 2x SAMSUNG 850 SSD, Windows Server 2016 Essentials; 2xHP Procurve Network Switch(one with POE+); 4xRaspberry Pi Zero; 1xPi 2; 1xPi 3; IP Network Cams; Homematic YAHM on Pi 3; Osram Lightify; mehr Geräte folgen

  8. #408
    Registriert seit
    Dec 2009
    Ort
    Berlin
    Beiträge
    826

    Hallo Swen,

    super gelöst

    Läuft seit einer dreiviertel Stunde einwandfrei.
    Uhrzeit kann ich auch wieder abfragen.

    Ich quäle das Modul grade mit drei 56 Byte Abfragen:
    (Da kommt manchmal die max. Empfangsdauerwartezeit bis zu 0,6sec hoch, Durchschnitt so bei 0,3sec).
    Evtl. die diese Zeit einstellbar machen, da wir ja alle unterschiedlich schnelle Heizungen/IPS Rechner haben werden.
    So kann jeder seine individuelle Zeit nachregeln.

    Noch ein Wunsch: Kann man die einzelenen Abfragen per Checkbox abschalten bzw. auch das ganze Modul Start/Stop schalten.
    Das ist aber nicht wirklich wichtig....

    Lieben Dank für die Anpassungen.

    Gruß und ein tolles WE
    lueralba
    __________________
    IPS 5.1 Testing auf Raspi3 ; Mobile5.x ; AEON Stick/Zwave.Me StickC/1x Razberry Gen5;ca. 90 ZWave Geräte; 10x FHT80B;CCU1 (Funk/Wired);Fritzbox 7590;Viessmann; 1x ChuWi13 ;2x Sensus HRI und 1xEltako DSZ12DM an PiiGAB M-Bus; Instar 4011; AXIS 207W; RG-11

  9. #409
    Registriert seit
    Jul 2008
    Ort
    Wiesbaden
    Beiträge
    124

    Standard Systemuhrzeit abfragen

    Temperaturen abzufragen ist jetzt OK. Bei der Abfrage der Systemuhrzeit mit Ausgabelänge 8 funktioniert es jedoch nicht mehr. Kann es daran liegen, dass im DEBUG der Schnittstelle die empfangenen Daten nicht in einer Zeile stehen, sd. in 3 (siehe Bild)Name:  test2.jpg
Hits: 37
Größe:  33.6 KB

    Die Rückgabe scheint nur die erste Zeile zu berücksichtigen. Und auch das Schreiben in eine String-Variable mit Ausgabelänge 8 (HEX) geht nicht ...

    Gruss,

    Hans-Christian

  10. #410
    Registriert seit
    Dec 2009
    Ort
    Berlin
    Beiträge
    826

    @ Hans-Christian:

    Für Swen wäre hier vermutlich die Debug-Ausgabe der Instanz besser.

    Da fällt mir auf: Bei mir kommen sogar die o.g. 56 Bytes in einem Paket an

    Gruß
    lueralba
    __________________
    IPS 5.1 Testing auf Raspi3 ; Mobile5.x ; AEON Stick/Zwave.Me StickC/1x Razberry Gen5;ca. 90 ZWave Geräte; 10x FHT80B;CCU1 (Funk/Wired);Fritzbox 7590;Viessmann; 1x ChuWi13 ;2x Sensus HRI und 1xEltako DSZ12DM an PiiGAB M-Bus; Instar 4011; AXIS 207W; RG-11

Ähnliche Themen

  1. Rolladen und Heizungsventil Steuerung
    Von s.jungen im Forum Haustechnik
    Antworten: 5
    Letzter Beitrag: 01.10.09, 22:07
  2. Synco Living | Viessmann Vitohome 300 - kompatibilität
    Von King-Nova im Forum KNX/EIB, LCN
    Antworten: 0
    Letzter Beitrag: 09.08.09, 08:54
  3. Entfernte Steuerung einbinden
    Von Jersey im Forum Haustechnik
    Antworten: 4
    Letzter Beitrag: 05.07.06, 17:21