+ Antworten
Seite 2 von 2 ErsteErste 1 2
Ergebnis 11 bis 14 von 14
  1. #11
    Registriert seit
    Jan 2009
    Beiträge
    366

    Hat jemand neue Erkenntnisse zu diesem Thema??

    Ich habe das gleiche Problem.

    Gruss
    gros_ibou

  2. #12
    Registriert seit
    Feb 2008
    Ort
    127.0.0.1
    Beiträge
    455

    Hallo,

    das ist ein Problem mit den "Sessions". Ich habe auch keine Ahnung warum das nicht mehr geht oder wie man es wieder richten kann. Aber ich habe die Datei "/web/modules/auth/Authentcation.ips.php" so verändert, daß auch mit fehlerhaftem Login, WIIPS zu bedienen ist.
    Achtung:
    1. Backup machen!!
    2. Es ist nun von jedem möglich, ohne Passwort, WIIPS zu bedienen!!


    folgender Teil muß verändert werden
    PHP-Code:
      public function auth($zone) {
        if ( !isset( 
    $_SESSION['_loginuser'] ) ) { return False; }
          if( 
    $this->users[$_SESSION['_loginuser']]['type'] != 'Super-Administrator'  ) {
            
    $zone_gruppe=explode('\\'$zone);
            
    // strikte Pruefung Zone
              
    if( (!in_array($zone$this->users[$_SESSION['_loginuser']]['zones'])) && (!in_array($zone_gruppe[0], $this->users[$_SESSION['_loginuser']]['zones']))) {
                  return 
    FALSE;
                  exit;
              }
          }    
          return 
    TRUE;        
      } 
    So sieht es nun aus:
    PHP-Code:
      public function auth($zone) {
        if ( !isset( 
    $_SESSION['_loginuser'] ) ) { return False; }
          return 
    TRUE;        
      } 
    Nochmal: Dies behebt den Fehler nicht, es ist jetzt nur möglich mit WIIPS mit diesem Fehler zu arbeiten.
    Das bedeutet aber auch, das WIIPS ohne Passwort zu bedienen ist, auch von anderen!
    Den eigentlichen Fehler muß Torro (oder jemand der was davon versteht) beheben.

  3. #13
    Registriert seit
    Aug 2009
    Beiträge
    101

    Exclamation Anmeldung fehlgeschlagen! Bitte Anmelden oder Zurück!

    Hallo Leute,

    ich kann mir nicht vorstellen, dass ich mit ein paar wenigen Usern dieses Problem alleine habe.
    Ich habe mir nach erscheinen von V2.2 eine komplett neue Installation aufgesetzt. Nach den anfänglichen Gehversuchen wollte ich das immer mal gemacht haben. Nun wollte ich gerne wiips einbinden.
    Resultat ist wie vorher auch, nach Einrichten des Admins und erstmaligem Anmelden kommt die Meldung:
    Zugang Beschränkt V0.213
    Anmeldung fehlgeschlagen! Bitte Anmelden oder Zurück!


    Ich habe schon im Archiv alle Beiträge durch:
    ...Verzeichnisrechte angepasst, Eintrag in der host-Datei geprüft etc..

    Gibt es denn niemand, der einem da mal nen Tip geben könnte, wie man wiips mit V2.2 zum laufen bringen kann?

    Gruß
    Palela
    Gruß Palela

    Im Einsatz:
    WAGO 750-841 mit Kopplung an DALI und EnOcean - Regelung Heizung, Licht, Energiemanagement etc...
    WAGO 750-881 für Software-Entwicklung.

    Multimedia ist immer noch eine ewige Baustelle...

  4. #14
    Registriert seit
    Apr 2007
    Ort
    Oberösterreich
    Beiträge
    629

    Ich stehe vor demselben Problem. Gibt es hier immer noch keine Erkenntnisse? Wollte heute einen neuen Graphen einrichten und kann mich nicht mehr anmelden!!

Ähnliche Themen

  1. WIIPS 3.0b funktioniert nicht unter IPS 2.1
    Von khge im Forum IP-Symcon WIIPS
    Antworten: 5
    Letzter Beitrag: 29.09.09, 20:38
  2. Probleme mit WIIPS unter aktueller IPS V2.1b
    Von Ferengi-Master im Forum IP-Symcon WIIPS
    Antworten: 6
    Letzter Beitrag: 19.08.09, 22:36
  3. WIIPS 3.0b Probleme mit Legende und MySQL
    Von s.jungen im Forum IP-Symcon WIIPS
    Antworten: 2
    Letzter Beitrag: 28.07.09, 07:36
  4. Probleme mit WIIPS Anmeldung
    Von xtrabau im Forum IP-Symcon WIIPS
    Antworten: 9
    Letzter Beitrag: 31.01.09, 23:01