+ Antworten
Seite 3 von 19 ErsteErste 1 2 3 4 5 13 ... LetzteLetzte
Ergebnis 21 bis 30 von 190
  1. #21
    Registriert seit
    Jan 2011
    Ort
    Wuppertal
    Beiträge
    135

    Hallo,

    ich hätte da mal ein paar Anfängerfragen:

    1.) Wie genau wird das Verzeichnis in der "NetPlayer_Configuration.inc.php" angegeben? Meine Konfig ist folgende: SBS-Server 2011 mit IP-Symcon, darauf unter Laufwerk F: ein Ordner "MP3s". Dieser Ordner ist gleichzeitig über den UNC-Pfad "\\SBServer\MP3s" erreichbar. Was gebe ich jetzt in der Config-Datei an? Den lokalen Pfad, da die Datei von dem PHP-Script geöffnet und gestreamt wird oder den UNC-Pfad da die MP3-Datei lokal vom WFE-Rechner abgespielt wird?

    2.) Wie genau binde ich die Dateien unter ./user/NetPlayer in das WFE ein?
    Geändert von Maloe (17.03.12 um 15:22 Uhr)
    Gruß, Marcus
    IPS 3.4 auf HP Proliant Microserver/Windows Small Business Server 2011, EIB, Squeezebox Server + Squeezebox Radio, EIB-Gateway auf Raspberry mit Buskopplung von SelfBus
    Elektrofachkraft nach DIN VDE 1000-10

  2. #22
    Registriert seit
    Aug 2011
    Beiträge
    975

    Hallo 1007,

    das mit dem fehlenden Anführungsstrich hat ich nicht im Script falsch, der ist beim kopieren in diesen Beitrag verloren gegangen.


    Zitat Zitat von 1007 Beitrag anzeigen
    Was genau heisst - Es tut sich nichts?
    Eigentlich muesste eine Fehlermeldung kommen , da du nach 'harmony fm
    ein Anfuehrungszeichen vergessen hast.
    PHP-Code:
    Parse errorsyntax errorunexpected 'Radio' (T_STRING), expecting ')' in C:\Programme\IP-SYMCON2\scripts\IPSLibrary\config\modules\NetPlayer\NetPlayer_Configuration.inc.php on line 79 
    Und nicht das Konfigurationsfile im default Ordner nehmen.
    Wenn ich einen der genannten Sender eingegeben habe und ihn start, passt er die daten im Objektbaum von IPS an stopt aber den netplayer. Siehe screenshot.
    Angehängte Grafiken Angehängte Grafiken  
    IPS 5.0unlim, 3x W&T WebIO12, diverse 1wire (LAN), FritzOS 7, z-Wave, DMX/ArtNet-Node, M-Bus, ESP8266 via MQTT

    "Prognosen sind schwierig, besonders wenn sie die Zukunft betreffen" N. Bohr

  3. #23
    Registriert seit
    Jan 2007
    Ort
    Nidda(Hessen)
    Beiträge
    7,330

    Der Mediaplayer steht doch auf PLAY. Allerdings, solltest Du auch mal die Lautstärke anpassen. Bei 0 hört man nicht allzuviel.
    Gruß Rainer


    Unmögliches wird sofort erledigt, Wunder dauern etwas länger.


  4. #24
    Registriert seit
    Aug 2011
    Beiträge
    975

    sorry falsches screenshot gepostet.
    Hier das richtige.
    Die Lautstärke steht komischerweise IMMER auf 0% auch wenn eine Webradio-Sender läuft der im DemoScript vorgegeben ist!?

    Gruß
    hardlog
    Angehängte Grafiken Angehängte Grafiken  
    IPS 5.0unlim, 3x W&T WebIO12, diverse 1wire (LAN), FritzOS 7, z-Wave, DMX/ArtNet-Node, M-Bus, ESP8266 via MQTT

    "Prognosen sind schwierig, besonders wenn sie die Zukunft betreffen" N. Bohr

  5. #25
    Registriert seit
    Jan 2011
    Ort
    Wuppertal
    Beiträge
    135

    Darf ich noch mal meine Fragen dazwischenstreuen? Nicht das sie verloren gehen...


    Zitat Zitat von Maloe Beitrag anzeigen
    Hallo,

    ich hätte da mal ein paar Anfängerfragen:

    1.) Wie genau wird das Verzeichnis in der "NetPlayer_Configuration.inc.php" angegeben? Meine Konfig ist folgende: SBS-Server 2011 mit IP-Symcon, darauf unter Laufwerk F: ein Ordner "MP3s". Dieser Ordner ist gleichzeitig über den UNC-Pfad "\\SBServer\MP3s" erreichbar. Was gebe ich jetzt in der Config-Datei an? Den lokalen Pfad, da die Datei von dem PHP-Script geöffnet und gestreamt wird oder den UNC-Pfad da die MP3-Datei lokal vom WFE-Rechner abgespielt wird?

    2.) Wie genau binde ich die Dateien unter ./user/NetPlayer in das WFE ein?
    Gruß, Marcus
    IPS 3.4 auf HP Proliant Microserver/Windows Small Business Server 2011, EIB, Squeezebox Server + Squeezebox Radio, EIB-Gateway auf Raspberry mit Buskopplung von SelfBus
    Elektrofachkraft nach DIN VDE 1000-10

  6. #26
    Registriert seit
    Aug 2010
    Ort
    Österreich (Korneuburg)
    Beiträge
    4,482

    NetPlayer einbinden mit Html Variable:
    PHP-Code:
    <iframe frameborder="0" width="100%" src="../user/NetPlayer/NetPlayer_MP3Control.php"    height=260px</iframe
    Ich würde die lokale Angabe des Pfades bevorzugen - bin mir nicht sicher, ob IP-Symcon auf \\SBServer... zugreifen kann (läuft als Service).
    Gruß
    Andreas

  7. #27
    Registriert seit
    Jan 2011
    Ort
    Wuppertal
    Beiträge
    135

    Zitat Zitat von Brownson Beitrag anzeigen
    NetPlayer einbinden mit Html Variable:
    PHP-Code:
    <iframe frameborder="0" width="100%" src="../user/NetPlayer/NetPlayer_MP3Control.php"    height=260px</iframe
    Ich hätte jetzt gesagt, "../user" ist falsch und muss "./user" heissen, aber es scheint ihm egal zu sein, denn ich bekomme jetzt den Fehler:



    Zitat Zitat von Brownson Beitrag anzeigen
    Ich würde die lokale Angabe des Pfades bevorzugen - bin mir nicht sicher, ob IP-Symcon auf \\SBServer... zugreifen kann (läuft als Service).
    Das erscheint logisch. jedoch hatte ich "\" verwendet und es müsste der "/" benutzt werden (zumindest laut Beispiel).



    .
    Angehängte Grafiken Angehängte Grafiken  
    Gruß, Marcus
    IPS 3.4 auf HP Proliant Microserver/Windows Small Business Server 2011, EIB, Squeezebox Server + Squeezebox Radio, EIB-Gateway auf Raspberry mit Buskopplung von SelfBus
    Elektrofachkraft nach DIN VDE 1000-10

  8. #28
    Registriert seit
    Dec 2009
    Ort
    Salzburg
    Beiträge
    262

    Standard Call to undefined function WAC_SetPlaylist()

    Hallo,

    wenn ich ein Lied in der Liste auswähle bekomme ich einen "Call to undefined function WAC_SetPlaylist()" Fehler, was kann das für ein Problem sein?

    Code:
    NetPlayer PlayListPosition=2</message></event>
    <event logger="PHP" timestamp="2012-03-18T11:29:48.000000+01:00" level="ERROR" domain="IPS.exe" username="IPS"><message>Error: Call to undefined function WAC_SetPlaylist()
       Error in Script C:\IP-Symcon\scripts\IPSLibrary\app\core\IPSComponent\IPSComponentPlayer\IPSComponentPlayer_Mediaplayer.class.php on Line 142
      132 in IPSLibrary\app\core\IPSLogger\IPSLogger.inc.php (call IPSLogger_Out)
       33 in IPSLibrary\app\core\IPSLogger\IPSLogger_PhpErrorHandler.inc.php (call IPSLogger_Err)
       91 in IPSLibrary\app\core\IPSLogger\IPSLogger_PhpErrorHandler.inc.php (call IPSLogger_PhpErrorHandler)
          in IPSLogger_PhpFatalErrorHandler</message></event>

  9. #29
    Registriert seit
    Aug 2010
    Ort
    Österreich (Korneuburg)
    Beiträge
    4,482

    @Maloe

    sieht so aus, als wäre mit Deiner IPSLibrary Basis Installation etwas nicht in Ordnung - kannst Du den Netplayer mit den anderen Variablen bedienen, wenn nicht mach nochmals eine Neuinstallation des IPSModuleManagers.
    Gruß
    Andreas

  10. #30
    Registriert seit
    Jan 2011
    Ort
    Wuppertal
    Beiträge
    135

    Hallo Andreas,

    der IPSLogger funktioiert, also gehe ich mal davon aus, dass nur der NetPlayer nicht richtig installiert ist. Ich habe folgendes gemacht:

    Zuerst geladen und eingebunden mit:

    PHP-Code:
    <?
     IPSUtils_Include 
    ("IPSModuleManager.class.php""IPSLibrary::install::IPSModuleManager");
        
    $moduleManager = new IPSModuleManager('NetPlayer');
        
    $moduleManager->LoadModule();
    ?>
    Anschließend die Config-Datei bearbeitet und dann mit :

    PHP-Code:
    <?

       IPSUtils_Include 
    ("IPSModuleManager.class.php""IPSLibrary::install::IPSModuleManager");
       
    $moduleManager = new IPSModuleManager('NetPlayer');
       
    $moduleManager ->InstallModule();
    ?>
    installiert. Richtig so? Den zweiten Teil habe ich schon 2-3 mal ausgeführt, jeweils ohne Fehlermeldungen.
    Gruß, Marcus
    IPS 3.4 auf HP Proliant Microserver/Windows Small Business Server 2011, EIB, Squeezebox Server + Squeezebox Radio, EIB-Gateway auf Raspberry mit Buskopplung von SelfBus
    Elektrofachkraft nach DIN VDE 1000-10

Ähnliche Themen

  1. Sammlung an Fehlern in Bezug zur IPSLibrary
    Von Brownson im Forum IPSLibrary
    Antworten: 27
    Letzter Beitrag: 09.09.19, 11:40
  2. Diskussions Thread zur IPSLibrary
    Von Brownson im Forum IPSLibrary
    Antworten: 216
    Letzter Beitrag: 16.06.19, 18:28
  3. IPSLibrary
    Von Brownson im Forum IPSLibrary
    Antworten: 35
    Letzter Beitrag: 03.11.18, 20:17