+ Antworten
Seite 2 von 9 ErsteErste 1 2 3 4 ... LetzteLetzte
Ergebnis 11 bis 20 von 84
  1. #11
    Registriert seit
    Apr 2011
    Ort
    Cologne
    Beiträge
    801

    Hi terenyi,

    installiert, läuft und bringt bessere Ergebnisse

    Danke & Gruß, Axel

  2. #12
    Registriert seit
    Sep 2008
    Beiträge
    385

    Wow ... jetzt brauche in aber ganz schnell einen eBus Adapter.
    Klasse Arbeit !!!!

  3. #13
    Registriert seit
    Sep 2008
    Beiträge
    385

    Thumbs up Der eBusConnection ist genial !!!!

    Vielen Dank !!!!!! Mein eBus Adapter "rockt" jetzt mit den Daten von meiner Wolf Gastherme.
    Absolut geniales Tool und super Beschreibung. In nur wenigen Minuten konnte ich alles Erfolgreich einstellen.

    Jetzt muß ich nur noch das Protokoll irgendwie verstehen.

  4. #14
    Registriert seit
    Apr 2011
    Ort
    Cologne
    Beiträge
    801

    Zitat Zitat von mr_cg Beitrag anzeigen
    Jetzt muß ich nur noch das Protokoll irgendwie verstehen.
    Och, hat mich nur ein Jahr beschäftigt. Durchbruch kam, als jemand den Adapter und Software des Herstellers mit USBalyzer belauscht hatte, dann konnte man sich ganz schnell einReim drauf machen. Ich finde sowas macht spaß :-)

  5. #15
    Registriert seit
    Sep 2008
    Beiträge
    385

    Du hast nicht zufällig eine Wolf Gastherme??? ;-)

    Da ich ja auch ein Bedienterminal auf dem eBus habe war meine Idee dort die gewünschten Werte abzufragen und mit dem USB Adapter die Anfrage als auch Antwort von der Therme zu loggen.
    Sollte so doch funktionieren .... oder? Bin für jeden Tipp dankbar.

  6. #16
    Registriert seit
    Apr 2011
    Ort
    Cologne
    Beiträge
    801

    Hi mr_cg, ich habe eine Vaillant. Dein Ansatz klingt aber gut - wir haben am Ende mit dem Original-Adapter von Vaillant auch nichts anderes gemacht...

    Viel Glück!

  7. #17
    Registriert seit
    Jan 2012
    Ort
    Wien
    Beiträge
    77

    Zitat Zitat von mr_cg Beitrag anzeigen
    Sollte so doch funktionieren .... oder?
    Sollte (mit etwas Mühe) prinzipiell für alle Daten funktionieren, die zwischen Therme und Regeler ausgetauscht werden. Interessanter wird es, wenn man Daten auslesen will, die nur am Regler gespeichert sind und normal nicht über den Bus geschickt werden.

  8. #18
    Registriert seit
    Jan 2012
    Ort
    Wien
    Beiträge
    77

    Habe gerade den eBus Connector auf v1.2 upgedated (siehe erster Post). Die Neuerungen:

    • Empfangen: Nachrichten die kürzer sind, als die Minimallänge von 6 Bytes (und daher definitiv ungültig sind) werden ignoriert und nicht weitergeleitet.
    • Senden: Der eBus Connector lauscht während des Schreibens auf den Bus auf die selbst gesendeten Bytes. Sollten die empfangen Bytes nicht mit den gesendeten Bytes übereinstimmen, wurde eine Kollision erkannt und das Senden wird abgebrochen. Dadurch werden weitere Kollisonen vermieden. In diesem Zusammenhang empfiehlt es sich, eigene Nachrichten mit der Absenderadresse FFh zu verschicken (niedrigste Priorität am Bus und daher minimierte Gefahr, die anderen Teilnehmer am Bus durch Kollisionen "zu stören").
    • Senden: Konnte eine Nachricht auf Grund einer Kollision nicht gesendet werden, wird sie bei der nächsten Gelegeneheit automatisch erneut verschickt. Dies stellt sicher, dass die an den eBus Connector übergegebenen Nachrichten auch tatsächlich erfolgreich versendet werden.
    • Installer: Der Starttyp des Diensts wurde von "Automatisch (Verzögert)" auf "Automatisch" geändert, dafür wurde der Dienst vom Virtual Serial Port Service abhängig gemacht, um sicherzustellen, dass dieser läuft, bevor der eBus Connector gestartet wird.


    Durch diese Neuerungen ist das Versenden von Daten verlässlicher und die Fehlerrate beim Empfangen konnte bei mir halbiert werden.

  9. #19
    Registriert seit
    Sep 2009
    Beiträge
    1,002

    @terenyi

    Schönes Tool, herzlichen Dank. Ich habe nach einigem Nachdenken das ganze installieren können (Bin etwas aus der Übung mit UDP, virtueller COM etc.)
    Im Moment nutze ich die Konsole. Ich habe zwar das Registry entsprechend angepasst und die install routine für den Service als Administrator laufen lassen, konnte aber den Dienst trotz reboot nachher nicht finden (Der müsste doch unter Dienste mit dem Namen "Ebusconnect" gelistet werden oder ?)

    Wird ein Logfile bei der Installation des Services erzeugt ? und wo finde ich das ?
    2 Standorte, 1 Win10 Symcon, 2 Raspi Stretch Symcon, 6 PIVCCU Stretch, IPSVIEW, 6 LAN Adapter, ALL4000, T 868, 4 EKM 868, ENOCEAN, EBUS , Chrome, AVM, PIXEL 2, 3 IPAD, 4 X Alexa

  10. #20
    Registriert seit
    Jan 2012
    Ort
    Wien
    Beiträge
    77

    Ja, der Dienst müsste in der Services-Konsole (services.msc) unter "eBus Connector" in der Liste sein. Dafür muss man dort lediglich Refresh drücken, ein Neustart ist nicht notwendig.

    Bei der Installation werden einerseits Meldungen in die Konsole ausgegeben, andererseits sollte es im gleichen Verzeichnis dann die Log-Files geben (.InstallLog und .InstallState).

Ähnliche Themen

  1. eBus Adapter da
    Von wupperi im Forum Haustechnik
    Antworten: 45
    Letzter Beitrag: 01.05.17, 11:36
  2. Anbindung WOLF Therme mittels eBus-Adapter und eBus-Modul
    Von Brownson im Forum Anleitungen / Nützliche PHP Skripte
    Antworten: 27
    Letzter Beitrag: 20.05.16, 11:24
  3. eBus Adapter
    Von Brownson im Forum Entwicklung mit PHP-SDK/Delphi-SDK
    Antworten: 87
    Letzter Beitrag: 26.01.16, 07:30
  4. Konfiguration der ebus connector software?
    Von klammeraffe im Forum Haustechnik
    Antworten: 2
    Letzter Beitrag: 26.09.12, 09:17
  5. USB to Ethernet Connector
    Von astrastar im Forum Schaufenster
    Antworten: 1
    Letzter Beitrag: 18.06.07, 19:22