+ Antworten
Ergebnis 1 bis 6 von 6
  1. #1
    Registriert seit
    Jan 2012
    Beiträge
    526

    Standard 4.0 RPI: Fehler mit file_get_contents nach Update

    Hallo zusammen,
    ich bin leicht verzweifelt. Habe IPS auf Raspberry upgedatet ( Version 4.00, 26.08.2016, 6cf41a555dae).
    Seitdem steigt "file_get_contents" mit folgender Fehlermeldung aus:

    Warning: file_get_contents(): php_network_getaddresses: getaddrinfo failed: Der Name oder der Dienst ist nicht bekannt

    Umstellen auf Beta bringt nichts. Da kommt die gleiche Version drauf. Umstellung auf 4.1 Testing löst das Problem, bringt dafür aber andere mit Z-Wave.

    Wer kann helfen? Gibt es einen Workaround, oder die Möglichkeit auf eine alte Version zurückzugehen?
    Viele Grüße
    Jürgen

  2. #2
    Registriert seit
    Jun 2012
    Ort
    House of Dragons @ Lübeck
    Beiträge
    9,033

    on Win7VM (ESXi): I5, 24GB RAM, HW-RAID5, 3xSat | HW: CCU + 123 Geräte (506ch), EM1000, CUL, 1Wire, XBee, ELRO 433MHz, FritzBox Cable, Android Phone + Tablet, Samsung C-Serie TV +SamyGo-Ext, Onkyo NR| SW: IPS, Apache2(mod_ssl/PHP), MySQL, hMailServer, PRTG, Rising AV, Piwik, RoundCube, Wordpress, WinLIRC, WHS2011, MediaPortal, XBMC

  3. #3
    Registriert seit
    Jan 2012
    Beiträge
    526

    danke für die schnelle Antwort.
    Was mache ich nun. 4.1 kann ich aktuell nicht aufspielen. Kann ich auf eine ältere 4.0 zurück? Oder hilft das auch nicht weiter? Kann man Jessie downgraden?

    Viele Grüße
    Jürgen

  4. #4
    Registriert seit
    Jun 2012
    Ort
    House of Dragons @ Lübeck
    Beiträge
    9,033

    Keine Ahnung ob du Jessie downgraden kannst.
    Backup der SD Karte vorhanden?
    Michael
    on Win7VM (ESXi): I5, 24GB RAM, HW-RAID5, 3xSat | HW: CCU + 123 Geräte (506ch), EM1000, CUL, 1Wire, XBee, ELRO 433MHz, FritzBox Cable, Android Phone + Tablet, Samsung C-Serie TV +SamyGo-Ext, Onkyo NR| SW: IPS, Apache2(mod_ssl/PHP), MySQL, hMailServer, PRTG, Rising AV, Piwik, RoundCube, Wordpress, WinLIRC, WHS2011, MediaPortal, XBMC

  5. #5
    Registriert seit
    Jan 2012
    Beiträge
    526

    nein leider nicht.
    das beste wäre eine bug fix, 4.1 hat doch noch einige Unzulänglichkeiten
    Viele Grüße
    Jürgen

  6. #6
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    21,259

    Ein Fix ist leider nicht möglich für die 4.0, da ich die 4.1 komplett anders kompilieren musste, damit das Jessie Problem gelöst wurde. Am einfachsten ist, wenn du dein System unter Wheezy neu aufsetzt, wenn es zwingend die 4.0 sein muss. Dort tritt das Problem nämlich spannender Weise nicht auf. Ich weiß auch echt nicht, was die Jungs unter Jessie kaputt gemacht haben, das ein Security Update so viel kaputt machen kann.

    paresy

Ähnliche Themen

  1. Symcon auf RPI startet nach Update nicht mehr
    Von Dutch83 im Forum Allgemeine Diskussion
    Antworten: 4
    Letzter Beitrag: 29.08.16, 22:06
  2. Update 3.4->4.0RC6, Win->RPI in 15min ohne Fehler?
    Von baba im Forum Allgemeine Diskussion
    Antworten: 0
    Letzter Beitrag: 27.02.16, 13:40
  3. Fehler nach Update 2.2
    Von Nairda im Forum IPSStudio & IPSView
    Antworten: 3
    Letzter Beitrag: 08.11.15, 20:21
  4. file_get_contents bzw. Sys_GetURLContent mit https://
    Von Sascha159 im Forum Skripte, PHP, SQL
    Antworten: 5
    Letzter Beitrag: 31.08.14, 19:11
  5. Fehler nach Update
    Von bladerunner im Forum IP-Symcon WIIPS für Version 1.0
    Antworten: 8
    Letzter Beitrag: 04.02.08, 08:43