+ Antworten
Ergebnis 1 bis 3 von 3
  1. #1
    Registriert seit
    Aug 2009
    Beiträge
    184

    Standard Sys_GetProcessInfo = IPS_VIRTUALSIZE

    Moin,

    ich nutze die Win 5.0 Version von IPS.

    Was mir gerade auf gefallen ist, seit dem 4.5.18 bekomme ich bei "IPS_VIRTUALSIZE" nur noch negative Werte angezeigt.

    Ich habe eben das noch mal neu nachgestellt, im Script sind es einwandfrei positive Werte, nur in die Integer Variable werden negative Werte geschrieben.

    Hier das Script:
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Script IPS_VIRTUALSIZE.jpg 
Hits:	17 
Größe:	9.7 KB 
ID:	45520

    Hier die Scriptausgabe:
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Ergebnis Script IPS_VIRTUALSIZE.jpg 
Hits:	19 
Größe:	8.9 KB 
ID:	45521

    Und hier der Wert der in die Variable geschrieben wird:
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Variable IPS_VIRTUALSIZE.jpg 
Hits:	23 
Größe:	6.6 KB 
ID:	45522

    Was mache ich da verkehrt, weil vorher hat das ja funktioniert, und die Suche ergab auch kein Ergebnis?

    Hein09

  2. #2
    Registriert seit
    Jun 2012
    Ort
    House of Dragons @ Lübeck
    Beiträge
    7,343

    Erklärt wird es hier:
    IPS_RunScriptEx Parameter Conversion Error
    Versuch Mal in IPS als Variable eine Float zu nutzen. Mit Glück kann die größere Zahlen darstellen.
    Sonst bleibt dir nur String.
    Michael
    on Win7VM (ESXi): I5, 24GB RAM, HW-RAID5, 3xSat | HW: CCU + 123 Geräte (506ch), EM1000, CUL, 1Wire, XBee, ELRO 433MHz, FritzBox Cable, Android Phone + Tablet, Samsung C-Serie TV +SamyGo-Ext, Onkyo NR| SW: IPS, Apache2(mod_ssl/PHP), MySQL, hMailServer, PRTG, Rising AV, Piwik, RoundCube, Wordpress, WinLIRC, WHS2011, MediaPortal, XBMC

  3. #3
    Registriert seit
    Aug 2009
    Beiträge
    184

    Hallo Michael,

    mit einer Float Variable funktioniert es jetzt einwandfrei.

    Vielen Dank für den Link mit der Erklärung.

    Hein09