Thema geschlossen
Ergebnis 1 bis 9 von 9
  1. #1
    Registriert seit
    Dec 2006
    Ort
    78056 Villingen-Schwenningen
    Beiträge
    213

    Standard Update Symcon 5.0 (Beta) auf 5.1 (Testing) --> Webfront nicht mehr erreichbar.

    Nach dem Update von IP-Symcon 5.0, Ubuntu, 11.03.2019, 2c04bde1199 auf die Testing ist
    http://ip:3777 und ...3777/console nicht mehr erreichbar.

    Screen-Video: Symcon 5 0 zu 5 1 keine Funktion nach Update - YouTube


    root@ips:~# apt update
    OK:1 Index of /ubuntu bionic InRelease
    Holen:2 Index of /ubuntu bionic-security InRelease [88,7 kB]
    Holen:3 Index of /ubuntu bionic-updates InRelease [88,7 kB]
    Holen:4 Index of /ubuntu bionic-backports InRelease [74,6 kB]
    Holen:5 http://apt.symcon.de testing InRelease [1.161 B]
    Holen:6 http://apt.symcon.de testing/ubuntu amd64 Packages [457 B]
    Es wurden 254 kB in 1 s geholt (384 kB/s).
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    Aktualisierung für 1 Paket verfügbar. Führen Sie »apt list --upgradable« aus, um es anzuzeigen.
    root@ips:~# apt dist-upgrade
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    Paketaktualisierung (Upgrade) wird berechnet... Fertig
    Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
    libboost-date-time1.65.1 libboost-filesystem1.65.1 libboost-system1.65.1 libgit2-26
    libgmpxx4ldbl libhttp-parser2.7.1 libjpeg-turbo8 libjpeg8 libmcrypt4
    Verwenden Sie »apt autoremove«, um sie zu entfernen.
    Die folgenden Pakete werden aktualisiert (Upgrade):
    symcon
    1 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
    Es müssen 49,4 MB an Archiven heruntergeladen werden.
    Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren? [J/n] j
    Holen:1 http://apt.symcon.de testing/ubuntu amd64 symcon amd64 5.1-3122 [49,4 MB]
    Es wurden 49,4 MB in 3 s geholt (16,7 MB/s).
    (Lese Datenbank ... 104105 Dateien und Verzeichnisse sind derzeit installiert.)
    Vorbereitung zum Entpacken von .../symcon_5.1-3122_amd64.deb ...
    IP-Symcon is running.
    Stopping...
    IP-Symcon stopped
    Entpacken von symcon (5.1-3122) über (5.0-2705) ...
    symcon (5.1-3122) wird eingerichtet ...
    IP-Symcon is not running.
    Starting...
    IP-Symcon started with PID 6045
    Trigger für ureadahead (0.100.0-20) werden verarbeitet ...
    Trigger für systemd (237-3ubuntu10.20) werden verarbeitet ...
    Trigger für man-db (2.8.3-2ubuntu0.1) werden verarbeitet ...

    Jetzt sollte eigentlich die 5.1 Version laufen.
    service symcon status zeigt auch, dass Symcon läuft, aber das Web-Frontend scheint tot zu sein.

  2. #2
    Registriert seit
    Dec 2006
    Ort
    78056 Villingen-Schwenningen
    Beiträge
    213

    Auch Deinstallieren (apt purge symcon) der 5.0 und Neuinstallieren der 5.1 hat das selbe Ergebnis.

    5.1 Testing deinstalliert, 5.0 Beta wieder installiert --> Funktioniert wieder.

  3. #3
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    22,146

    Hattest du vielleicht auch mal ins logfile von IPS geschaut? Dort gibt es meistens Hinweise, wenn beim Start etwas nicht glatt läuft.

    paresy

  4. #4
    Registriert seit
    Dec 2006
    Ort
    78056 Villingen-Schwenningen
    Beiträge
    213

    Im Log steht einiges, aber ich kann nicht erkennen, wo IPS nicht mehr will.
    Es sind einige Fehlermeldungen von Modulen dabei, die dürften bei anderen Anwendern aber auch installiert sein und dort evtl. die selben Probleme verursachen.

    Hier das Log zum Download:
    Von der 5.1 https://cloud.2hv.de/s/RkxxaR5rbrRYm87
    zum Vergleich
    Von der 5.0 https://cloud.2hv.de/s/iC9bjza7pYNDeYH

  5. #5
    Registriert seit
    Jun 2012
    Ort
    House of Dragons @ Lübeck
    Beiträge
    9,585

    Das Modul IPS2GPIO nutzt die phpseclib.
    Diese bringt leider aktuell PHP und IPS unter Ubuntu zum Absturz.
    Michael
    on Win7VM (ESXi): I5, 24GB RAM, HW-RAID5, 3xSat | HW: CCU + 123 Geräte (506ch), EM1000, CUL, 1Wire, XBee, ELRO 433MHz, FritzBox Cable, Android Phone + Tablet, Samsung C-Serie TV +SamyGo-Ext, Onkyo NR| SW: IPS, Apache2(mod_ssl/PHP), MySQL, hMailServer, PRTG, Rising AV, Piwik, RoundCube, Wordpress, WinLIRC, WHS2011, MediaPortal, XBMC

  6. #6
    Registriert seit
    Dec 2006
    Ort
    78056 Villingen-Schwenningen
    Beiträge
    213

    Bingo !!!
    Danke !!!

    Habe zum Test die Instanzen der Raspi-Anbindung per IPS2GPIO_1Wire gelöscht und nun klappt der Update einwandfrei.

    Gibt es eine Alternative zu IPS2GPIO?
    Ich kann nur schwer darauf verzichten, da wir ca. 15 Raspis mit DS18b20 per IPS auslesen.....

    Ich verlinke den Thread mal zum GPIO Modul Thread.....

  7. #7
    Registriert seit
    Jun 2012
    Ort
    House of Dragons @ Lübeck
    Beiträge
    9,585

    Entweder erstmal nicht IPS unter Ubuntu nutzen oder warten bis der Bug aus PHP weg ist...
    Michael
    on Win7VM (ESXi): I5, 24GB RAM, HW-RAID5, 3xSat | HW: CCU + 123 Geräte (506ch), EM1000, CUL, 1Wire, XBee, ELRO 433MHz, FritzBox Cable, Android Phone + Tablet, Samsung C-Serie TV +SamyGo-Ext, Onkyo NR| SW: IPS, Apache2(mod_ssl/PHP), MySQL, hMailServer, PRTG, Rising AV, Piwik, RoundCube, Wordpress, WinLIRC, WHS2011, MediaPortal, XBMC

  8. #8
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    22,146

    Danke. Ich bin an dem Fehler noch dran...

    Weiter geht es hier: IP-Symcon Community Forum

    paresy
    Geändert von paresy (21.04.19 um 18:17 Uhr)

  9. #9
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    22,146

    @juergen852: Magst du mir in dem anderen Thema kurz ein paar Details zu deinem Ubuntu und deinem System darunter nennen? (z.B. Intel Prozessor? Native oder VM? Vielleicht sogar ESXi drunter?)

    IP-Symcon Community Forum

    paresy

Ähnliche Themen

  1. Raspberry: Update auf 4.4 - Symcon nicht erreichbar
    Von hanspeda417 im Forum Allgemeine Diskussion
    Antworten: 2
    Letzter Beitrag: 24.12.17, 15:28
  2. IPSModuleManagementGUI nach Update nicht mehr erreichbar
    Von Casimir im Forum Allgemeine Diskussion
    Antworten: 6
    Letzter Beitrag: 08.09.15, 20:50
  3. Webfront ist nicht mehr erreichbar.
    Von eierfuchs im Forum WebFront
    Antworten: 7
    Letzter Beitrag: 13.10.09, 17:47