+ Antworten
Ergebnis 1 bis 2 von 2
  1. #1
    Registriert seit
    Jun 2020
    Beiträge
    54

    Standard Autostart der HaBridge

    Hallo,
    versuche bereits seit Stunden folgendes Problem mit dem RaspberryPi zu lösen.
    Ich habe die HaBridge nach folgendem Schema installiert, aber ich kann die Bridge nicht mit "sudo systemctl start habridge.service" starten sondern nur mit "sudo /usr/bin/java -jar -Dserver.port=8008 /services/haBridge/ha-bridge-5.3.0.jar"...
    Was läuft da schief? Somit funktioniert der Autostart auch nicht...

    Java11:
    sudo apt update
    sudo apt install default-jdk

    sudo su -
    cd /
    sudo mkdir services
    cd services
    sudo mkdir haBridge
    cd haBridge
    wget https://github.com/bwssytems/ha-brid...idge-5.3.0.jar
    cd /etc/systemd/system
    sudo nano habridge.service

    In dieser Datei für den Autostart folgenden Code einfügen:

    [Unit]
    Description=HA Bridge
    Wants=network.target
    After=network.target
    [Service]
    Type=simple
    ExecStart= /usr/bin/java -jar -Dconfig.file=/services/haBridge/data/habridge.config /services/haBridge/ha-bridge-5.3.0.jar
    [Install]
    WantedBy=multi-user.target

    sudo systemctl daemon-reload
    sudo /usr/bin/java -jar -Dserver.port=8008 /services/haBridge/ha-bridge-5.3.0.jar

    Folgende Pfade unter dem Reiter "Bridge Control" anpassen und mit Save speichern:
    Configuration Path and File: /services/haBridge/data/habridge.config
    Device DB Path and File: /services/haBridge/data/device.db
    Zurück zu PuTTY und die geöffnete Ha-Bridge mit STRG+C beenden

    sudo chown pi:www-data data -R
    sudo chmod 775 data -R
    sudo systemctl enable habridge.service
    sudo systemctl start habridge.service

  2. #2
    Registriert seit
    Sep 2018
    Ort
    Gsiberg
    Beiträge
    148

    Soweit ich mich erinnern kann legt die habridge die "habridge.config" standardmässig nach /data/*.
    Wenn du die Einstellungen nach dem manuellen Start per Bash gemacht hast, könnte es sein das die habridge.config dort hingelegt wurde? Eventuell nach "/services/haBridge/data/habridge.config" kopieren..
    Was sagt systemd beim Start ?

    Oder einfach mal root aktivieren,
    Code:
    sudo su
    passwd
    und nach dieser Anleitung gehen ?
    Hatte zumindest bei mir ohne Probleme funktioniert.
    IPS v5.x Unlimited auf Debian-10 (KVM-Guest)
    HomeMatic@CCU3 | BlueIris(MQTT) | Unifi | LogitechHub | Squeezebox | Enigma2 | Echo | WIMAXIT-TouchDisplay am NUC
    Symcon Module: CCUBackup | GeraeteStatus | Nmap

Ähnliche Themen

  1. Autostart von IPS
    Von hardlog im Forum Allgemeine Diskussion
    Antworten: 5
    Letzter Beitrag: 29.10.16, 07:49
  2. Autostart
    Von TomW im Forum Dashboard
    Antworten: 19
    Letzter Beitrag: 23.02.11, 19:26
  3. Autostart-Skript
    Von tkaufmann im Forum Allgemeine Diskussion (2.x/3.x)
    Antworten: 2
    Letzter Beitrag: 13.01.09, 11:32
  4. Autostart Skript
    Von wgreipl im Forum Allgemeine Diskussion (2.x/3.x)
    Antworten: 3
    Letzter Beitrag: 29.10.08, 06:17
  5. Autostart
    Von wasserflo im Forum Allgemeine Diskussion
    Antworten: 0
    Letzter Beitrag: 05.08.05, 09:20