+ Antworten
Seite 1 von 3 1 2 3 LetzteLetzte
Ergebnis 1 bis 10 von 23
  1. #1
    Registriert seit
    Apr 2017
    Ort
    Hilter
    Beiträge
    35

    Standard Nach Update von 5.4 --> 5.5 konnte bekannten Ordnerpfad nicht lesen

    Hallo,
    nach dem Update von 5.4 --> 5.5 kommt unter Win 7 Pro die Fehlermeldung im Bild, wenn ich auf das Tray-Icon (mit Links- oder Rechtsklick) klicke.
    Nach dem Klick auf OK passiert nichts.
    Ansonsten funktioniert, in der Kürze der Zeit betrachtet, alles.
    Woran liegt das?

    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Symcon55_1.png 
Hits:	132 
Größe:	7.7 KB 
ID:	55774

  2. #2
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    24,143

    Welche Version von Windows 7 hast du genau? Ist dies vollständig gepatched?

    Wir versuchen folgenden Pfad unter Windows zu finden und scheinbar schlägt dies fehl: FOLDERID_UserProgramFiles
    Laut Windows API soll es diesen aber in Windows 7 definitiv geben.

    Kannst du die Pro-Konsole auf Windows 7 überhaupt installieren? Wenn ja, findest du wo diese Installiert wird?

    paresy

  3. #3
    Registriert seit
    Apr 2017
    Ort
    Hilter
    Beiträge
    35

    Hey,
    habe das Win 7 auf einer VM meiner Syno Diskstation.
    Win Version und Update-Status auf den Bildern.
    Die Pro-Konsole benötige ich auf der VM nicht. Hatte diese daher nicht darauf installiert.
    Aber nach Installation der Pro-Konsole startet diese nun bei Linksklick auf das Tray-Icon. Und der Rechtsklick ist nun auch wie gewohnt.
    Heißt das, die Symcon 5.5 benötigt immer auch die Pro-Konsole?

    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	WinVer.png 
Hits:	42 
Größe:	11.6 KB 
ID:	55780

    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	WinUpDate.png 
Hits:	49 
Größe:	49.9 KB 
ID:	55781

    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	RDPKonsole.png 
Hits:	44 
Größe:	49.0 KB 
ID:	55782

  4. #4
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    24,143

    Ich befürchte eher, dass Windows den fehlenden Ordner durch die Installation hinzugefügt hat... Mich wundert, dass die offizielle API von Windows den Ordner nicht automatisch erstellt, wenn wir diesen Anfragen.

    paresy

  5. #5
    Registriert seit
    Apr 2017
    Ort
    Hilter
    Beiträge
    35

    Standard Seit Update hat sich der Server-Dienst schon 2x selbst beendet

    Hallo,
    ich habe da noch einen kleinen Nachschlag.
    Seit dem Update von 5.4 --> 5.5 hat sich der Symcon Server Dienst schon 2x selbst beendet.
    Wenn ich ihn dann über das Tray Icon "Dienst starten" erneut starten möchte, dann funktioniert das nicht. Und dann kommt das LogFile:
    Code:
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | Creating...
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | Platform: Windows x64
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | Version: 5.5
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | Revision: e7d6ee85b48e43d0a2ed7874d6a00284620f7fa0
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | Build: 10/15/20
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | WorkingDir: C:\ProgramData\Symcon\
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | SystemDir: C:\IP-Symcon\
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | LogDir: C:\ProgramData\Symcon\logs\
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | Boost Version: 1_73
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | cURL Version: libcurl/7.71.1 OpenSSL/1.1.1h
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | Git2 Version: 1.0.1
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | SSH Version: 0.9.5
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | ZLIB Version: 1.2.11
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | RapidJSON Version: 1.1.0
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | OpenSSL Version: OpenSSL 1.1.1h  22 Sep 2020
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | OpenSSL CertDir: C:\IP-Symcon\
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | OpenSSL CertFile: C:\IP-Symcon\cacert.pem
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | PHP Version: 7.4.11.0
    10/19/20 19:26:13 | 00000 | MESSAGE | Kernel               | Initializing...
    10/19/20 19:26:13 | 00000 | MESSAGE | LocalePool           | Creating...
    10/19/20 19:26:13 | 00000 | MESSAGE | LocalePool           | Erkanntes Gebietsschema: de_DE
    19.10.2020 19:26:13 | 00000 | MESSAGE | LicensePool          | Erstelle...
    19.10.2020 19:26:21 | 00000 | MESSAGE | Settings             | Erstelle...
    19.10.2020 19:26:21 | 00000 | MESSAGE | Settings             | Lade Einstellungen...
    19.10.2020 19:26:21 | 00000 | MESSAGE | ObjectManager        | Erstelle...
    19.10.2020 19:26:21 | 00000 | MESSAGE | ObjectManager        | Erstelle Root-Kategorie...
    19.10.2020 19:26:21 | 00000 | MESSAGE | CategoryManager      | Erstelle...
    19.10.2020 19:26:22 | 00000 | MESSAGE | VariableManager      | Erstelle...
    19.10.2020 19:26:22 | 00000 | MESSAGE | InstanceManager      | Erstelle...
    19.10.2020 19:26:22 | 00000 | MESSAGE | ScriptManager        | Erstelle...
    19.10.2020 19:26:22 | 00000 | MESSAGE | EventManager         | Erstelle...
    19.10.2020 19:26:22 | 00000 | MESSAGE | MediaManager         | Erstelle...
    19.10.2020 19:26:22 | 00000 | MESSAGE | LinkManager          | Erstelle...
    19.10.2020 19:26:22 | 00000 | MESSAGE | ModuleLoader         | Erstelle...
    19.10.2020 19:26:23 | 00000 | MESSAGE | FlowHandler          | Erstelle...
    19.10.2020 19:26:23 | 00000 | MESSAGE | SyncHandler          | Erstelle...
    19.10.2020 19:26:23 | 00000 | MESSAGE | ProfilePool          | Erstelle...
    19.10.2020 19:26:23 | 00000 | MESSAGE | ScriptEngine         | Erstelle...
    19.10.2020 19:26:24 | 00000 | MESSAGE | ScriptEngine         | Erkannte Zeitzone: Europe/Berlin
    Anschließend kann ich den Dienst erneut starten, und der Server funktioniert wieder.
    Anmerkung: Seit dem Update habe ich auf dem Symcon-Server genau nix gemacht und auch sonst nix geändert. Symcon 5.4 und drunter sind nie (zumindest kann ich mich nicht daran erinnern) abgestürzt.

  6. #6
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    24,143

    Hast du uns entsprechend Absturzberichte zugesendet?

    paresy

  7. #7
    Registriert seit
    Apr 2017
    Ort
    Hilter
    Beiträge
    35

    Ne, wie mache ich das?

  8. #8
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    24,143

    Du müsstest, wenn IP-Symcon abgestützt ist, nach dem Neustart in der Konsole ein neues Widget sehen, welches Absturzberichten senden will. Gibt es die?

    paresy

  9. #9
    Registriert seit
    Apr 2017
    Ort
    Hilter
    Beiträge
    35

    Leider nein.
    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Konsole.png 
Hits:	24 
Größe:	147.1 KB 
ID:	55818

  10. #10
    Registriert seit
    Feb 2005
    Ort
    Lübeck
    Beiträge
    24,143

    Hast du mal in den Logfile geschaut, was quasi die letzten Zeilen vor dem Absturz gewesen sind?
    Es ist nämlich eher selten, dass ein Absturz passiert, es aber keinen Bericht dazu gibt.

    paresy

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 30.08.19, 13:22
  2. Symcon startet nicht mehr nach update von 5.0 auf 5.1
    Von Andisch im Forum Allgemeine Diskussion
    Antworten: 2
    Letzter Beitrag: 08.05.19, 14:57
  3. IPS V2 startet nicht mehr nach Update einspielen von Gestern
    Von sanman im Forum Allgemeine Diskussion (2.x/3.x)
    Antworten: 4
    Letzter Beitrag: 08.12.08, 11:54